cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5696
Views
1
Helpful
16
Replies

Issue to connect to MDS switches

arnaudch
Level 1
Level 1

Dear all,

 

In order to setup an architecture, I am trying to configure a LAB with 2 MDS switches 9148 and a FibreChannel 8 tester.

That works perfectly if I use only 1 switch (alone 192.168.1.87). My Tester is connected between port fc1/1 and fc1/2.

I can monitor the traffic on port fc1/3. Everything is fine.

 

But I have trouble to connect the both MDS switches together.

The goal would be to allow the traffic between the MDS (192.168.1.87) port fc1/1 and the MDS (192.168.1.88) port fc1/2 using a trunk on fc1/15 (for both switches)

 

The traffic is not going through.

Please find bellow the both configuration. I'm sure it's just a small mistake on the configuration

 

MDS 192.168.1.87

 

!Command: show running-config
!Time: Thu Sep 21 17:52:13 2017

version 6.2(15)
power redundancy-mode redundant

feature npiv

role name default-role
  description This is a system defined role and applies to all users.
  rule 5 permit show feature environment
  rule 4 permit show feature hardware
  rule 3 permit show feature module
  rule 2 permit show feature snmp
  rule 1 permit show feature system
username admin password 5 $1$DkUa35Ey$3qxuSy1ei3pKzkVsTSC7n.  role network-admin
no password strength-check
ip domain-lookup
ip host 192.168.1.87  192.168.1.87
aaa group server radius radius
snmp-server user admin network-admin auth md5 0x132b8a08d2d0f6fe3ec160ea631a83d9 priv 0x132b8a08d2d0f6fe3ec160ea631a8
3d9 localizedkey
rmon event 1 log trap public description FATAL(1) owner PMON@FATAL
rmon event 2 log trap public description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 log trap public description ERROR(3) owner PMON@ERROR
rmon event 4 log trap public description WARNING(4) owner PMON@WARNING
rmon event 5 log trap public description INFORMATION(5) owner PMON@INFO

vsan database
  vsan 55 name "LABVSAN"
fcdomain fcid database
  vsan 1 wwn 10:00:00:00:00:01:00:01 fcid 0xd50000 dynamic
  vsan 1 wwn 10:00:00:00:00:02:00:01 fcid 0xd50100 dynamic
  vsan 1 wwn 20:02:54:7f:ee:c6:77:18 fcid 0xd50200 area dynamic
  vsan 1 wwn 20:01:54:7f:ee:c6:77:18 fcid 0xd50300 area dynamic
  vsan 55 wwn 10:00:00:00:00:01:00:01 fcid 0x6a0000 dynamic
  vsan 55 wwn 10:00:00:00:00:02:00:01 fcid 0x6a0100 dynamic


interface mgmt0
  ip address 192.168.1.87 255.255.255.0
vsan database
  vsan 55 interface fc1/1
  vsan 55 interface fc1/2
  vsan 55 interface fc1/3
  vsan 55 interface fc1/4
  vsan 55 interface fc1/15

line console
line vty
boot kickstart bootflash:/m9100-s3ek9-kickstart-mz.6.2.15.bin
boot system bootflash:/m9100-s3ek9-mz.6.2.15.bin
interface fc1/1
  switchport mode F
interface fc1/2
  switchport mode F
interface fc1/3
  switchport mode SD
interface fc1/4
  switchport mode SD
interface fc1/5
interface fc1/6
interface fc1/7
interface fc1/8
interface fc1/9
interface fc1/10
interface fc1/11
interface fc1/12
interface fc1/13
interface fc1/14
interface fc1/15
  switchport mode E
interface fc1/16
interface fc1/17
interface fc1/18
interface fc1/19
interface fc1/20
interface fc1/21
interface fc1/22
interface fc1/23
interface fc1/24
interface fc1/25
interface fc1/26
interface fc1/27
interface fc1/28
interface fc1/29
interface fc1/30
interface fc1/31
interface fc1/32
interface fc1/33
interface fc1/34
interface fc1/35
interface fc1/36
interface fc1/37
interface fc1/38
interface fc1/39
interface fc1/40
interface fc1/41
interface fc1/42
interface fc1/43
interface fc1/44
interface fc1/45
interface fc1/46
interface fc1/47
interface fc1/48
!Active Zone Database Section for vsan 55
zone name LAB vsan 55
    member pwwn 10:00:00:00:00:01:00:01
    member pwwn 10:00:00:00:00:02:00:01

zoneset name zoneset_vsan55 vsan 55
    member LAB

zoneset activate name zoneset_vsan55 vsan 55
do clear zone database vsan 55
!Full Zone Database Section for vsan 55
fcalias name LABALIAS vsan 55
    member pwwn 10:00:00:00:00:01:00:01

fcalias name LABALIAS2 vsan 55
    member pwwn 10:00:00:00:00:02:00:01

zone name LAB vsan 55
    member pwwn 10:00:00:00:00:01:00:01
    member pwwn 10:00:00:00:00:02:00:01
    member fwwn 20:0f:54:7f:ee:a7:c8:e0
    member fwwn 20:0f:54:7f:ee:c6:77:18
    member fcalias LABALIAS
    member fcalias LABALIAS2

zoneset name zoneset_vsan55 vsan 55
    member LAB



interface fc1/1
  port-license acquire
  no shutdown

interface fc1/2
  port-license acquire
  no shutdown

interface fc1/3
  port-license acquire
  no shutdown

interface fc1/4
  port-license acquire
  no shutdown

interface fc1/5
  port-license acquire

interface fc1/6
  port-license acquire

interface fc1/7
  port-license acquire

interface fc1/8
  port-license acquire

interface fc1/9
  port-license acquire

interface fc1/10
  port-license acquire

interface fc1/11
  port-license acquire

interface fc1/12
  port-license acquire

interface fc1/13
  switchport trunk allowed vsan 55
  port-license acquire

interface fc1/14
  port-license acquire

interface fc1/15
  switchport trunk allowed vsan 55
  port-license acquire
  no shutdown

interface fc1/16
  port-license acquire

interface fc1/17

interface fc1/18

interface fc1/19

interface fc1/20

interface fc1/21

interface fc1/22

interface fc1/23

interface fc1/24

interface fc1/25

interface fc1/26

interface fc1/27

interface fc1/28

interface fc1/29

interface fc1/30

interface fc1/31

interface fc1/32

interface fc1/33

interface fc1/34

interface fc1/35

interface fc1/36

interface fc1/37

interface fc1/38

interface fc1/39

interface fc1/40

interface fc1/41

interface fc1/42

interface fc1/43

interface fc1/44

interface fc1/45

interface fc1/46

interface fc1/47

interface fc1/48
ip default-gateway 192.168.1.1
span session 1
  destination interface fc1/3
  source interface fc1/1 rx

 

 

MDS 192.168.1.88

!Command: show running-config
!Time: Thu Sep 21 15:22:40 2017

version 6.2(15)
power redundancy-mode redundant

feature npiv

role name default-role
  description This is a system defined role and applies to all users.
  rule 5 permit show feature environment
  rule 4 permit show feature hardware
  rule 3 permit show feature module
  rule 2 permit show feature snmp
  rule 1 permit show feature system
username admin password 5 $1$i.olFCUt$Drx3XjKZ5kqhBpckYDmkp1  role network-admin
						  
ip domain-lookup
ip host 192.168.1.88  192.168.1.88
aaa group server radius radius
snmp-server user admin network-admin auth md5 0x76942a05ad356714662f3fb384f4d59d priv 0x76942a05ad356714662f3fb384f4d
59d localizedkey
rmon event 1 log trap public description FATAL(1) owner PMON@FATAL
rmon event 2 log trap public description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 log trap public description ERROR(3) owner PMON@ERROR
rmon event 4 log trap public description WARNING(4) owner PMON@WARNING
rmon event 5 log trap public description INFORMATION(5) owner PMON@INFO

vsan database
  vsan 55 name "LABVSAN"
fcdomain fcid database
														  
														  
															   
															   
  vsan 55 wwn 10:00:00:00:00:01:00:01 fcid 0x070000 dynamic
														   


interface mgmt0
  ip address 192.168.1.88 255.255.255.0
vsan database
  vsan 55 interface fc1/1
						 
						 
						 
  vsan 55 interface fc1/15

line console
line vty
boot kickstart bootflash:/m9100-s3ek9-kickstart-mz.6.2.15.bin
boot system bootflash:/m9100-s3ek9-mz.6.2.15.bin
interface fc1/1
  switchport mode F
interface fc1/2
  switchport mode F
interface fc1/3
  switchport mode SD
interface fc1/4
  switchport mode SD
interface fc1/5
interface fc1/6
interface fc1/7
interface fc1/8
interface fc1/9
interface fc1/10
interface fc1/11
interface fc1/12
interface fc1/13
interface fc1/14
interface fc1/15
				   
interface fc1/16
interface fc1/17
interface fc1/18
interface fc1/19
interface fc1/20
interface fc1/21
interface fc1/22
interface fc1/23
interface fc1/24
interface fc1/25
interface fc1/26
interface fc1/27
interface fc1/28
interface fc1/29
interface fc1/30
interface fc1/31
interface fc1/32
interface fc1/33
interface fc1/34
interface fc1/35
interface fc1/36
interface fc1/37
interface fc1/38
interface fc1/39
interface fc1/40
interface fc1/41
interface fc1/42
interface fc1/43
interface fc1/44
interface fc1/45
interface fc1/46
interface fc1/47
interface fc1/48
!Active Zone Database Section for vsan 55
zone name LAB vsan 55
    member pwwn 10:00:00:00:00:01:00:01
									   

zoneset name zoneset_vsan55 vsan 55
    member LAB

zoneset activate name zoneset_vsan55 vsan 55
do clear zone database vsan 55
!Full Zone Database Section for vsan 55
fcalias name LABALIAS vsan 55
    member pwwn 10:00:00:00:00:01:00:01

fcalias name LABALIAS2 vsan 55
    member pwwn 10:00:00:00:00:02:00:01

zone name LAB vsan 55
    member pwwn 10:00:00:00:00:01:00:01
    member pwwn 10:00:00:00:00:02:00:01
    member fcid 0x6a0100
    member fcid 0x070000
    member fcalias LABALIAS
    member fcalias LABALIAS2

zoneset name zoneset_vsan55 vsan 55
    member LAB



interface fc1/1
  port-license acquire
  no shutdown

interface fc1/2
  port-license acquire
  no shutdown

interface fc1/3
  port-license acquire
			 

interface fc1/4
  port-license acquire
			 

interface fc1/5
  port-license acquire

interface fc1/6
  port-license acquire

interface fc1/7
  port-license acquire

interface fc1/8
  port-license acquire

interface fc1/9
  port-license acquire

interface fc1/10
  port-license acquire

interface fc1/11
  port-license acquire

interface fc1/12
  port-license acquire

interface fc1/13
  no switchport trunk allowed  vsan all
  port-license acquire

interface fc1/14
  port-license acquire

interface fc1/15
  switchport trunk allowed vsan 55
  port-license acquire
  no shutdown

interface fc1/16
  port-license acquire

interface fc1/17

interface fc1/18

interface fc1/19

interface fc1/20

interface fc1/21

interface fc1/22

interface fc1/23

interface fc1/24

interface fc1/25

interface fc1/26

interface fc1/27

interface fc1/28

interface fc1/29

interface fc1/30

interface fc1/31

interface fc1/32

interface fc1/33

interface fc1/34

interface fc1/35

interface fc1/36

interface fc1/37

interface fc1/38

interface fc1/39

interface fc1/40

interface fc1/41

interface fc1/42

interface fc1/43

interface fc1/44

interface fc1/45

interface fc1/46

interface fc1/47

interface fc1/48
ip default-gateway 192.168.1.1

switch#
						   

 

On MDS 192.168.1.88 everything looks fine and UP

switch(config-zone)# do sh int brie

-------------------------------------------------------------------------------
Interface  Vsan   Admin  Admin   Status       SFP    Oper  Oper   Port
                  Mode   Trunk                       Mode  Speed  Channel
                         Mode                              (Gbps)
-------------------------------------------------------------------------------
fc1/1      55     F      on      up           swl   F      8      --
fc1/2      1      F      on      notConnected swl    --    --     --
fc1/3      1      SD     --      down         swl    --    --     --
fc1/4      1      SD     --      down         swl    --    --     --
fc1/5      1      auto   on      down         swl    --    --     --
fc1/6      1      auto   on      down         swl    --    --     --
fc1/7      1      auto   on      down         swl    --    --     --
fc1/8      1      auto   on      down         swl    --    --     --
fc1/9      1      auto   on      down         swl    --    --     --
fc1/10     1      auto   on      down         swl    --    --     --
fc1/11     1      auto   on      down         swl    --    --     --
fc1/12     1      auto   on      down         swl    --    --     --
fc1/13     1      auto   on      down         swl    --    --     --
fc1/14     1      auto   on      down         swl    --    --     --
fc1/15     55     E      on      trunking     swl   TE     8      --
fc1/16     1      auto   on      down         swl    --    --     --
fc1/17     1      auto   on      sfpAbsent    --     --    --     --
fc1/18     1      auto   on      sfpAbsent    --     --    --     --
fc1/19     1      auto   on      sfpAbsent    --     --    --     --
fc1/20     1      auto   on      sfpAbsent    --     --    --     --
fc1/21     1      auto   on      sfpAbsent    --     --    --     --
fc1/22     1      auto   on      sfpAbsent    --     --    --     --
fc1/23     1      auto   on      sfpAbsent    --     --    --     --
fc1/24     1      auto   on      sfpAbsent    --     --    --     --
fc1/25     1      auto   on      sfpAbsent    --     --    --     --
fc1/26     1      auto   on      sfpAbsent    --     --    --     --
fc1/27     1      auto   on      sfpAbsent    --     --    --     --
fc1/28     1      auto   on      sfpAbsent    --     --    --     --
fc1/29     1      auto   on      sfpAbsent    --     --    --     --
fc1/30     1      auto   on      sfpAbsent    --     --    --     --
fc1/31     1      auto   on      sfpAbsent    --     --    --     --
fc1/32     1      auto   on      sfpAbsent    --     --    --     --
fc1/33     1      auto   on      sfpAbsent    --     --    --     --
fc1/34     1      auto   on      sfpAbsent    --     --    --     --
fc1/35     1      auto   on      sfpAbsent    --     --    --     --
fc1/36     1      auto   on      sfpAbsent    --     --    --     --
fc1/37     1      auto   on      sfpAbsent    --     --    --     --
fc1/38     1      auto   on      sfpAbsent    --     --    --     --
fc1/39     1      auto   on      sfpAbsent    --     --    --     --
fc1/40     1      auto   on      sfpAbsent    --     --    --     --
fc1/41     1      auto   on      sfpAbsent    --     --    --     --
fc1/42     1      auto   on      sfpAbsent    --     --    --     --
fc1/43     1      auto   on      sfpAbsent    --     --    --     --
fc1/44     1      auto   on      sfpAbsent    --     --    --     --
fc1/45     1      auto   on      sfpAbsent    --     --    --     --
fc1/46     1      auto   on      sfpAbsent    --     --    --     --
fc1/47     1      auto   on      sfpAbsent    --     --    --     --
fc1/48     1      auto   on      sfpAbsent    --     --    --     --

-------------------------------------------------------------------------------
Interface                Status                            Speed
                                                           (Gbps)
-------------------------------------------------------------------------------
sup-fc0                  up                                1

Any idea of the root cause ?

Thanks per advance for your reply.

Best regards

 

Arnaud

1 Accepted Solution

Accepted Solutions

The trunk interfaces don't need to be zoned !

Please delete all the zone's and zoneset on each switch and then start from scratch. 

The ISL should be up and working !

Then connect your end device and do a 

show flogi database vsan 55 on each switch

or

show fcns database vsan 55 on one switch

On one switch you do !!!!!!

configure the zone(s)

a zone should have 2 members (one initiator, one target)

the zone members should be based on pwwn, NOT fcid, or interface

then create a zoneset and add the zones

This configuration is automatically pushed over the ISL link to the other switch

then activate the zoneset

View solution in original post

16 Replies 16

Walter Dey
VIP Alumni
VIP Alumni

Hi Arnaud

On the second switch, I don't see 

interface fc1/15
  switchport mode E

Can you please post the output of this commands, for both switches

- show interface brief

- show interface fc 1 / 15

- sho vsan database membership

- show zoneset active .. vsan 55

I would advise you to use device alias, not fc-alias.

https://supportforums.cisco.com/t5/storage-networking/what-is-the-difference-between-quot-fcalias-quot-quot-device/td-p/1080710

 

Dear Walter,

Thanks for your reply.

Now both port fc1/15 are in switchport mode E, but the issue persists.

 

To avoid any confusion: my traffic gen is connected between sw192.168.1.87 fc1/2 and sw192.168.1.88 fc1/1

 

Please find bellow the results asked:

 

Hope that will help you.

 

Thanks per advance

 

Arnaud

 

192.168.1.87

switch# show interface brief

-------------------------------------------------------------------------------
Interface  Vsan   Admin  Admin   Status       SFP    Oper  Oper   Port
                  Mode   Trunk                       Mode  Speed  Channel
                         Mode                              (Gbps)
-------------------------------------------------------------------------------
fc1/1      55     F      on      notConnected swl    --    --     --
fc1/2      55     F      on      up           swl   F      8      --
fc1/3      55     SD     --      up           swl   SD     8      --
fc1/4      55     SD     --      up           swl   SD     8      --
fc1/5      1      auto   on      down         swl    --    --     --
fc1/6      1      auto   on      down         swl    --    --     --
fc1/7      1      auto   on      down         swl    --    --     --
fc1/8      1      auto   on      down         swl    --    --     --
fc1/9      1      auto   on      down         swl    --    --     --
fc1/10     1      auto   on      down         swl    --    --     --
fc1/11     1      auto   on      down         swl    --    --     --
fc1/12     1      auto   on      down         swl    --    --     --
fc1/13     1      auto   on      down         swl    --    --     --
fc1/14     1      auto   on      down         swl    --    --     --
fc1/15     55     E      on      trunking     swl   TE     8      --
fc1/16     1      auto   on      down         swl    --    --     --
fc1/17     1      auto   on      sfpAbsent    --     --    --     --
fc1/18     1      auto   on      sfpAbsent    --     --    --     --
fc1/19     1      auto   on      sfpAbsent    --     --    --     --
fc1/20     1      auto   on      sfpAbsent    --     --    --     --
fc1/21     1      auto   on      sfpAbsent    --     --    --     --
fc1/22     1      auto   on      sfpAbsent    --     --    --     --
fc1/23     1      auto   on      sfpAbsent    --     --    --     --
fc1/24     1      auto   on      sfpAbsent    --     --    --     --
fc1/25     1      auto   on      sfpAbsent    --     --    --     --
fc1/26     1      auto   on      sfpAbsent    --     --    --     --
fc1/27     1      auto   on      sfpAbsent    --     --    --     --
fc1/28     1      auto   on      sfpAbsent    --     --    --     --
fc1/29     1      auto   on      sfpAbsent    --     --    --     --
fc1/30     1      auto   on      sfpAbsent    --     --    --     --
fc1/31     1      auto   on      sfpAbsent    --     --    --     --
fc1/32     1      auto   on      sfpAbsent    --     --    --     --
fc1/33     1      auto   on      sfpAbsent    --     --    --     --
fc1/34     1      auto   on      sfpAbsent    --     --    --     --
fc1/35     1      auto   on      sfpAbsent    --     --    --     --
fc1/36     1      auto   on      sfpAbsent    --     --    --     --
fc1/37     1      auto   on      sfpAbsent    --     --    --     --
fc1/38     1      auto   on      sfpAbsent    --     --    --     --
fc1/39     1      auto   on      sfpAbsent    --     --    --     --
fc1/40     1      auto   on      sfpAbsent    --     --    --     --
fc1/41     1      auto   on      sfpAbsent    --     --    --     --
fc1/42     1      auto   on      sfpAbsent    --     --    --     --
fc1/43     1      auto   on      sfpAbsent    --     --    --     --
fc1/44     1      auto   on      sfpAbsent    --     --    --     --
fc1/45     1      auto   on      sfpAbsent    --     --    --     --
fc1/46     1      auto   on      sfpAbsent    --     --    --     --
fc1/47     1      auto   on      sfpAbsent    --     --    --     --
fc1/48     1      auto   on      sfpAbsent    --     --    --     --

-------------------------------------------------------------------------------
Interface                Status                            Speed
                                                           (Gbps)
-------------------------------------------------------------------------------
sup-fc0                  up                                1

-------------------------------------------------------------------------------
Interface               Status     IP Address         Speed     MTU
-------------------------------------------------------------------------------
mgmt0                    up         192.168.1.87/24    100 Mbps 1500
switch# show interface fc 1 / 15
fc1/15 is trunking (Not all VSANs UP on the trunk)
    Hardware is Fibre Channel, SFP is short wave laser w/o OFC (SN)
    Port WWN is 20:0f:54:7f:ee:c6:77:18
    Peer port WWN is 20:0f:54:7f:ee:a7:c8:e0
    Admin port mode is E, trunk mode is on
    snmp link state traps are enabled
    Port mode is TE
    Port vsan is 55
    Speed is 8 Gbps
    Rate mode is dedicated
    Transmit B2B Credit is 32
    Receive B2B Credit is 32
    B2B State Change Number is 14
    Receive data field Size is 2112
    Beacon is turned off
    admin fec state is down
    oper fec state is down
    Trunk vsans (admin allowed and active) (55)
    Trunk vsans (up)                       ()
    Trunk vsans (isolated)                 (55)
    Trunk vsans (initializing)             ()
    5 minutes input rate 0 bits/sec,0 bytes/sec, 0 frames/sec
    5 minutes output rate 0 bits/sec,0 bytes/sec, 0 frames/sec
      291 frames input,37104 bytes
        0 discards,0 errors
        0 invalid CRC/FCS,0 unknown class
        0 too long,0 too short
      297 frames output,26224 bytes
        0 discards,0 errors
      7 input OLS,7  LRR,1 NOS,11 loop inits
      13 output OLS,11 LRR, 4 NOS, 7 loop inits
      32 receive B2B credit remaining
      32 transmit B2B credit remaining
      28 low priority transmit B2B credit remaining
    Interface last changed at Thu Sep 21 17:35:30 2017

    Last clearing of "show interface" counters  :never

switch# sho vsan 55
vsan 55 information
         name:LABVSAN  state:active
         interoperability mode:default
         loadbalancing:src-id/dst-id/oxid
         operational state:up

switch# sho vsan 55 membership
vsan 55 interfaces:
    fc1/1             fc1/2             fc1/3             fc1/4
    fc1/15

switch# show zon
zone                   zone-attribute-group   zoneset
switch# show zoneset active  vsan 55
zoneset name zoneset_vsan55 vsan 55
  zone name LAB vsan 55
    pwwn 10:00:00:00:00:01:00:01
  * fcid 0x6a0100 [pwwn 10:00:00:00:00:02:00:01]
switch#

192.168.1.88

switch# sho int brie

-------------------------------------------------------------------------------
Interface  Vsan   Admin  Admin   Status       SFP    Oper  Oper   Port
                  Mode   Trunk                       Mode  Speed  Channel
                         Mode                              (Gbps)
-------------------------------------------------------------------------------
fc1/1      55     F      on      up           swl   F      8      --
fc1/2      1      F      on      notConnected swl    --    --     --
fc1/3      1      SD     --      down         swl    --    --     --
fc1/4      1      SD     --      down         swl    --    --     --
fc1/5      1      auto   on      down         swl    --    --     --
fc1/6      1      auto   on      down         swl    --    --     --
fc1/7      1      auto   on      down         swl    --    --     --
fc1/8      1      auto   on      down         swl    --    --     --
fc1/9      1      auto   on      down         swl    --    --     --
fc1/10     1      auto   on      down         swl    --    --     --
fc1/11     1      auto   on      down         swl    --    --     --
fc1/12     1      auto   on      down         swl    --    --     --
fc1/13     1      auto   on      down         swl    --    --     --
fc1/14     1      auto   on      down         swl    --    --     --
fc1/15     55     E      on      trunking     swl   TE     8      --
fc1/16     1      auto   on      down         swl    --    --     --
fc1/17     1      auto   on      sfpAbsent    --     --    --     --
fc1/18     1      auto   on      sfpAbsent    --     --    --     --
fc1/19     1      auto   on      sfpAbsent    --     --    --     --
fc1/20     1      auto   on      sfpAbsent    --     --    --     --
fc1/21     1      auto   on      sfpAbsent    --     --    --     --
fc1/22     1      auto   on      sfpAbsent    --     --    --     --
fc1/23     1      auto   on      sfpAbsent    --     --    --     --
fc1/24     1      auto   on      sfpAbsent    --     --    --     --
fc1/25     1      auto   on      sfpAbsent    --     --    --     --
fc1/26     1      auto   on      sfpAbsent    --     --    --     --
fc1/27     1      auto   on      sfpAbsent    --     --    --     --
fc1/28     1      auto   on      sfpAbsent    --     --    --     --
fc1/29     1      auto   on      sfpAbsent    --     --    --     --
fc1/30     1      auto   on      sfpAbsent    --     --    --     --
fc1/31     1      auto   on      sfpAbsent    --     --    --     --
fc1/32     1      auto   on      sfpAbsent    --     --    --     --
fc1/33     1      auto   on      sfpAbsent    --     --    --     --
fc1/34     1      auto   on      sfpAbsent    --     --    --     --
fc1/35     1      auto   on      sfpAbsent    --     --    --     --
fc1/36     1      auto   on      sfpAbsent    --     --    --     --
fc1/37     1      auto   on      sfpAbsent    --     --    --     --
fc1/38     1      auto   on      sfpAbsent    --     --    --     --
fc1/39     1      auto   on      sfpAbsent    --     --    --     --
fc1/40     1      auto   on      sfpAbsent    --     --    --     --
fc1/41     1      auto   on      sfpAbsent    --     --    --     --
fc1/42     1      auto   on      sfpAbsent    --     --    --     --
fc1/43     1      auto   on      sfpAbsent    --     --    --     --
fc1/44     1      auto   on      sfpAbsent    --     --    --     --
fc1/45     1      auto   on      sfpAbsent    --     --    --     --
fc1/46     1      auto   on      sfpAbsent    --     --    --     --
fc1/47     1      auto   on      sfpAbsent    --     --    --     --
fc1/48     1      auto   on      sfpAbsent    --     --    --     --

-------------------------------------------------------------------------------
Interface                Status                            Speed
                                                           (Gbps)
-------------------------------------------------------------------------------
sup-fc0                  up                                1

-------------------------------------------------------------------------------
Interface               Status     IP Address         Speed     MTU
-------------------------------------------------------------------------------
mgmt0                    up         192.168.1.88/24    100 Mbps 1500
switch# show int fc1/15
fc1/15 is trunking (Not all VSANs UP on the trunk)
    Hardware is Fibre Channel, SFP is short wave laser w/o OFC (SN)
    Port WWN is 20:0f:54:7f:ee:a7:c8:e0
    Peer port WWN is 20:0f:54:7f:ee:c6:77:18
    Admin port mode is E, trunk mode is on
    snmp link state traps are enabled
    Port mode is TE
    Port vsan is 55
    Speed is 8 Gbps
    Rate mode is dedicated
    Transmit B2B Credit is 32
    Receive B2B Credit is 32
    B2B State Change Number is 14
    Receive data field Size is 2112
    Beacon is turned off
    admin fec state is down
    oper fec state is down
    Trunk vsans (admin allowed and active) (55)
    Trunk vsans (up)                       ()
    Trunk vsans (isolated)                 (55)
    Trunk vsans (initializing)             ()
    5 minutes input rate 0 bits/sec,0 bytes/sec, 0 frames/sec
    5 minutes output rate 0 bits/sec,0 bytes/sec, 0 frames/sec
      369 frames input,30780 bytes
        0 discards,0 errors
        0 invalid CRC/FCS,0 unknown class
        0 too long,0 too short
      391 frames output,43976 bytes
        0 discards,0 errors
      11 input OLS,12  LRR,1 NOS,15 loop inits
      15 output OLS,10 LRR, 6 NOS, 6 loop inits
      32 receive B2B credit remaining
      32 transmit B2B credit remaining
      28 low priority transmit B2B credit remaining
    Interface last changed at Thu Sep 21 15:28:47 2017

    Last clearing of "show interface" counters  :never

switch# sho vsa 55
vsan 55 information
         name:LABVSAN  state:active
         interoperability mode:default
         loadbalancing:src-id/dst-id/oxid
         operational state:up

switch# sho vsa 55 mem
vsan 55 interfaces:
    fc1/1             fc1/15

switch# show zoneset active  vsan 55
zoneset name zoneset_vsan55 vsan 55
  zone name LAB vsan 55
  * fcid 0x070000 [pwwn 10:00:00:00:00:01:00:01]
switch#

 

 

Hi

I see that the trunking VSAN 55 is isolated ! 

Can you please post the output of the following command

switch# show interface fc1/15 trunk vsan 55

Most likely its a zoning merge issue. You could also try to

Shut the ISL link  between the 2 switches; then delete the whole zoning configuration on one switch; then enable the trunk again. The ISL should come up properly, and the zoneset should be pushed to the other switch. 

Hello Walter,

You're right, VSAN55 is isolated

Same result on both switches:

switch# show interface fc1/15 trunk vsan 55
fc1/15 is trunking
    Vsan 55 is down (Isolation due to zone merge failure)

How can I put it UP ?

Thanks per advance

Arnaud

Hi Arnoud

 

An E port is segmented (isolation due to zone merge failure) if the following conditions are true:

The active zone sets on the two switches differ from each other in terms of zone membership (provided there are zones at either side with identical names).

The active zone set on both switches contain a zone with the same name but with different zone members.

Step 2 Verify the zoning information, using the following commands on each switch:

show zone vsan vsan-id

show zoneset vsan vsan-id

Step 3 You can use two different approaches to resolve a zone merge failure by overwriting the zoning configuration of one switch with the other switch's configuration. This can be done with either of the following commands:

zoneset import interface interface-number vsan vsan-id

zoneset export interface interface-number vsan vsan-id

Hi Walter,

 

Now the vsan looks UP on both switches but the traffic is still not going through :(

switch(config-if)# show interface fc1/15 trunk vsan 55
fc1/15 is trunking
    Vsan 55 is up (None)

please post for both switches

show zoneset

show zoneset active

As asked:

Thanks again for your help

I much appreciate

 

192.168.1.87

switch(config-if)# show zoneset
zoneset name zoneset_vsan55 vsan 55
  zone name LAB vsan 55
    pwwn 10:00:00:00:00:01:00:01
    pwwn 10:00:00:00:00:02:00:01
    fcid 0x070000
    fcid 0x6a0100
    fcalias name LABALIAS vsan 55
      pwwn 10:00:00:00:00:01:00:01

    fcalias name LABALIAS2 vsan 55
      pwwn 10:00:00:00:00:02:00:01
switch(config-if)#
switch(config-if)# show zoneset active
zoneset name zoneset_vsan55 vsan 55
  zone name LAB vsan 55
  * fcid 0x070000 [pwwn 10:00:00:00:00:01:00:01]
switch(config-if)#

 

192.168.1.88

switch(config-if)# show zoneset
zoneset name zoneset_vsan55 vsan 55
  zone name LAB vsan 55
    pwwn 10:00:00:00:00:01:00:01
    pwwn 10:00:00:00:00:02:00:01
    fcid 0x6a0100
    fcid 0x070000
    fcalias name LABALIAS vsan 55
      pwwn 10:00:00:00:00:01:00:01

    fcalias name LABALIAS2 vsan 55
      pwwn 10:00:00:00:00:02:00:01
switch(config-if)# show zoneset active
zoneset name zoneset_vsan55 vsan 55
  zone name LAB vsan 55
  * fcid 0x070000 [pwwn 10:00:00:00:00:01:00:01]
switch(config-if)#

Your active zoneset just has one zone ! therefore no communication possible with only one device.

please do a flogi database vsan 55, on both switches; you should do at least 2 devices. then add a second zone and active the zoneset again !

You mean a "show flogi database vsan 55" command ?

So If I well understood, I need to create another zone behind the zoneset LAB for both switches, right ?

yes of course show flogi database vsan 55 !

yes, you have to add the additional zone to the zoneset; but only on one switch ! the zoneset activation will push everything over the ISL link to the other switch.

see eg. https://www.cisco.com/c/en/us/td/docs/switches/datacenter/mds9000/sw/4_1/configuration/guides/fm_4_1/fmguide/zone.pdf

Ok,

I've just added these following commands on both switches:

zone name TRUNK vsan 55
member interface fc1/15
zoneset name zoneset_vsan55 vsan 55
member TRUNK

But the issue persists

show flogi database vsan55 shows the same results:

192.168.1.87

switch# show flogi database vsan 55
--------------------------------------------------------------------------------
INTERFACE        VSAN    FCID           PORT NAME               NODE NAME
--------------------------------------------------------------------------------
fc1/2            55    0x6a0100  10:00:00:00:00:02:00:01 10:00:00:00:00:00:02:01

Total number of flogi = 1.

switch#

192.168.1.88

switch# show flogi database vsan 55
--------------------------------------------------------------------------------
INTERFACE        VSAN    FCID           PORT NAME               NODE NAME
--------------------------------------------------------------------------------
fc1/1            55    0x070000  10:00:00:00:00:01:00:01 10:00:00:00:00:00:01:01

Total number of flogi = 1.

switch#

Sorry, I had to do on 1 switch. Let me fix that

So I added the second zone only on switch 192.168.1.88.

I rebooted both of them but the issue stays

 

On 192.168.1.88

switch# show zoneset active
zoneset name zoneset_vsan55 vsan 55
  zone name LAB vsan 55
  * fcid 0x070000 [pwwn 10:00:00:00:00:01:00:01]
switch# show zoneset
zoneset name zoneset_vsan55 vsan 55
  zone name TRUNK vsan 55
    interface fc1/15 swwn 20:00:54:7f:ee:a7:c8:e0

  zone name LAB vsan 55
    pwwn 10:00:00:00:00:01:00:01
    pwwn 10:00:00:00:00:02:00:01
    fcid 0x6a0100
    fcid 0x070000
    fcalias name LABALIAS vsan 55
      pwwn 10:00:00:00:00:01:00:01

    fcalias name LABALIAS2 vsan 55
      pwwn 10:00:00:00:00:02:00:01
switch#

192.168.1.87

switch# show zoneset active
zoneset name zoneset_vsan55 vsan 55
  zone name LAB vsan 55
  * fcid 0x070000 [pwwn 10:00:00:00:00:01:00:01]
switch# show zoneset
zoneset name zoneset_vsan55 vsan 55
  zone name LAB vsan 55
    pwwn 10:00:00:00:00:01:00:01
    pwwn 10:00:00:00:00:02:00:01
    fcid 0x070000
    fcid 0x6a0100
    fcalias name LABALIAS vsan 55
      pwwn 10:00:00:00:00:01:00:01

    fcalias name LABALIAS2 vsan 55
      pwwn 10:00:00:00:00:02:00:01
switch#

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: