Showing results for 
Search instead for 
Did you mean: 

Password Recovery for MDS-9148 MutliLayer Fabric Switch


Good Day


I have 4 MDS 9148 Fiber Channel Switches I want to re-use for a development network. They are older of course, But we just need a system where I can connect a VNX 5500 to a few Servers. I have searched the internet and I have found the "procedure" however it does not work for me. I am able to get to the loader prompt by using "cntl - c" but cannot find anythinbg after that to help me. If it is easier I can actaully reset the whole switch back to factory defaults as long as that sets the password to blank or gives me the otion to change it.  Can anyone assist me in the proper way to either recover the password or reset the entire switch?

4 Replies 4

Kirk J
Cisco Employee
Cisco Employee

Checking on some previous cases, please try:


Step 2 Power cycle the switch.
Step 3 Press the Ctrl-] key sequence when the switch begins its Cisco NX-OS software boot sequence to enter the switch(boot)# prompt mode.

Step 4 Change to configuration mode.
switch(boot)# config terminal

Step 5 Issue the admin-password command to reset the administrator password.
switch(boot-config)# admin-password <new password>

Step 6 Exit to the EXEC mode.
switch(boot-config)# exit

Step 7 Issue the load command to load the Cisco NX-OS software.
switch(boot)# load bootflash:xxxxxxxxxxxxxxxxxxxxxxxx.bin   where xxxxxxxxxxxxxxx is the name of the nxos system file.

Step 8 Save the software configuration.

   switch#copy running-config startup-config






Believe it or not I tried that several times and could not get in. After you sent me this I tried it again and it worked. I feel pretty dumb. Now I have another question I may need to start a new thread. I am trying to run the Cisco Device Manager from the device through a browser, when I put the IP address in the browser It runs the "element manager" and brings up Device Manager 6.2(1). This was all after trying to get Java JRE 5 or 6 running i stead of 7. I had to actually go into Java config disable the "Java Plug-in"  enable the next generation java-plugin (requires browser restart" then when I clicked on the hyperlink "Cisco Device Manager"  embedded in the landing page for the Web GUI on the 9148. it asked me to save the file, so I did then opened it with the "jawas" exe in the jre 1.5.0_07 folder. it took a while to figure that out, but my switch is so old, it kept giving me a warning, I needed jre 1.5/6 to run it. anyway


Now when I put the device name in "MDSDR-9148-B" which is what it says at the prompt and the user name and password I get "Busy network, no route, unknown host or snmpd is unresponsive" what could be causing this? I know the info is correct


It will NOT let me perform a copy running-config startup-config. it is still at switch(boot)# and will not go to just switch#. How do I get to that switch root?

Looks like you skipped step 7, which is to load the OS from the bootflash.



Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers