cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3546
Views
10
Helpful
10
Replies
gassolini
Beginner

Unexpected prompt got through SoL for esxi

Hello,

I am trying to install the hyperflex platform.

All UCS FI configuration is successful but as soon as the ESXi configuration starts iget thuis error:

Server rack-unit-1 config failed
Reason: Unexpected prompt got through SoL for esxi

I am having a really har time find out what is going on because there is no reference anywhere about the Serial over lan interface.

How can I test it?

Is this configured on ESXi or on CIMC?

Can someone give me some advice on how to resolve this?

Thanks

Sandro

10 REPLIES 10
Kirk J
Cisco Employee

Greetings.

Can you confirm you are actually using the HX custom ISO, and not a generic  or Cisco OEM installer?

I.E. https://software.cisco.com/download/release.html?mdfid=286305809&flowid=81503&softwareid=286312290&release=6.0.U3patch1&relind=AVAILABLE&rellifecycle=&reltype=latest

Thanks,

Kirk...

Hello Kirk,

yes the esxi version is the one that comes bundled and already installed.

From what I understand up to now the SoL interface it is trying to use is something connected to the CIMC and UCS and not to the ESXi.

I have checked the serial over lan profile created on UCSM and it looks ok. I had to change the password on the esxi server.

Sandro

HX installed utilizes the SoL configuration in order to obtain cli access to ESXi and configure the vmk0 interface IP settings and VLAN tag. See link for config details if you need to configure it if for some reason it's missing or ESXi was reset. 

https://pubs.vmware.com/vsphere-50/index.jsp#com.vmware.vsphere.install.doc_50/GUID-C65306C0-DA37-4F45-8A50-31F8D109BB1D.html

Hello,

Try to enable ssh and cli shell in the esxi (troubleshooting options). i had the same problem and this helped me.

Andrea Florio
Beginner

how did you solve? i have the same problem.

 

i had to reset the esxi to factory, and i am stuck like this

Tony Welch
Cisco Employee

I was able to resolve this by switching the cimc outband IP to use the pooled one instead of the manually assigned one I had already configured.

lovefengzhiyuan
Beginner

Have you resolved the problem ?
lovefengzhiyuan
Beginner

Have you resolved the problem ?
guido.capodanno
Beginner

Hi all,

I had the same issue, that was solved following the procedure "Preparing HX servers for a Re-install" from Cisco HyperFlex Systems Getting Started Guide, Release 1.7

 

Link below:

https://www.cisco.com/c/en/us/td/docs/hyperconverged_systems/HyperFlex_HX_DataPlatformSoftware/GettingStartedGuide/b_HyperFlexSystems_GettingStartedGuide/b_HX_BookMap_updated_chapter_0111.html

 

Regards

jkilleda
Participant

Hello Sandro,

Unexpected prompt got through SoL for esxi
You can check the VHBA placement and SOL policy , the below links may help you out for further troubleshooting.

https://kb.vmware.com/s/article/2004954

https://communities.vmware.com/thread/459947

Content for Community-Ad