Showing results for 
Search instead for 
Did you mean: 

Can I save my SRW224G4?


I have a SRW224G4 that keeps rebooting. I connect via terminal and this is what I see:

------ Performing the Power-On Self Test (POST) ------

UART Channel Loopback Test........................PASS

Testing the System SDRAM..........................PASS

Boot1 Checksum Test...............................PASS

Boot2 Checksum Test...............................PASS

Flash Image Validation Test.......................PASS

BOOT Software Version Built  23-May-2005  16:58:25


:::        ::: :::       ::: :::     :::::  :::::::::: :::      ::: ::::::::::

:::        ::: :::::     ::: :::   :::::   ::::     ::: ::::  :::: ::::     :::

:::        ::: ::: :::   ::: ::::::::      ::::          ::::::::  ::::

:::        ::: :::   ::  ::: ::::::::::     ::::::::::     ::::     ::::::::::

:::        ::: :::    :::::: :::    ::::            :::    ::::             :::

:::::::::: ::: :::      :::: :::      :::: :::......:::    ::::    :::......:::

......... ... ...       ... ...       .... ..........     ....     ..........

Linksys SmartSwitch based on 88E6218 with ARM946E-S.

32MByte SDRAM. I-Cache 8 KB. D-Cache 8 KB. Cache Enabled.

Autoboot in 2 seconds - press RETURN or Esc. to abort and enter prom.

Preparing to decompress...


Decompressing SW from flash



Running from RAM...


*** Running  SW  Ver. 1.2.2a  Date  05-Apr-2007  Time  15:35:50 ***


HW version is 00.00.02

Base Mac address is: 00:12:17:5d:08:d5

Dram size is  : 32M bytes

Dram first block size is  : 16969K bytes

Dram first PTR is  : 0xF6D840

Flash size is: 8M

01-Jan-2000 01:01:05 %CDB-I-LOADCONFIG: Loading startup configuration.

01-Jan-2000 01:01:08 %ERHG-F-SEND: BOXP_perform_smi_scan_of_devices_in_slot: inv

alid device type is found: 268374443 on device 0

***** FATAL ERROR *****

Reporting Task: ROOT.

Software Version: 1.2.2a (date  05-Apr-2007 time  15:35:50)


*****************  SYSTEM RESET  *****************


It just repeats this over and over. The unit is out of warranty. Can I do anything to get this switch back up and running?

Any help or suggestions would be greatly appreciated.

Thank you!

11 Replies 11

Tom Watts

Hi Charles, here is a document I wrote for a different small business switch. The process is exactly the same however. This should recover the switch, if it doesn't it is likely time for a replacement-

Here is the software replease for the older srw switches

As you already know, it is 38400 baud rate.

Please rate helpful posts

-Tom Please mark answered for helpful posts

Hi Thomas and thank you for the quick reply!

Unfortunately, I don't think this SRW224G4 (hardware version 00.03.00 / boot version 1.0.2) will allow me to update firmware to anything later than 1.2.1b. I have another SRW224G4 of the same "vintage" and if I remember correctly, they both had the same hardware/boot versions and I could not update either one to 1.2.3. When I looked into it, I believe I was told that the hardware was too old to update to the current version.

I don't seem to have a copy of the 1.2.1b firmware anywhere. Do you happen to have a copy or a link to it?

Thank you again!

- Charles

Actually, if I could reload v1.2.2a to start, that might be better. I did find a copy of that version, so I will try that first.

If that doesn't fix it, is there anything else I could try? Maybe the 1.2.1a or 1.2.1b versions?

If all else fails, would Cisco be able to repair this unit for me via RMA for a fee?

Also, why aren't any older firmware versions available? Every link to every version I have tried to find ultimately redirects to Cisco's home page.

Is there an archive of older firmware somewhere? Quite frustrating.

Thanks again.

Charles,  If you're on such an old code, the only way to load the newest software is with a newer boot code as well. The switch has only 2 firmwares to download any longer.

If the switch is out of hardware warranty, there is no service levels available from Cisco for the device.

Please rate helpful posts

-Tom Please mark answered for helpful posts

Hi Thomas -

Well I tried reloading 1.2.2a and got the same results:

***** FATAL ERROR *****

Reporting Task: ROOT.

Software Version: 1.2.2a (date  05-Apr-2007 time  15:35:50)

Does this indicate a real hardware failure or is it software-related?

Are you saying older versions are no longer available anywhere?

Would it be worth trying an older version if I could get a hold of one?

Just seems a shame to kick it to the curb if the problem is just a corrupt flash.

- Charles

Hi Thomas -

Do you have any other ideas before I dispose of the switch?

Regardless, I want to thank you for taking the time to help and respond on a Sunday.

Thanks again.

- Charles

Charles, when the switch has a reboot loop, it is indicative of a bad flash. When the newer firmwares were released, the bootcode was integrated in to the software .ros files. Thats why you don't see the older firmware around or downloadable boot codes.

But, this is also why you should always use the latest release softwares. At some point, software does become so obselete and has failures to interop with newer technologies.

You may try to delete the flash files (boot and firmware) from the prom menu and then reload the newest released firmware. But it is looking like the switch may have met its end.

Please rate helpful posts

-Tom Please mark answered for helpful posts

Thanks Tom -

Can you tell me how or point me to something that explains how to delete the flash files? I had actually been looking into how to do this, but it seems you have to enter the name of the file in order to delete it and the only info I could find was in reference to the CONFIG file. How would I go about deleting the boot and firmware files? I think that would be a good last try before finally calling it quits.

- Charles

Hi Tom -

Can you provide the names of the files I should delete? The only one I know of is CONFIG.


- Charles

Hi Charles, I think it is time to move on and purchase a SF300-24  (srw224g4-k9-).

The old boot code and firmware images have been pulled for years.

If the switch is rejecting the 1.2.2a and 1.2.2b the switch has a failure.

If you want, I can email you the boot code and an old image I found in my "stash of goodies". However, I will tell you right now, if it doesn't work, the switch rejects or any other problem, I can't really be responsible for this.

Please let me know your email address if you want the boot code and an old firmware image.

Please rate helpful posts

-Tom Please mark answered for helpful posts

Hi Tom -

That would be most appreciated! Of course I would not hold you responsible, but I understand completely why you have to make that clear. I am truly grateful for your efforts in helping me try to salvage this switch.

I have sent an email to the address in your contact info.

- Charles

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Switch products supported in this community
Cisco Business Product Family
  • CBS110
  • CBS220
  • CBS250
  • CBS350
Cisco Switching Product Family
  • 110
  • 200
  • 220
  • 250
  • 300
  • 350
  • 350X
  • 550X
Recognize Your Peers