cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
468
Views
0
Helpful
4
Replies

Connect VLANs switch SF300 in the same switch

Hello,

 

I have 5 VLANs in a switch SF300 configured in Layer3. I Set the switch to general mode so I could connect all the vlans. After 2 weeks that connection has been lost. Now you can only communicate with your respective gateway.

 

This are the vlans.

interface vlan 2
 name "Linea Nueva" 
 ip address 10.0.0.150 255.255.255.0 
!
interface vlan 3
 name vlan_invitados 
 ip address 192.168.10.253 255.255.255.0 
!
interface vlan 4
 name "Red Administrativa" 
 ip address 10.178.5.150 255.255.255.0 
!
interface vlan 5
 name vlan_plc2 
 ip address 192.168.1.65 255.255.255.0 
!
interface vlan 6
 name vlan_plc3 
 ip address 192.168.0.150 255.255.255.0 

 

 

vlan 2,4,5 and 6 connect to each other. Notice that disable spanning briefly connected but then stopped.

This is my configuration

 

config-file-header
ciscoauto2
v1.3.5.58 / R750_NIK_1_35_647_358
CLI v1.0
set system mode router 

file SSD indicator encrypted
@
ssd-control-start 
ssd config 
ssd file passphrase control unrestricted 
no ssd file integrity control 
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0 
!
vlan database
vlan 2-6,700 
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
bonjour interface range vlan 1
hostname ciscoauto2
username cisco password encrypted fc48b9daa3849fab289dd8919097ede3b9f2b3eb privilege 15 
clock timezone " " 0 minutes 0
ip telnet server
!
interface vlan 1
 no ip address dhcp 
!
interface vlan 2
 name "Linea Nueva" 
 ip address 10.0.0.150 255.255.255.0 
!
interface vlan 3
 name vlan_invitados 
 ip address 192.168.10.253 255.255.255.0 
!
interface vlan 4
 name "Red Administrativa" 
 ip address 10.178.5.150 255.255.255.0 
!
interface vlan 5
 name vlan_plc2 
 ip address 192.168.1.65 255.255.255.0 
!
interface vlan 6
 name vlan_plc3 
 ip address 192.168.0.150 255.255.255.0 
!
interface fastethernet1
 switchport default-vlan tagged 
!
interface fastethernet2
 spanning-tree link-type point-to-point 
 switchport mode general 
 macro description switch
 switchport default-vlan tagged 
 !next command is internal.
 macro auto smartport dynamic_type unknown 
!
interface fastethernet3
 spanning-tree link-type point-to-point 
 switchport mode general 
 macro description switch
 switchport default-vlan tagged 
 !next command is internal.
 macro auto smartport dynamic_type unknown 
!
interface fastethernet4
 spanning-tree link-type point-to-point 
 switchport mode general 
 switchport general allowed vlan add 700 tagged 
 macro description switch
 switchport default-vlan tagged 
 !next command is internal.
 macro auto smartport dynamic_type unknown 
!
interface fastethernet5
 switchport trunk allowed vlan add 4 
 switchport trunk native vlan 2 
 no macro auto smartport 
!
interface fastethernet6
 switchport trunk allowed vlan add 2 
 switchport trunk native vlan 4 
!
interface fastethernet7
 switchport trunk allowed vlan add 4 
 switchport trunk native vlan 2 
!
interface fastethernet8
 switchport trunk allowed vlan add 4 
 switchport trunk native vlan 2 
!
interface fastethernet9
 switchport trunk allowed vlan add 4 
 switchport trunk native vlan 2 
!
interface fastethernet10
 switchport trunk allowed vlan add 4 
 switchport trunk native vlan 2 
!
interface fastethernet11
 spanning-tree link-type point-to-point 
 switchport mode general 
 switchport general allowed vlan add 2-6 untagged 
 switchport general pvid 2 

interface fastethernet12
 spanning-tree link-type point-to-point 
 switchport mode general 
 switchport general allowed vlan add 2-6 untagged 
 switchport general pvid 6 
!
interface fastethernet13
 switchport trunk allowed vlan add 4 
 switchport trunk native vlan 2 
!
interface fastethernet14
 switchport trunk allowed vlan add 4 
 switchport trunk native vlan 2 
!
interface fastethernet15
 switchport trunk allowed vlan add 4 
 switchport trunk native vlan 2 
!
interface fastethernet16
 switchport trunk allowed vlan add 4 
 switchport trunk native vlan 2 
!
interface fastethernet17
 switchport trunk allowed vlan add 4 
 switchport trunk native vlan 2 
!
interface fastethernet18
 switchport trunk allowed vlan add 4 
 switchport trunk native vlan 2 
!
interface fastethernet19
 switchport trunk allowed vlan add 4 
 switchport trunk native vlan 2 
!
interface fastethernet20
 switchport trunk allowed vlan add 4 
 switchport trunk native vlan 2 
!
interface fastethernet21
 switchport trunk allowed vlan add 4 
 switchport trunk native vlan 2 
!
interface fastethernet22
 switchport trunk allowed vlan add 2 
 switchport trunk native vlan 4 
!
interface fastethernet23
 switchport trunk allowed vlan add 4 
 switchport trunk native vlan 2 
!
interface fastethernet24
 spanning-tree link-type point-to-point 
 switchport mode general 
 switchport general allowed vlan add 2-6 untagged 
 switchport general pvid 5 
!
interface gigabitethernet1
 spanning-tree link-type point-to-point 
 switchport mode general 
 switchport general allowed vlan add 3 tagged 
 switchport general allowed vlan add 2,4-5 untagged 
 switchport general pvid 4 
 macro description switch
 !next command is internal.
 macro auto smartport dynamic_type unknown 
!
interface gigabitethernet3
 switchport mode access 
 switchport access vlan 3 
!
exit

 

 

 

 

4 Replies 4

psandel
Cisco Employee
Cisco Employee

Hi Alan,

 

My name is Puneet Sandel and I am from Cisco small business technical support center. Kindly try changing the switch mode from General to Trunk and allow the management VLAN as untagged and rest of the VLANs as Tagged on the port.

 

It will definitely resolve your issue. sometimes Trunk mode works better as compared to General Mode. General mode is only used when the devices do not understand Dot1q  trunking.

 

Also in case the issue is not resolved, please feel free to contact Cisco small business support center. We will definitely help you out with the issue.

 

Please find below the link to contact us.

https://www.cisco.com/c/en/us/support/web/tsd-cisco-small-business-support-center-contacts.html

 

Regards,

Puneet Sandel

Technical Consulting Engineer-Level 2

Global CX Centers – Small Business Support

Trank you very much, to make it clear. You say that I have to change general to trunk and untagged management vlan like native vlan? 

Mode trunk doesn't support allowed vlan add x untagged

 

interface gigabitethernet4
switchport trunk allowed vlan add 2-4,6
switchport trunk native vlan 5

 

 

Alan,

 

In case the Gi4 port will be a part of VLAN 5(It will have IP address from VLAN 5) then the VLAN configuration will be 5U,2T,3T,4T,6T under port to VLAN membership in case you login through GUI of the switch.

 

For CLI you can refer to configuration guide of SF300. Small business devices have some commands different as compared to enterprise catalyst switches.

 

Regards,

Port Gi4 with configurationPort Gi4 with configurationvlansvlans

This is my new configuration for port gi 4 and I put a host with IP 192.168.1.122 to gateway from vlan 5 192.168.1.65 and this respond, but with gw 10.0.0.150 doens't


interface gigabitethernet4
switchport trunk allowed vlan add 2-4,6
switchport trunk native vlan 5

 

 Captura3.JPG

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Switch products supported in this community
Cisco Business Product Family
  • CBS110
  • CBS220
  • CBS250
  • CBS350
Cisco Switching Product Family
  • 110
  • 200
  • 220
  • 250
  • 300
  • 350
  • 350X
  • 550X
Recognize Your Peers