Showing results for 
Search instead for 
Did you mean: 

SG300-28P - POE not correctly supported on all ports - possible firmware or hardware issue

Level 1
Level 1

So, I spent some time this weekend troubleshooting the issues I've had  with the new SG300-28P switch and POE to many of my devices in the  office.  As a recap, I cannot utilize all of the 24 POE ports on the switch  for POE purposes.  Really only every other port [with a few odd  combinations thrown in between]. In addition, the SG300-28P switch, on occasion, is sending POE to non-POE devices [e.g. my Ruckus Zone Director 1106].

Here are my POE devices [all 802.3 af-compliant]:

  • 3 Ruckus 7982 access points
  • 1 Pakedge access point
  • 2 home-automation controllers
  • 2 Polycom voip phones

I called Cisco support several times in regards to this problem, and they figured it was a hardware issue - a faulty switch.  So, Cisco sent me a replacement SG300-28P, which I  hooked up today.  The exact problem still occurs.  Default configuration  [fresh out of the box].  No way I can land, for example, the 3 Ruckus  7982 AP's on ports 1, 2, and 3 [or ports 1,13, and 2].  I have to put  them on ports 1, 3, and 5 in order for them to power up.  In addition, I  can't plug any other POE devices on the ports either between or below  them.   I had to skip another port bay.  This is very odd behavior!!   Two Cisco SG300-28P's in a row with the same problem.

However, I also had one of the new Cisco SG300-10P switches in my  possession for a recent project of ours.  I decided to hook up the same  POE devices to this switch.  ALL POE devices were recognized and  worked!  No need to skip a port.  And it didn't matter what device was  plugged in first or not.  I am now convinced that it is either a  hardware issue [bad power supply/transformer?] inside all of the  SG300-28P switches, or a firmware issue. 

Both of the SG300-28P switches were running firmware 1.1.2 [the  latest on Cisco's website].  So, I decided to install an older firmware  version on the SG300-28P switch that I'm returning [installed].   Here's what I found out.  I could then plug 2 POE devices [e.g. two  Ruckus AP's] in adjacent horizontal ports, but not three in a row.  In  addition, not all adjacent ports.  It's funky. For example, I could plug  an access point in ports 20 and 21, but not in 21 and 22.  No rhyme or  reason in how it worked.  And I still couldn't plug an access point in  adjacent vertical ports [e.g. ports 1 and 13].  BUT...

It's interesting that the same exact switch that would not initially  allow 2 horizontally-adjacent POE ports to be utilized WOULD allow 2  horizontally-adjacent POE ports to be utilized when running a different  firmware version.   It's also interesting to note that when plugged into  a "non-working" POE  port, the SG300-28P would actually make a small whining noise.  Very  subtle noise; I could hear it when approx. 1ft away from the switch.   The noise was not noticeable when ports were skipped [and POE actually  worked].  Therefore, I believe that Cisco has some SG300-28P firmware  bugs [at least in the last two versions of firmware] that is not truly  allowing all 24 ports to utilize POE correctly.  This problem does not  exist with the SG300-10P switch.

I'm really interested to hear what Cisco's reply and findings on this  matter would be.  And would welcome a reply from one of their senior  support team members/managers who could actually experiment with this,  too.   In addition, I'd like to know when they think a solution could be  created if it's firmware-related.  If hardware-related, I don't think  I'll be recommending any 28P switches in our projects.  Perhaps just the  regular SG300-28 with a separate SG300-10P.  It's a shame because the  SG300-28P is more of a bargain when compared to the two separate  components.

90 Replies 90

Please send me an email. I will write out a process for you if you're comfortable with that.

Please rate helpful posts

-Tom Please mark answered for helpful posts

If anyone else has the problem with Ruckus 7982 connecting to the SX300 switch, I will share the process which should be completed to help things along-

As an example:

AP#1 to port 1 <-Works

AP#2 to port 2<-Works

AP#3 to port 13<-Fails

A working example would be

AP#1 to port 1

AP#2 to port 3

AP#3 to port 5

-Network topology (What router, switch, AP, #users, #devices)

-How many SX300 switches are affected

-Configuration file of all switches in question

-Ensure you're using the firmware

In addition to this information I'd like the following tests       performed

-Factory default the unit (leave the switch at 100% default       status)

1.) Set up a console (or CLI) connection and log all output to a       text file

2.) Once logged on to the CLI, connect Ruckus AP#1 to port #1 then       perform the following

-show spanning-tree active

-show power inline  gi1

-show power inline

-show power inline consumption

-show interface status gi1

3.) Connect Ruckus AP#2 to port#2 then performing the following

-show spanning-tree active

-show power inline gi2

-show power inline

-show power inline consumption

-show interface status gi2

4.) Connect Rucks AP#3 to port #13 then perform the following

-show spanning-tree active

-show power inline gi13

-show power inline

-show power inline consumption

-show interface status gi13

5.) At this point, port 13 should fail. At this time, disconnect AP #3 from port #13 and AP#2 from Port#2

6.) Connect a computer that has wireshark installed to port #10

7.) Set up a SPAN (port monitor), with the destination port #10, source port#2 (remember, if the computer connects to a monitor port, it has zero network connectivity)

config t

interface gi10

port monitor gi2

8.) Connect AP#2 to port#2, wait 30 seconds then discontinue the  wireshark, save the file (please mark the file clearly what ports used)

9.) Remove the port monitor from gi2 and change it to gi13

config t

int gi10

no port monitor gi2

port monitor gi13

10.) Connect the AP#3 to port#13

11.) Wait 30 seconds then discontinue the wireshark, save the file (please mark the file clearly what ports used)

12.) Collect the log file from the session

show log

show log file

13.) Collect tech data

show tech

14.) Please put all files, clearly named in to a folder and make a ZIP file

Please rate helpful posts

-Tom Please mark answered for helpful posts

Hi Tom,

Just wanted to say that the issue I was having was not resolved yet.  So, I'm interested as well about this continuing issue.  On a side note, guys, I'm getting in a group of Ruckus 7363 AP's to try with the SG300-28P switch.  I'll let you guys know if I have the same performance issue with that model of AP in order to help narrow down some issues.  Feel free to contact me if you guys have any questions.  Thanks.

Hi John, I had a customer using 7363 x5, on his switch all AP worked on port 1,2,13,14.  They were pulling about 3-4 watt per port, class 3 poe around 50 MA.

They should work for you.

Please rate helpful posts

-Tom Please mark answered for helpful posts

Thanks for the info, Tom:

Funny timing you have.  We're actually in our offices configuring the 7363/SG300-28P combo as I type this.  I'll let you know what I discover later on this evening.  Thanks.

Are you getting anywhere with this?  I've got a bunch of PoE adapters from MacWireless (POE-TGS-25125DN) that don't really work on an SG500-28P.  I can plug in one and it works, but more than a couple and some or all of them don't power up and flicker and throw some signature(?) errors in the logs.

Of course MacWireless says they work just fine, so they won't take them back, nor have they any interest in buying an SG500 just to test them.

I threw them in the junk box and went with Trendnet TPE-114GS boxes which work fine.

John (or any other Cisco engineer), if you think you can debug the problem with them I'm happy to ship them to you, but I have neither the time nor the spare SG500 to play with debugging them from here.

Not _positive_ if this is related to the SG300 PoE issues, but it might be worth checking out.

Steven Barnes
Level 1
Level 1

I'm seeing a similar issue on SG200-26P switches with the Ruckus 7982s.

This is still an open issue. There is no ETA. The good thing is, it is a well documented problem and Cisco engineering is VERY aware of this.

If you guys need a solution right now use the 8/10 port or the MP versions.

Please mark answered for helpful posts

-Tom Please mark answered for helpful posts

Level 1
Level 1