cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3147
Views
0
Helpful
5
Replies

Не могу настроить Vlan-маршрутизацию на C3750G

zhenche
Level 1
Level 1

Доброго дня, знатоки. Возможно я покажусь безголовым и криворуким, но уже доведен до состояния отчаяния.
Есть у меня 3 каталиста C3750G, соединены в стек. Прошивка последняя 15-я сервисная. У меня есть сеть на 100 машин, её нужно поделить на 3 влана. В пакет-трейсере сделал всю схему, работает...Машинки вланов видят друг друга, пинги бегают. Соответственно всё это после #ip routing. 

Взял свой реальный стек, врубил в него 2 машины, они соответственно в нативном Vlan1. 
Телнечусь, Создаю 2 Vlan:

Switch(config)#vlan 50
Switch(config-vlan)#name 50
Switch(config-vlan)#exit
Switch(config)#vlan 40
Switch(config-vlan)#name 40
Switch(config-vlan)#exit

Далее назначаю машинкам настройки сети:

1. 192.168.50.2
255.255.255.0
192.168.50.1

Вешаю на порт Gi1/0/8
На С3750 отрабатываю код:
Switch(config)#int Fa0/8
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 40
Switch(config-if)#no shut
Switch(config-if)#exit

2. 192.168.40.2
255.255.255.0
192.168.40.1
На С3750 отрабатываю код:
Switch(config)#int Fa0/7
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 50
Switch(config-if)#no shut
Switch(config-if)#exit

Назначаю адреса SVI-интерфейсам:
Switch(config)#int vlan50
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan50, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan50, changed state to up
Switch(config-if)#ip address 192.168.50.1 255.255.255.0
Switch(config-if)#no shut
Switch(config-if)#exit
Switch(config)#int vlan40
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan40, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to up
Switch(config-if)#ip address 192.168.40.1 255.255.255.0
Switch(config-if)#no shut
Switch(config-if)#exit
Switch(config)#ip routing
Switch(config)#exit

Маршрутизация между VLAN на коммутаторе L3

При такой настройке и конфигурации в пакет-трейсере обе машины друг друга видят и пингуют.
При такой же конфигурации на реальном С3750 каждый хост в вилане пингует SVI свой (как осн.шлюз) и соседнего вилана,но хост в соседнем вилане не пигуется. Т.е. вроде как маршрутизация и работает, но как-то не до конца. У меня конечная цель - имея несколько виланов дать возможность отдельным компьютерам и разныз подсетей видеть друг друга. От этого я, увы, уйти не смогу, т.к. моя плоская сеть уже настойко укоренилась, что ломать сложнее, чем сделать правила маршрутизации. Чуть ниже я приведу конфиг.Максимально его укомпактил как мог, сократив лишь количество неиспользуемых портов. 
Гуру, прошу вашей помощи в совете что я сделал не так или не сделал? Я пытался создавать правила ACL,вешал их уже как угодно в разных вариациях на 4 возможных варианта (как на оба порта, так и на оба SVI)...Видать я жёстко туплю. Прошу помощи.
Конфиг:
Cisco3#show configuration
Using 4389 out of 524288 bytes
!
! Last configuration change at 17:46:40 EET Fri Mar 5 1993
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service sequence-numbers
!
hostname NDCisco3
!
boot-start-marker
boot-end-marker
!
enable secret 5 
enable password 0000000000
!
no aaa new-model
clock timezone EET 2 0
switch 1 provision ws-c3750g-24ts-1u
switch 2 provision ws-c3750g-24ts-1u
switch 3 provision ws-c3750g-24ts-1u
system mtu routing 1500
ip routing
!
crypto pki trustpoint TP-self-signed-
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-
revocation-check none
rsakeypair TP-self-signed-
!
crypto pki certificate chain TP-self-signed-
certificate self-signed 01 nvram:IOS-Self-Sig#1.cer
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet1/0/1
interface GigabitEthernet1/0/2
interface GigabitEthernet1/0/3
interface GigabitEthernet1/0/4
interface GigabitEthernet1/0/5
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
no switchport
no ip address
!
interface GigabitEthernet1/0/8
no switchport
no ip address
!
interface GigabitEthernet1/0/9
interface GigabitEthernet1/0/10
interface GigabitEthernet1/0/11
interface GigabitEthernet1/0/12
interface GigabitEthernet1/0/13
interface GigabitEthernet1/0/14

interface GigabitEthernet1/0/15
switchport mode access

interface GigabitEthernet1/0/16
...........куча незадействованных портов.............
interface GigabitEthernet3/0/28

interface Vlan1
ip address 192.168.112.12 255.255.255.0
!
interface Vlan40
ip address 192.168.40.1 255.255.255.0
!
interface Vlan50
ip address 192.168.50.1 255.255.255.0
!
ip http server
ip http secure-server
!
line con 0
password 00000000000
login
line vty 0 4
password 0000000
login
line vty 5 15
password 000000000
login
!
end

1 Accepted Solution

Accepted Solutions

Predrag Jovic
Level 3
Level 3

interfaces Gi1/0/7 and Gi1/0/8 are configured as routed interfaces.

interface GigabitEthernet1/0/7
switchport
switchport mode access
switchport access vlan 50
!
interface GigabitEthernet1/0/8
switchport
switchport mode access
switchport access vlan 40

show vlan brief
show int status | e not
sh ip route
sh ip int brief | i up.*up

View solution in original post

5 Replies 5

Predrag Jovic
Level 3
Level 3

interfaces Gi1/0/7 and Gi1/0/8 are configured as routed interfaces.

interface GigabitEthernet1/0/7
switchport
switchport mode access
switchport access vlan 50
!
interface GigabitEthernet1/0/8
switchport
switchport mode access
switchport access vlan 40

show vlan brief
show int status | e not
sh ip route
sh ip int brief | i up.*up

you need to make

нужно включить ip routing

по умолчанию он выключен

conf t

ip routing

exi

wr

:)) Как Вы думаете, учитывая написанное выше с выложенным конфигом, я этого не сделал?

zhenche
Level 1
Level 1

I have done this and recieved nothing....BUT!!! i have taken a PC with Linux, added it to the VLAN 50 and......GACHA!!! host 192.168.40.2 have a ping to host 192.168.50.4 (PC with Linux)..That is mean routing works. Now, please, i need a help to find were in Windows 7 is a block of outside connection?

Now i have:

1. Vlan 40 with host windows 7,ip:192.168.40.2 (mask /24,gw 192.168.40.1). It have a ping to host in VLAN50.   -   called PC1

2. Vlan 50 with 2 PCs:

              a. 192.168.50.2 (Windows 7, ip:192.168.50.2 (mask /24,gw 192.168.50.1)   - called PC2

              b. 192.168.50.4 (Linux Centos 7) - called PC3

PC1 (vlan 40) and PC2 (vlan 50) have a ping to PC3 (vlan 50)

PC3 have a ping to PC2 (in the same vlan) but not have a ping to PC1

PC1 and PC2 have not ping in both directionals

I think that a problem in Windows 7 with PC1 and PC2. Brandmauer is enable (when it is down C3750 not pinging hosts with win7), Antiviruses i deleted. In the parametrs of network access i enabled the natwork discovered for main and home networks..i another case i have not a ping from C3750. Where i have tern on/off something to enable ping between VLANs?

ip routing was present in running configuration in the first post.

Ping can be blocked by network location in windows 7, 8, 10 (typically when network zone is set to public mode - so it is untrusted) or firewall configuration (including third party firewalls). Additionally, you will need to configure default route to access other networks - currently you can access only locally connected networks. :)

Windows 7: Network Location - Set as Home, Work, or Public Network

 

Review Cisco Networking for a $25 gift card