Showing results for 
Search instead for 
Did you mean: 

10GB ethernet uplink to 1gb ethernet issues

Abbas Rizvi
Level 1
Level 1

I have a 3945 router with a 1gb interface(Hwic) that I am connecting directly via  a cat6 cable to a 4948e switch that has a 10gb SPF slot.  I am using a 1gb GLC-T transceiver in the slot.  The switch recognized the transceiver but I am unable to link the two devices together.  Both interfaces are set to auto negotiate.  My assumption is that both devices should dynamically establish a trunk.

Is there special configuration required on the 10gb SPF module to work as a 1GB ethernet interface?  How can I establish the link? 





7 Replies 7

Jon Marshall
Hall of Fame
Hall of Fame

Not sure if this is applicable on your 4948 but under the interface configuration have you tried adding -

"media-type rj45"

if you haven't already.


Yes I tried that Jon,  but not applicable.  This should be basic layer 2 connectivity unless the 10gb interfaces are not backward compatible connected to 1gb interface.


Is the fiber interface 1/10 Gig or only 10Gig?

if yes try adding speed 1000 to the interface.


adding speed is not an option.  I can only set negotiation auto.

Issue resolved.  The GLC-T transceiver had a hardware issue.  Tried another module and it works perfectly.  Both sides a set to auto negotiate and the established a layer 2 connection.



switch# show interface capabilities



  Model:                 WS-C4948E-F-Gbic

  Type:                  1000BaseT

  Speed:                 1000,10000

  Duplex:                full

  Auto-MDIX:             no

  EEE:                   no

  Trunk encap. type:     802.1Q

  Trunk mode:            on,off,desirable,nonegotiate

  Channel:               yes

  Broadcast suppression: percentage(0-100), hw

  Multicast suppression: percentage(0-100), hw

  Flowcontrol:           rx-(off,on,desired),tx-(off,on,desired)

  VLAN Membership:       static, dynamic

  Fast Start:            yes

  CoS rewrite:           yes

  ToS rewrite:           yes

  Inline power:          no

  SPAN:                  source/destination

  UDLD:                  yes

  Link Debounce:         yes

  Link Debounce Time:    yes

  Port Security:         yes

  Dot1x:                 yes

  Maximum MTU:           9198 bytes (Jumbo Frames)

  Multiple Media Types:  no

  Diagnostic Monitoring: N/A

  Queuing:               rx-(N/A), tx-(1p7q1t)

Joseph W. Doherty
Hall of Fame
Hall of Fame


The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.


I'm not 100% sure, but I thought 10g ports on the 4948 were only 10g, i.e. they are not SFP+.  If true, it would explain why it doesn't work.

Review Cisco Networking for a $25 gift card