cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1112
Views
0
Helpful
6
Replies
Highlighted
Beginner

1921 router EHWIC tagged vlan ports

In this configuration:

FIOS ONT Ethernet ---->  3750 Switch 5 interfaces on VLAN2 two of the 5 interfaces tagged to handle VLAN1 and 2 traffic ----> 1921 router WAN interface connected to one of the VLAN2 3750 interfaces, the two tagged interfaces go to two Mac Minis that handle low volume email.  The minis have one ethernet interface with WAN traffic on VLAN2, LAN traffic on VLAN1

I would like to move the VLAN2 interfaces from the 3750 Switch to the 1921 Router to have this configuration:

FIOS ONT Ethernet ---->  1921 G0/0 Interface WAN  with EHWIC-4G interfaces

Four fixed IP addresses, contiguous addresses but not a subnet,  are provided by FIOS and used for:

WAN router traffic on the 1921 port G0/0

WAN email traffic and local LAN traffic for the 2 Mac Minis each with one ethernet interface on the 1921 port g0/0/2 and G0/0/3. These are low volume email servers and they do not route.

Is there a way to configure the 1921 router so that the G0/0 and the EHWIC-4G interfaces G0/0/0 - G0/0/3 work as a switch for the WAN FIOS fixed IP addresses and interfaces G0/0/2 and G0/0/3 are 802.1q tagged and handle traffic for VLAN1 (the LAN) and VLAN2 (the WAN)?  G0/0/0 and G0/0/1 would be VLAN2 traffic only.  G0/0/2 and G0/0/3 would be tagged for VLAN1 and VLAN2 traffic

On a CISCO 3750 I can configure a group of interfaces to do what I want using these IOS statements:

interface GigabitEthernet2/0/43
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet2/0/44
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet2/0/45
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet2/0/46
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet2/0/47
 switchport access vlan 2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,2
 switchport mode trunk
 spanning-tree portfast
!
interface GigabitEthernet2/0/48
 switchport access vlan 2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,2
 switchport mode trunk
 spanning-tree portfast
!

Is there an equivalent way to congifgure the 1921 router to do the same switching using G0/0 and the G0/0/0 to G0/0/3 interfaces on the EHWIC-4?

 

6 REPLIES 6
Highlighted
Cisco Employee

Hey Paul,Well in this case i

Hey Paul,

Well in this case i believe you will be able to configure the EHWIC with same commands as your switch for required roles, however i really doubt that if the onboard port i.e. G0/0 can be configured as layer 2 switchport.

But i still recommend to check if it can be done so use the IOS help (?) at the interafce configuration mode of G0/0 and look for switchport command as it will configure the port as layer 2.

If available you are good to go by configuring the link as access for vlan 2 else you may have to install another EHWIC or need to use a layer 3 link on your router.

HTH.

Regards,
RS.

Highlighted
Beginner

Hello Rajeevsh,

Hello Rajeevsh,

I thought the same commands would work, just as you suggested.  That's what I tried and couldn't get to work when I posted for help.

When entering:

interface GigabitEthernet0/0/3
 switchport access vlan 2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,2
 switchport mode trunk
 spanning-tree portfast

The

switchport trunk encapsulation dot1q

entry is ignored and the

Switchport trunk allowed vlan 1,2

produces an error and

Switchport trunk allowed vlan all

can be entered but gets ignored.

 

 

ALso, I think the 1921 will only support one EHWIC-4G so the option to add another isn't supported according to the documentation.

Highlighted
Cisco Employee

Hey Paul,Check the link and

Highlighted
Beginner

Rajeevsh,Thank you for trying

Rajeevsh,

Thank you for trying to help me.  I've read the links you provided and many more before posting my question.  The EHWIC configuration guide is nice, but doesn't address the configuration that I am trying to implement.  Table 6 of the EHWIC specification link clearly states that the 1921 router only supports 1 4-port EHWIC.  I'm not looking for help in reading CISCO and related web pages.

What I'm hoping to find is somenone that has actually configured a 1921 to pass dot1q traffic on the ehwic ports to both the lan and wan on a 1921 router.  If that person exists, then I hope they can share their portion of their config file that shows what to enter to get it to work.

Highlighted
Cisco Employee

Hey Paul,I never meant to

Hey Paul,

I never meant to share just the links and really appriciate the fact that you came to forum after throrough reserch.

If you check the bottom of page 15 in the pdf it tells about configuring the EHWIC port for trunking. I am adding a snipet:

Configuring a Gigabit Ethernet Interface as a Layer 2 Trunk
Beginning in global configuration mode, follow these steps to configure a GigabitEthernet interface as a Layer 2 trunk.

SUMMARY STEPS
1.interface gigabitethernet 0/slot/port

2.shutdown

3.switchport mode trunk

4.switchport trunk native vlan vlan-num

5.switchport trunk allowed vlan {add|except|none|remove} vlan1[,vlan[,vlan[,...]]

6.no shutdown

7.end

As far as the onboard port is concerned i suggested you to use the IOS help to find out if it can be configured as layer 2 port to support dot1q. I did try on one of my routers but its not supported.

HTH.

Regards,

RS.

Highlighted
Beginner

Re: Rajeevsh,Thank you for trying

Hello dude, I have the same problem; you have a solution?

Content for Community-Ad