cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

169
Views
5
Helpful
7
Replies
Beginner

2901 Switch Module Issue

Hi,

 

I have a very strange issue which have spent lots of time and can't find any reason for it. Got a 2901 with below modules:

1) NAME: "4 Port FE Switch on Slot 0 SubSlot 0", DESCR: "4 Port FE Switch"
PID: HWIC-4ESW , VID: VN/A, SN: 

2) NAME: "WIC/VIC/HWIC 0 Power Daughter Card", DESCR: "4-Port HWIC-ESW Power Daughter Card"
PID: ILPM-4 , VID: VN/A, SN: 

NAME: "4 Port FE Switch on Slot 0 SubSlot 1", DESCR: "4 Port FE Switch"
3) PID: HWIC-4ESW , VID: V01 , SN: 

 

Panzer-Router#sh vlan-switch

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/0/0, Fa0/0/1, Fa0/0/2, Fa0/0/3, Fa0/1/0, Fa0/1/1, Fa0/1/2, Fa0/1/3
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

 

All 8 ports of the switch modules are in VLAN1 as per above. My issue is whatever I connect to Fa0/1/x cannot ping the VLAN1 ip. Here is what I have done till now:

- Swapped module in slot1(non-working) to working slot 0 test if the switch module 2 is dead , works fine (switch module no issue)

- Swapped the the working module in slot0 to slot1 to test if the router mainboard (Slot1) has an issue , works fine(router mainboard seems fine)

- Swapped the non-working module in slot1 to slot 2/3 to test (while slot0 present) , doesn't work but when i remove slot0 works!!!! 

- Swapped working module in slot0 to slot2 or 3 when slot1 present , stops working but slot 1 module starts working... :O)

 

Whatever I have done , i can't have both working.

 

Any idea? or any test you think i can do to verify? is there a limitation of how many switch modules can be inserted in 29xx?!

 

 

 

Thanks

Samy

1 ACCEPTED SOLUTION

Accepted Solutions
Rising star

Re: 2901 Switch Module Issue

Hi

Isn't those module the ones that have to have one physical cross-over-cable connected between one port in each module?

/Mikael

7 REPLIES 7
VIP Mentor

Re: 2901 Switch Module Issue

Hi

they should be able to have 2 wics as per doc below , maybe its the software have you tried a newer version says you need minimum below just in case its that

Cisco 2900 Series

15.0(1)M: IP Base License of the Universal Image

 

https://www.cisco.com/c/en/us/products/collateral/interfaces-modules/high-speed-wan-interface-cards/product_data_sheet0900aecd8016bf0b.html

Beginner

Re: 2901 Switch Module Issue

I'm running the latest version mate 15.4M7 or something
Rising star

Re: 2901 Switch Module Issue

Hi

Isn't those module the ones that have to have one physical cross-over-cable connected between one port in each module?

/Mikael

Hall of Fame Master

Re: 2901 Switch Module Issue

It is my understanding that Mikael is correct. This router can have 2 switch modules but that the router backplane communicates with only one of the switch modules. For the second module to work it must have one of its ports connected to a port in the other switch module.

 

HTH

 

Rick

Beginner

Re: 2901 Switch Module Issue

Thanks Richard , that's a bit strange but if i understood correctly this reminds me a VDC inside a 2901 which have to physically run a cable to another VDC...lol

 

Hopefully the ports are auto-sensing so no cross-over needed ,  I'll test it tonight and update.

Highlighted
Hall of Fame Master

Re: 2901 Switch Module Issue

auto-sensing would be nice. Hope that is the case. But in any event the important thing is that the second switch module needs to have a port with a cable to a port on the first switch module. If you try a standard Ethernet cable and it works then that is great. But if it does not work then you need to try a cross over.

 

HTH

 

Rick

Beginner

Re: 2901 Switch Module Issue

Tested it :)
Mikael (yourself) were right , have to cable like a VDC (burn a port from each switch module and physically cable them). Ports are autosensing , no crossover needed. Turned spanning tree off and works perfectly. It's one of the things never mentioned in any Datasheet i guess :D

Thanks again to both of you


CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards