cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1437
Views
0
Helpful
4
Replies
Highlighted
Beginner

2960 IGMPv3

Hi all;

 

I'm new in multicast and I'm asked in my company to activate IGMPv3 in my 2960 switch;

we have a server witch can send only in IGMPv3, this server don't work with IGMPv2 so what I did is using an HP switch (1920) I tried activating IGMPv2 the server didn't work after that I had activat IGMPv3 the server worked good;

now I want that working with Cisco 2960-tc-l I didn't fin wher I can enable IGMPv3 I have IGMPv3 (minimal)

 

ac-sw#sh ip igmp snooping
Global IGMP Snooping configuration:
-------------------------------------------
IGMP snooping : Enabled
IGMPv3 snooping (minimal) : Enabled

 

can you help on that? is ther any solution to get IGMPv3 enabling fully on 2960 ? 

 

thanks in advence.

regards.

4 REPLIES 4
Highlighted
Contributor

IGMPv3 snooping is enabled. That means that IGMPv3 packets are being blocked. This is default on switches. Im guessing your server is on a different subnet compared to the other devices that 'multicast' with it considering it didnt work

To have the most minimal movement in your network. Have the server AND the devices that 'multicast' with it BE on the same subnet
Highlighted

thanks for your reply;

 

the server and devices are in the same subnet.

 

if "IGMPv3 snooping is enabled. That means that IGMPv3 packets are being blocked" how can I desable IGMPv3 snooping to permit IGMPv3 packets

Highlighted

Hi

IGMP Snooping actually is enabled by default on Catalyst switches, it is used to listen and know who will be requesting a stream from the source (few words it will hear about receivers), now you could specify the vlan to be used with snooping. Disabling IGMP Snooping is a solution but the multicast traffic will have a broadcast behavior indeed. (no ip igmp snooping)

Please check this link: 

https://www.cisco.com/c/en/us/support/docs/switches/catalyst-6500-series-switches/68131-cat-multicast-prob.html

 

Also you can specify the IGMP version on the interfaces, please try using:

int vlan X

ip pim sparse-mode   <-- it should be configured under all the interface from and to the source. 
ip igmp version 3

 

 

 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<
Highlighted

Hi Julio;

 

thanks for your reply; unfortunatly on 2960 switch we can not activate "ip igmp version 3";

do you think that can I use a router (as cisco 1941) that I activat ip igmp version 3 to do the role of "mroute" ? and do this will enable IGMPv3 on my 2960 ?

 

regards.

Content for Community-Ad