cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1040
Views
50
Helpful
35
Replies
Jason Tech Guy
Beginner

2960X Switch will only uplink with 1 port on QNAP NAS.

ello,

 

I have a 2960X-48FPS-L with 15.2-7.E5 (also tested on 15.0), and when I plug in the first port from a QNAP NAS it will not recognize it being plugged in, but it will recognize the second port.  With Term Mon turned on, it shows no log of it being plugged in. 

 

I plug the same NAS into a 2960S switch and it will recognize both ports.  I have also tried a different 2960X with the same result of Port 1 on the NAS not going UP.

 

Another side note on these 2960X's, when I try to plug in our building security system in to ports 1-24 it will not recognize the device, but if I plug it into ports 25-48, it works.

 

Below is my port config:

interface GigabitEthernet2/0/5
description To QNAP
switchport access vlan 31
switchport mode access
switchport voice vlan 100
priority-queue out
mls qos trust device cisco-phone
spanning-tree portfast edge
spanning-tree bpdufilter disable
spanning-tree bpduguard disable

 

Thanks in advance for any advice!

Jason

35 REPLIES 35

I will try this and report back

 

Hello,

 

I tried downgrading to the older versions as you suggested, and it still will not work.

 

If I go to QNAP they will say it works in every other switch, it is the 2960X's issue, and if I go to Cisco, they will say it is a QNAP issue...  I am caught between a rock and a hard place lol

Leo L
VIP Community Legend

This is not making a lot of sense.

Check the QNAP firmware.  Upgrade if necessary.

Please do something stupid:  Disable PoE on the port. 

conf t
 interface <PORT>
 power inline never
end

Ok, the QNAP was on the latest version, so I have downgraded to an older version, that did not work.

 

What I am going to try is this.

Currently upgrading to the most recent firmware, 15.2

going to do a factory reset and run a very bare-bone config and test.

 

If that doesn't work, I am going to downgrade the firmware to the oldest firmware that I can find and test with "out of the box" firmware.  If that doesn't work, then I don't know what to do next.

 

I will try to get the QNAP RMA'ed (even though it works with 5 different models/brands of switches)

Leo, I did try your suggestion, and unfortunately, that didn't work.  

 

I really do appreciate everyone's assistance with this weird issue.

 

Jason

Jason Tech Guy
Beginner

Hello Everyone,

 

So after much frustration with QNAP and twisting their arm they agreed to take a look at the QNAP NAS.  I shipped it back to them and they discovered that there was a fault in the mainboard.  They shipped it back to me and it now works.

 

QNAP support was not great to work with as I had to incur all shipping costs for a DOA device.

 

Thank you everyone for your assistance!

Jason