cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
492
Views
0
Helpful
4
Replies

3500XL HTTP server

I have a few old switches being used for ilo. A scan found an http injection vulnerability. I need to disabled the http server on these switches but I can't for life of me figure out how they are enabled... There are three switches configured like this. All of them share the same config minus the obvious stuff. They are not part of a cluster.

 

At any rate, pointing a browser to the vlan 2 interface IP results in success. I don't see anything about ip http

 

Any ideas on how to disable something that isn't enabled?


Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname BCA-ILO-1
!
enable password 7 014254115502151632
!
username scan.admin privilege 15 password 7 053D0F042842491A2A101419
!
!
!
!
clock timezone CST -6
clock summer-time CDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
!
no spanning-tree vlan 205
no spanning-tree vlan 208
no spanning-tree vlan 216
no spanning-tree vlan 218
no spanning-tree vlan 220
no spanning-tree vlan 222
no spanning-tree vlan 228
no spanning-tree vlan 230
no spanning-tree vlan 242
no spanning-tree vlan 300
ip subnet-zero
no ip finger
udld enable

!
!
!
interface FastEthernet0/1
 description ISL trunk to BCA-3750
 port group 1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 description ISL trunk to BCA-3750
 port group 1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/3
 switchport access vlan 87
!
interface FastEthernet0/4
 description APPCLSTR-PROD-3 iLO
 switchport access vlan 87
!         
interface FastEthernet0/5
 switchport access vlan 87
!
interface FastEthernet0/6
 switchport access vlan 87
!
interface FastEthernet0/7
 switchport access vlan 87
!
interface FastEthernet0/8
 switchport access vlan 87
!
interface FastEthernet0/9
 description LEMSJX-PROD-1 iLO
 switchport access vlan 87
!
interface FastEthernet0/10
 description LEMSJX-PROD-2 iLO
 switchport access vlan 87
!
interface FastEthernet0/11
 description LEMSJX-TEST-1 iLO
 switchport access vlan 87
!
interface FastEthernet0/12
 description LEMSJX-TEST-2 iLO
 switchport access vlan 87
!
interface FastEthernet0/13
 switchport access vlan 87
!
interface FastEthernet0/14
 switchport access vlan 87
!
interface FastEthernet0/15
 switchport access vlan 87
!
interface FastEthernet0/16
 switchport access vlan 87
!
interface FastEthernet0/17
 switchport access vlan 87
!
interface FastEthernet0/18
 switchport access vlan 87
!
interface FastEthernet0/19
 switchport access vlan 87
!
interface FastEthernet0/20
 switchport access vlan 87
!
interface FastEthernet0/21
 switchport access vlan 87
!
interface FastEthernet0/22
 switchport access vlan 87
!
interface FastEthernet0/23
 switchport access vlan 87
!
interface FastEthernet0/24
 description BEAST-PROD-1
 switchport access vlan 87
!
interface GigabitEthernet0/1
 shutdown
!
interface GigabitEthernet0/2
 shutdown
!
interface VLAN1
 no ip address
 no ip directed-broadcast
 no ip route-cache
 shutdown
!
interface VLAN90
 ip address 10.34.90.236 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
interface VLAN91
 no ip directed-broadcast
 no ip route-cache
 shutdown
!
ip default-gateway 10.34.90.1
snmp-server engineID local 0000000902000009433F5100
snmp-server community 
snmp-server location 
snmp-server contact 
snmp-server chassis-id 
banner motd ^C

line con 0
 exec-timeout 60 0
 password 7 00074215070B
 login
 transport input none
 stopbits 1
line vty 0 4
 exec-timeout 60 0
 password 7 00074215070B
 login
line vty 5 15
 exec-timeout 60 0
 password 7 121A5404115B
 login
!
ntp authentication-key 1 md5 045802150C2E01401D09 7
ntp authenticate
ntp trusted-key 1
ntp clock-period 11259627
ntp server  key 1
ntp server  key 1 prefer
end

4 Replies 4

Sam Smiley
Level 3
Level 3

Hi Richard,

I have one customer using an old 3524XL running c3500xl-c3h2s-mz.120-5.WC17.bin. This IOS does have the no ip http server that is included in more modern switches; after applying the command it did turn off the web server. What IOS are you running? Here is the output for this switch:

 

CCT-3524XL#show ver
Cisco Internetwork Operating System Software
IOS (tm) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5)WC17, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2007 by cisco Systems, Inc.
Compiled Tue 13-Feb-07 15:04 by antonino
Image text-base: 0x00003000, data-base: 0x00352924

ROM: Bootstrap program is C3500XL boot loader

CCT-3524XL uptime is 39 weeks, 2 days, 1 hour, 52 minutes
System returned to ROM by power-on
System restarted at 15:59:08 EDT Tue Jun 17 2014
System image file is "flash:c3500xl-c3h2s-mz.120-5.WC17.bin"


cisco WS-C3524-XL (PowerPC403) processor (revision 0x01) with 8192K/1024K bytes of memory.
Processor board ID FAB0536V288, with hardware revision 0x00
Last reset from power-on

Processor is running Enterprise Edition Software
Cluster command switch capable
Cluster member switch capable
24 FastEthernet/IEEE 802.3 interface(s)
2 Gigabit Ethernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:07:50:CE:48:40
Motherboard assembly number: 73-3904-11
Power supply part number: 34-0851-02
Motherboard serial number: FAB05362F31
Power supply serial number: PHI052806L0
Model revision number: A0
Motherboard revision number: D0
Model number: WS-C3524-XL-EN
System serial number: FAB0536V288
Configuration register is 0xF

CCT-3524XL#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
CCT-3524XL(config)#ip http ?
  access-class    Restrict access by access-class
  authentication  Set http authentication method
  path            Set base path for HTML
  port            HTTP port
  server          Enable HTTP server

Sam, 

 

That's the exact same version (and interestingly enough same model) running. That's really weird to me that it doesn't show up in the config. Is it just enabled by default? 

I'll throw that in there tomorrow!

 

Thanks!

Richard,

When I first looked at this router it did not show ip http server in the config as we are used to seeing in new switches. It does however show no ip http server once the command is issued.

 

Cheers,

Sam

that means its default. A lot of times it will not show if its default.  On newer stuff if you do a sh running config all  it will show everything including default stuff.

Review Cisco Networking products for a $25 gift card