cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
303
Views
0
Helpful
4
Replies
Highlighted
Beginner

3560 ports flapping.

Hi,

We have a large number of 3560's installed on which we see a high number of interfaces flapping. I've not been able to pin it down to a particular sw release, but one example we are seeing it is 12.2(55)SE3 (there are others though).

The messages in the logs are all along the lines as the example below:-

Apr 5 02:20:21.049 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/43, changed state to down
Apr 5 02:20:22.055 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/43, changed state to down
Apr 5 02:20:24.429 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/43, changed state to up
Apr 5 02:20:25.436 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/43, changed state to up

These are happening often throughout the day, this particular example occurred out of hours. It appears as if the switch is detecting the ports as down and then within 3 seconds saying it is up again. We are seeing this on many different speed links on different l2 networks etc.

It appears that this is only happening when the ports are either receiving a small number of input packets, or at periods when none at all are received. My thoughts are it is some automatic process within the switch, but have not been able to find the reason.

switch#sh run int g0/43
Building configuration...
!
interface GigabitEthernet0/43
switchport access vlan 36
switchport mode access
switchport port-security maximum 3
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
srr-queue bandwidth share 10 10 60 20
priority-queue out
no snmp trap link-status
no mdix auto
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input Standard-Edge-Port
end
switch#sh int g0/43
GigabitEthernet0/43 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is c464.13a0.62ab (bia c464.13a0.62ab)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 49
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 36000 bits/sec, 24 packets/sec
17189577 packets input, 2744003656 bytes, 0 no buffer
Received 405906 broadcasts (215452 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 215452 multicast, 0 pause input
0 input packets with dribble condition detected
158772189 packets output, 58489314874 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out
switch#

I am confident we are not experiencing a spanning tree loop, but am intrigued why this is being seen across so many of our switches.

Any suggestions ?

4 REPLIES 4
Highlighted
VIP Mentor

I Hi

I Hi

wouldn't say its the physical int dropping as the resets are at 1 , I would say its the end devices causing the logs , pcs rebooting or turned off etc

if you want to stop this use no logging event link-status

That interface looks in good shape no errors , whats attached to it ?

Highlighted
Beginner

Hi,

Hi,

I agree, but I am keen to understand why they are changing state so often. Having a quick look at the log shows many going up and down. Interestingly all the ports exhibiting this behaviour seem to have very light input traffic.

The end devices are all PC's from various vendors.

switch#sh log | inc state
igabitEthernet0/28, changed state to down
Apr 5 02:19:10.040 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/28, changed state to up
Apr 5 02:19:11.047 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/28, changed state to up
Apr 5 02:20:21.049 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/43, changed state to down
Apr 5 02:20:22.055 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/43, changed state to down
Apr 5 02:20:24.429 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/43, changed state to up
Apr 5 02:20:25.436 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/43, changed state to up
Apr 5 02:27:51.660 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/28, changed state to down
Apr 5 02:27:52.667 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/28, changed state to down
Apr 5 02:27:55.091 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/28, changed state to up
Apr 5 02:27:56.098 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/28, changed state to up
Apr 5 02:28:07.238 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/28, changed state to down
Apr 5 02:28:08.244 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/28, changed state to down
Apr 5 02:28:11.239 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/28, changed state to up
Apr 5 02:28:12.245 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/28, changed state to up
Apr 5 02:29:57.177 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/28, changed state to down
Apr 5 02:29:58.183 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/28, changed state to down
Apr 5 02:30:01.237 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/28, changed state to up
Apr 5 02:30:02.243 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/28, changed state to up
Apr 5 02:45:19.195 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/28, changed state to down
Apr 5 02:45:20.201 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/28, changed state to down
Apr 5 02:45:22.626 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/28, changed state to up
Apr 5 02:45:23.632 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/28, changed state to up
Apr 5 09:00:36.164 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/28, changed state to down
Apr 5 09:00:37.171 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/28, changed state to down
Apr 5 09:00:40.510 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/28, changed state to up
Apr 5 09:00:41.516 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/28, changed state to up
Apr 5 11:05:31.954 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/43, changed state to down
Apr 5 11:05:32.961 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/43, changed state to down
Apr 5 11:05:35.980 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/43, changed state to up
Apr 5 11:05:36.987 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/43, changed state to up
Apr 5 14:19:04.783 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/28, changed state to down
Apr 5 14:19:05.789 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/28, changed state to down
Apr 5 14:19:09.103 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/28, changed state to up
Apr 5 14:19:10.110 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/28, changed state to up
Apr 5 14:20:04.827 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/28, changed state to down
Apr 5 14:20:05.834 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/28, changed state to down
Apr 5 14:20:09.718 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/28, changed state to up
Apr 5 14:20:10.725 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/28, changed state to up
switch#

And on another switch

switch2#sh log | inc state
Interface GigabitEthernet0/45, changed state to down
Apr 5 13:16:54.460 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/45, changed state to down
Apr 5 13:16:56.842 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/45, changed state to up
Apr 5 13:16:57.849 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/45, changed state to up
Apr 5 13:17:20.120 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/44, changed state to down
Apr 5 13:17:21.127 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/44, changed state to down
Apr 5 13:17:23.618 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/44, changed state to up
Apr 5 13:17:24.625 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/44, changed state to up
Apr 5 13:25:12.812 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/44, changed state to down
Apr 5 13:25:13.819 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/44, changed state to down
Apr 5 13:25:16.713 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/44, changed state to up
Apr 5 13:25:17.720 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/44, changed state to up
Apr 5 13:33:16.921 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/36, changed state to down
Apr 5 13:33:17.919 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/36, changed state to down
Apr 5 13:33:20.302 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/36, changed state to up
Apr 5 13:33:21.308 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/36, changed state to up
Apr 5 13:38:21.516 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/41, changed state to down
Apr 5 13:38:22.514 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/41, changed state to down
Apr 5 13:38:25.467 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/41, changed state to up
Apr 5 13:38:26.474 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/41, changed state to up
Apr 5 13:51:00.273 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/42, changed state to down
Apr 5 13:51:01.279 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/42, changed state to down
Apr 5 13:51:03.712 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/42, changed state to up
Apr 5 13:51:04.719 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/42, changed state to up
Apr 5 14:13:41.416 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/42, changed state to down
Apr 5 14:13:42.414 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/42, changed state to down
Apr 5 14:13:45.308 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/42, changed state to up
Apr 5 14:13:46.332 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/42, changed state to up
Apr 5 14:43:26.456 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/48, changed state to down
Apr 5 14:43:27.454 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/48, changed state to down
Apr 5 14:43:30.038 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/48, changed state to up
Apr 5 14:43:31.044 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/48, changed state to up
Apr 5 14:53:30.243 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/45, changed state to down
Apr 5 14:53:31.250 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/45, changed state to down
Apr 5 14:53:34.312 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/45, changed state to up
Apr 5 14:53:35.318 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/45, changed state to up
Apr 5 15:17:11.784 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/48, changed state to down
Apr 5 15:17:12.782 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/48, changed state to down
Apr 5 15:17:15.685 BST: %LINK-3-UPDOWN: Interface GigabitEthernet0/48, changed state to up
Apr 5 15:17:16.691 BST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/48, changed state to up
switch2#

I would expect these messages to appear when PC's are rebooted, just find it hard to believe this many PC's are rebooting throughout the day.

Interesting the G0/48 above went through that flap whilst I was looking at the interface. I can't be 100% sure the end device wasn't rebooted but think it unlikely.

Highlighted
VIP Mentor

Hi You could span the port

Hi You could span the port and see exactly what traffic causes the drop at same time it comes into logs, pcs could also just be going into sleep mode causing this log, especially if centrally controlled through IT they may all be locked down to a certain length of time for security

some other reasons ports may be seen to constantly flap

    • Duplex mismatch
    • Port channel misconfiguration
    • BPDU guard violation
    • UDLD condition
    • Late-collision detection
    • Link-flap detection
    • Security violation
    • L2TP guard
    • DHCP snooping rate-limit
    • Incorrect GBIC / SFP module or cable
    • ARP inspection
    • Inline power
Highlighted
Beginner

Thanks Mark for you feedback

Thanks Mark for you feedback and comments.

I've not had chance to troubleshoot further yet, but will report back as soon as I have more information.

Content for Community-Ad