cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
2554
Views
0
Helpful
5
Replies
alabedekenny
Beginner

3560G L3 Routing Issues

Hi everyone,
I need help on what seems to be simple but driving me crazy.
I have a new 3560G to set up a small network for a remote site. I configured the vlan and an SVI as the gateway. The switch is also the DHCP server for the LAN. I configured Gi0/2 as L3 port, connecting to the nearest neighbor. My network runs EIGRP so i advertised the routes into the EIGRP process. The switch forms EIGRP neighbors and learns all routes in the enterprise network. The problems I'm having now are:
1. The switch learns all routes in my enterprise LAN and can ping devices in the enterprise LAN, but I can’t ping any interface on the switch from the enterprise LAN.
2. I noticed that despite the fact that users can get IP address automatically from the switch, they cannot connect to the enterprise network. They can ping only the IP addresses local on the switch, but not any other IP address beyond the switch, although my laptop (ONLY MMY LAPTOP) could connect normally and ping remote IPs.
Could this be a CEF issue? Since CEF is enabled by default???

Please see the “debug ip packet details” and relevant configs attached

The IOS version (Cisco IOS Software, C3560 Software (C3560-IPSERVICES-M), Version 12.2(50)SE5, RELEASE SOFTWARE (fc1)

**************************************************************************

DEBUG OUTPUT
IP: s=172.27.100.21 (Vlan27), d=172.41.201.2, len 60, stop process pak for forus packet
ICMP type=8, code=0
IP: s=172.41.201.2 (local), d=172.27.100.21, len 60, local feature
ICMP type=0, code=0, RCLI(7), rtype 0, forus FALSE, sendself FALSE, mtu 0
IP: s=172.41.201.2 (local), d=172.27.100.21, len 60, local feature
ICMP type=0, code=0, Local Clustering(8), rtype 0, forus FALSE, sendself FALSE, mtu 0
FIBipv4-packet-proc: route packet from (local) src 172.41.201.2 dst 172.27.100.21
FIBipv4-packet-proc: packet routing succeeded
IP: tableid=0, s=172.41.201.2 (local), d=172.27.100.21 (Vlan27), routed via FIB
IP: s=172.41.201.2 (local), d=172.27.100.21 (Vlan27), len 60, sending
ICMP type=0, code=0
IP: s=172.41.201.2 (local), d=172.27.100.21 (Vlan27), len 60, output feature
ICMP type=0, code=0, Check hwidb(68), rtype 1, forus FALSE, sendself FALSE, mtu 0
IP: s=172.41.201.2 (local), d=172.27.100.21 (Vlan27), len 60, sending full packet
ICMP type=0, code=0
IP: s=172.27.100.21 (Vlan27), d=172.41.201.2, len 60, input feature
ICMP type=8, code=0, MCI Check(62), rtype 0, forus FALSE, sendself FALSE, mtu 0
FIBipv4-p
FMN_ROM_OIL_IB(config)#acket-proc: route packet from Vlan27 src 172.27.100.21 dst 172.41.201.2
FIBfwd-proc: Default:172.41.201.2/32 receive entry
FIBipv4-packet-proc: packet routing failed
IP: s=172.27.100.21 (Vlan27), d=172.41.201.2, len 60, rcvd 2
ICMP type=8, code=0
IP: s=172.27.100.21 (Vlan27), d=172.41.201.2, len 60, stop process pak for forus packet
ICMP type=8, code=0
IP: s=172.41.201.2 (local), d=172.27.100.21, len 60, local feature
ICMP type=0, code=0, RCLI(7), rtype 0, forus FALSE, sendself FALSE, mtu 0
IP: s=172.41.201.2 (local), d=172.27.100.21, len 60, local feature
ICMP type=0, code=0, Local Clustering(8), rtype 0, forus FALSE, sendself FALSE, mtu 0
FIBipv4-packet-proc: route packet from (local) src 172.41.201.2 dst 172.27.100.21
FIBipv4-packet-proc: packet routing succeeded
IP: tableid=0, s=172.41.201.2 (local), d=172.27.100.21 (Vlan27), routed via FIB
IP: s=172.41.201.2 (local), d=172.27.100.21 (Vlan27), len 60, sending
ICMP type=0, code=0
IP: s=172.41.201.2 (local), d=172.27.100.21 (Vlan27), len 60, output feature
ICMP type=0, code=0, Check hwidb(68), rtype 1, forus FALSE, sendself FALSE, mtu 0
IP: s=172.41.201.2 (local), d=172.27.100.21 (Vlan27), len 60, sending full packet
ICMP type=0, code=0
IP: s=172.20.200.35 (local), d=224.0.0.10 (Loopback0), len 60, local feature, proto=88, RCLI(7), rtype 0, forus FALSE, sendself FALSE, mtu 0
IP: s=172.20.200.35 (local), d=224.0.0.10 (Loopback0), len 60, local feature, proto=88, Local Clustering(8), rtype 0, forus FALSE, sendself FALSE, mtu 0
IP: s=172.20.200.35 (local), d=224.0.0.10 (Loopback0), len 60, sending broad/multicast, proto=88
IP: s=172.20.200.35 (local), d=224.0.0.10 (Loopback0), len 60, sending full packet, proto=88
IP: s=172.20.200.35 (Loopback0), d=224.0.0.10, len 60, input feature, proto=88, MCI Check(62), rtype 0, forus FALSE, sendself FALSE, mtu 0
FIBipv4-packet-proc: route packet from Loopback0 src 172.20.200.35 dst 224.0.0.10
FIBfwd-proc: Default:224.0.0.0/24 receive entry
FIBipv4-packet-proc: packet routing failed
IP: s=172.20.200.35 (Loopback0), d=224.0.0.10, len 60, rcvd 2, proto=88
IP: s=172.20.200.35 (Loopback0), d=224.0.0.10, len 60, stop process pak for forus packet, proto=88
IP: s=172.27.100.21 (Vlan27), d=172.41.201.2, len 60, input feature
ICMP type=8, code=0, MCI Check(62), rtype 0, forus FALSE, sendself FALSE, mtu 0
FIBipv4-packet-proc: route packet from Vlan27 src 172.27.100.21 dst 172.41.201.2
FIBfwd-proc: Default:172.41.201.2/32 receive entry
FIBipv4-packet-proc: packet routin
FMN_ROM_OIL_IB(config)#g failed
IP: s=172.27.100.21 (Vlan27), d=172.41.201.2, len 60, rcvd 2
ICMP type=8, code=0
IP: s=172.27.100.21 (Vlan27), d=172.41.201.2, len 60, stop process pak for forus packet
ICMP type=8, code=0
IP: s=172.41.201.2 (local), d=172.27.100.21, len 60, local feature
ICMP type=0, code=0, RCLI(7), rtype 0, forus FALSE, sendself FALSE, mtu 0
IP: s=172.41.201.2 (local), d=172.27.100.21, len 60, local feature
ICMP type=0, code=0, Local Clustering(8), rtype 0, forus FALSE, sendself FALSE, mtu 0
FIBipv4-packet-proc: route packet from (local) src 172.41.201.2 dst 172.27.100.21
FIBipv4-packet-proc: packet routing succeeded
IP: tableid=0, s=172.41.201.2 (local), d=172.27.100.21 (Vlan27), routed via FIB
IP: s=172.41.201.2 (local), d=172.27.100.21 (Vlan27), len 60, sending
ICMP type=0, code=0
IP: s=172.41.201.2 (local), d=172.27.100.21 (Vlan27), len 60, output feature
ICMP type=0, code=0, Check hwidb(68), rtype 1, forus FALSE, sendself FALSE, mtu 0
IP: s=172.41.201.2 (local), d=172
FMN_ROM_OIL_IB(config)#.27.100.21 (Vlan27), len 60, sending full packet
ICMP type=0, code=0
IP: s=172.27.100.21 (Vlan27), d=172.41.201.2, len 60, input feature
ICMP type=8, code=0, MCI Check(62), rtype 0, forus FALSE, sendself FALSE, mtu 0
FIBipv4-packet-proc: route packet from Vlan27 src 172.27.100.21 dst 172.41.201.2
FIBfwd-proc: Default:172.41.201.2/32 receive entry
FIBipv4-packet-proc: packet routing failed
IP: s=172.27.100.21 (Vlan27), d=172.41.201.2, len 60, rcvd 2
ICMP type=8, code=0
IP: s=172.27.100.21 (Vlan27), d=172.41.201.2, len 60, stop process pak for forus packet
ICMP type=8, code=0
IP: s=172.41.201.2 (local), d=172.27.100.21, len 60, local feature
ICMP type=0, code=0, RCLI(7), rtype 0, forus FALSE, sendself FALSE, mtu 0
IP: s=172.41.201.2 (local), d=172.27.100.21, len 60, local feature
ICMP type=0, code=0, Local Clustering(8), rtype 0, forus FALSE, sendself FALSE, mtu 0
FIBipv4-packet-proc: route packet from (local) src 172.41.201.2 dst 172.27.100.21
FIBipv4-packet-proc: packet routing succeeded
IP: tableid=0, s=172.41.201.2 (local), d=172.27.100.21 (Vlan27), routed via FIB
IP: s=172.41.201.2 (local), d=172.27.100.21 (Vlan27), len 60, sending
ICMP type=0, code=0
IP: s=172.41.201.2 (local), d=172.27.100.21 (Vlan27), len 60, output feature
ICMP type=0, code=0, Check hwidb(68), rtype 1, forus FALSE, sendself FALSE, mtu 0
IP: s=172.41.201.2 (local), d=172.27.100.21 (Vlan27), len 60, sending full packet
ICMP type=0, code=0

************************************************************************************************************

CONFIGS

ip routing

!

ip dhcp pool ROM

network 172.27.100.0 255.255.255.0

default-router 172.27.100.254

dns-server 172.20.180.9 172.20.180.10

! interface Loopback0

ip address 172.20.200.35 255.255.255.255

!

interface GigabitEthernet0/1

description ***LINK TO MAJI, NOT CONNECTED YET ***

!

interface GigabitEthernet0/2

description ***LINK TO IBADA***

no switchport

ip address 172.41.201.2 255.255.255.0

spanning-tree portfast

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface GigabitEthernet0/5

switchport access vlan 27

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/6

switchport access vlan 27

switchport mode access

spanning-tree portfast

!

!

interface GigabitEthernet0/25

switchport access vlan 27

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/26

!

interface GigabitEthernet0/27

!

interface GigabitEthernet0/28

!

interface Vlan1

no ip address

shutdown

!

interface Vlan27

ip address 172.27.100.254 255.255.255.0

!

!

router eigrp 55

no auto-summary

network 172.20.200.35 0.0.0.0

network 172.27.100.254 0.0.0.0

network 172.41.201.0 0.0.0.255

!

ip classless

ip http server

5 REPLIES 5
Peter Paluch
Hall of Fame Cisco Employee

Hello,

I am afraid that the detail of the debug is actually obscuring the real cause of the issue. Can you just run the debug ip packet 111 where 111 is an ACL defined as follows?

access-list 111 permit icmp any any

Also, can you enclose the output of the show ip route command?

Best regards,

Peter

dslice
Beginner

Are the addresses assigned by dhcp from the /24 listed under the dhcp command (172.27.100.0)? If so, you don't have them in a network statement so EIGRP won't advertise them. Could this be your issue?

Sent from Cisco Technical Support iPad App

Peter Paluch
Hall of Fame Cisco Employee

Hi Don,

Are the addresses assigned by dhcp from the /24 listed under the dhcp  command (172.27.100.0)? If so, you don't have them in a network  statement so EIGRP won't advertise them.

I believe this is not the case here: the OP uses the network 172.27.100.254 0.0.0.0 in his EIGRP configuration, with the 172.27.100.254/24 being the IP address of his Vlan27 SVI, so the network should be advertised properly.

Best regards,

Peter

glen.grant
Advisor

Try changing this " network 172.27.100.254 0.0.0.0  to this network 172.27.100.0 0.0.0.255  . 

Yep, thanks.  I missed the SVI config and focused on the dhcp config.  The fact that the SVI has a /24 should cause that block to be advertised correctly.  I need to read for completeness.