cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4684
Views
0
Helpful
3
Replies

3750 replaced with 3750x - port-channel config problem

hi,

i have a problem in a 3750, 3750x mixed stack. i replaced 2 pcs. 3750 with 3750x with no problem, but now we have a port config problem

IOS 12.2(55)SE1

the old config was:

interface Port-channel1

description UPLINK

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

FastEthernet 2/0/1 - 48

description **ACCESS PORT**

switchport access vlan 301

switchport mode access

storm-control broadcast level 10.00

storm-control action trap

no cdp enable

no cdp tlv server-location

no cdp tlv app

spanning-tree portfast trunk

spanning-tree bpduguard enable

GigabitEthernet 2/0/1 - 4

description **UPLINK**

switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active

----

then we replaced this switch 2 with the new 3750X with the 4port Gigabit Module

new config:

GigabitEthernet 2/0/1 - 48

-> access Ports (same as old for access ports)

GigabitEthernet 2/1/1 - 4

-> uplink ports in the port-channel group 1 (same as old for uplink)

but the old config from the first 4gigabit ports was not deleted -> now i became following errors:

000096: Apr 10 06:57:24: %EC-5-CANNOT_BUNDLE2: Gi2/0/1 is not compatible with Gi2/1/1 and will be suspended (Broadcast suppression: Level of Gi2/0/1 is 10.00%, 10.00%. Level of Gi2/1/1 is not configured.) (switch2)

000097: Apr 10 06:57:24: %EC-5-CANNOT_BUNDLE2: Gi2/0/4 is not compatible with Gi2/1/3 and will be suspended (Broadcast suppression: Level of Gi2/0/4 is 10.00%, 10.00%. Level of Gi2/1/3 is not configured.) (switch2)

000098: Apr 10 06:57:24: %EC-5-CANNOT_BUNDLE2: Gi2/0/3 is not compatible with Gi2/1/3 and will be suspended (Broadcast suppression: Level of Gi2/0/3 is 10.00%, 10.00%. Level of Gi2/1/3 is not configured.) (switch2)

it seems that the old config, which was associated to the gigabit 2/0/1 - 4 uplink ports, is now active on the new switch - but these are now configured as access ports.

i tried to remove the Portchannel 1 -> reassociated to the Uplink ports -> no changes on this behaviour

i tried default interface giga 2/0/1...4 -> not ok

i replaced the switches when the whole stack was running... should i try to reload the whole stack?

other ideas?

thanks.

1 Accepted Solution

Accepted Solutions

Leo Laohoo
Hall of Fame
Hall of Fame

Try this:

default interface range Gig 2/0/1 , Gig 2/1/1

interface range Gig 2/0/1 , Gig 2/1/1

switchport encap dot

switchport mode trunk

switchport non

channel-group 1 mode active

View solution in original post

3 Replies 3

Leo Laohoo
Hall of Fame
Hall of Fame

Try this:

default interface range Gig 2/0/1 , Gig 2/1/1

interface range Gig 2/0/1 , Gig 2/1/1

switchport encap dot

switchport mode trunk

switchport non

channel-group 1 mode active

hi leolaohoo,

thx!

it seems that the configuration was not visible under the interfaces. also the default interface was not able to reset the interface to a NULL configuration.

i've done:

int ran g2/0/1 - 4

switchport encap dot

switchport mode trunk

switchport non

channel-group 1 mode active

removed the uplink config and config as an access switchport

int ran g2/0/1 - 4

no switchport mode trunk

no switchport non

no channel-group 1 mode active

sw mo ac

no switchport encap dot

thats it!

thanks!

Konrad.

Glad to be of some form of assistance.  Thanks for the ratings Konrad.

Review Cisco Networking for a $25 gift card