Showing results for 
Search instead for 
Did you mean: 
Michael Kline

3750 Switch cycling

I have a 3750-48TS switch that has a port that is constantly cycling amber to green to amber etc.  I currently have the port set for 100/full and have verified the workstation is also set for 100/full on the NIC.  I have tried setting the port to auto/auto, but the port continues to cycle.  All of my other ports are fine.  What can be causing the cycling of the port?


how is configured your port in access mode in trunk mode? What about log on your switch do you see some error or log information can help this behavior?

Port is in access mode.  The sh int shows no errors.

From what Favio suggested, can you look in the log and post the specific error messages you are seeing with this cycling port? Can you also post the configuration for this specific port?

I cannot post the configuration, this is for a isolated DOD network.  The only errors I see is the port changing state to up and down.

Ok, I wouldn't post anything from an isolated DOD network as well

When you look at the log do you see the logs for the interface going up and down?

Does the port have port security or anything configured on it?

It could be a bad port, but you would expect to see some FCS or CRC errors.

Have you tried a different cable and or port?

I switched ports and it continues to cycle.  I do see the logs showing the interfaces going up and down.  There is no port security configured.  I have a few CRC errors, but the errors are not incrementing as the port cycles.

Have you tried on same port to connect with a laptop? do the same things? The workstation connected on that port work correctly and is only a problem of led?

If you reset the counters on that interface do the CRC errpors come back? Also, is this cable connected to a patch cable or just connected directly to a PC?


sounds like a faulty cable or faulty nic card if all everything else I as standard on the switch port such as speed duplex access port and portfast suggest as suggested before stick a laptop in the same port and see if it occurs if that fails the port on the switch could be faulty. We have had the same issues before on 3750 switches

Sent from Cisco Technical Support iPhone App

The PC is directly conneted to the switch by CAT5.  I have tried using a couple of different machines on the same port (f1/0/1) and have no problem connecting.  I am feeling like I am having a NIC problem?  Does that seem right?

Leo Laohoo
VIP Community Legend

 I currently have the port set for 100/full and have verified the workstation is also set for 100/full on the NIC.

Can you please post the output to the following command:

1.  sh interface ; and

2.  sh controll e

It looks like a bad NIC Michael.

i agree..

Thanks for assistance....