cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1695
Views
0
Helpful
6
Replies
Highlighted
Beginner

3750G Won't factory default. help?

Hello everyone.

I have a 3750G that used to be a Stack Master of a stack comprised of 2 identical switches. Since then, we have removed the stack from production, and I factory defaulted the stack MEMBER and that went fine. I just held the "Mode" button on the front until the lights all lit up and then issued the reload command and the switch came back with no configuration OTHER than the vlan database I issued the "del vlan.dat" command to no avail. I just manually removed all the vlans.

The stack MASTER on the other hand will NOT go back to factory defaults, and will also NOT erase the vlan database. Everything I try will NOT work. I've tried the following

1) Hold mode button & issue a reload after the lights start flashing

2) issue "Write Erase" then issue "reload"

3) issue "Write Erase", then issue "Write", then issue "reload"

4) issue "erase start" then issue "reload" (just in case the "write erase" command is being depriciated or something weird)

5) issue "erase start" then issue "copy run start" then issue "reload"

Is there a special way to reset a StackMaster back to factory defaults?

Any input would help!

Everyone's tags (3)
6 REPLIES 6
Frequent Contributor

3750G Won't factory default. help?

You can delete all the vlans easily by doing this:

conf t

!

no vlan 2-4094

How did you unstack them?  Did you use the "no switch 2 provision", "no switch 1 provision" commands?

Now when you say that it won't go back to the default config what exactly do you mean?  After you do "erase start" and reload it should not have the previous configuration on it.  Once you issue the reload command it should ask you this:

System configuration has been modified. Save? [yes/no]: "Did you type (no) here?"

3750G Won't factory default. help?

Mohammad, I actually have a 3750x that still thought of itself as switch two in a stack no matter what I did. I tried the "no switch provision" commands and also deleted EVERYTHING in flash, reloaded, still shows up as switch 2 in the stack.

It's not a big deal since it still functions the same, just annoying...

It is in production now so there isn't anything I can do about it but was just wondering if there was something else I should have tried...

Frequent Contributor

3750G Won't factory default. help?

Should be the same scenario with it, usually after you remove the stack cables you connect to the second switch and run "no switch 1 provision" and on the First one you run "no switch 2 provision"

Now after you reload that second switch you can change the port numbers from 2/x/x to 1/x/x by running the following command "switch 2 renumber 1"

Beginner

3750G Won't factory default. help?

In order to unstack the switches I did issue a "no switch 2 provision" but not a no switch 1 as this is switch 1.

When I issue:

Switch# Write erase

it just asks me to confirm, and says it completes successfully.

When I issue:

Switch# reload

it just asks me to confirm the reload. It does NOT ask me to say yes or no to the config being changed. I wonder if it would only do that with "erase star"?

Let me try all of these suggestions and report back.

3750G Won't factory default. help?

Have you tried just looking in the flash directory "dir flash:"?

There you can find the vlan.dat, config.txt, etc...

Then you just enter "delete (name of file in flash)". Example "delete vlan.dat"

If it is in there as a directory, then you just enter the "delete /force /recursive flash:/(name of file)"

Just DON'T, I repeat DON'T delete the ios files...

Beginner

3750G Won't factory default. help?

Issue, resolved.

I ran a write erase, and it worked. I have no idea why it wasnt working yesterday.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards