cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
968
Views
0
Helpful
2
Replies
Adam Swindell
Beginner

3750X – Bizarre Diagnostic Results

I'm trying to figure out if some Diagnostic failures are real or not. These are 3750x switches, running 12.2(58)SE2.

Story is.... A stack port kept flapping up and down. Replaced the cable, didn't fix the problem.

So I started to look at closer, and run some diagnostics on the switch.

After I've run some diagnostics (diagnostics start switch XX test all) and I get the "TestPortAsicCam --- Failed" result back. So I run it on the other switch in the stack, and I get the same thing. I then went and ran the diagnostic on two separate switches and both came back failed as well. If I re-run the diagnostic on the original two switches sometimes the result comes back failed, and other times it comes back okay. At this point I’m thinking it is a software issue and the hardware is completely fine. I can’t believe that four switches would have the same hardware failure.

So what does everyone else think? An actual issue or not?  I've seen on the Nexus 7000 switches where diagnostics would fail. We ended up RMA-ing several line cards; eventually Cisco came out and said it was actually a software issue giving false positives. I'm sort of thinking I'm seeing a similar issue here as well.

Also, there is no TAC support on these switches so I can't just open a case.

switch-sw#sh diagnostic result switch all

Current bootup diagnostic level: minimal

Switch 1:   SerialNo : FDXXXXXXXX

  Overall Diagnostic Result for Switch 1 : MAJOR ERROR

  Diagnostic level at card bootup: minimal

  Test results: (. = Pass, F = Fail, U = Untested)

    1) TestPortAsicStackPortLoopback ---> .

    2) TestPortAsicLoopback ------------> .

    3) TestPortAsicCam -----------------> F

    4) TestPortAsicRingLoopback --------> .

    5) TestMicRingLoopback -------------> .

    6) TestPortAsicMem -----------------> .

Switch 2:   SerialNo : FDXXXXXXXXX

  Overall Diagnostic Result for Switch 2 : MAJOR ERROR

  Diagnostic level at card bootup: minimal

  Test results: (. = Pass, F = Fail, U = Untested)

    1) TestPortAsicStackPortLoopback ---> .

    2) TestPortAsicLoopback ------------> .

    3) TestPortAsicCam -----------------> F

    4) TestPortAsicRingLoopback --------> .

    5) TestMicRingLoopback -------------> .

    6) TestPortAsicMem -----------------> .

1 ACCEPTED SOLUTION

Accepted Solutions
Wilson Bonilla
Participant

Hello Adam.

Your switches are hitting this bug

GOLD test TestPortAsicCam fails on a 3750x stack 

Symptom:

On demand GOLD test 3 fails on a WS-C3750X stack with the following error message :

%DIAG-3-TEST_FAIL: Switch 6: TestPortAsicCam{ID=3} has failed. Error code = 0x1

(DIAG_FAILURE)

Conditions:

This issue is seen ONLY in Catalyst 3750X running 12.2(58)SE or 15.0(1)SE releases.

This issue is NOT seen in Catalyst 3750G/E or in pre-12.2(58)SE releases.

Workaround:

None

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCtl54262

Regards.

Wilson B.

Please rate useful post!

View solution in original post

2 REPLIES 2
Wilson Bonilla
Participant

Hello Adam.

Your switches are hitting this bug

GOLD test TestPortAsicCam fails on a 3750x stack 

Symptom:

On demand GOLD test 3 fails on a WS-C3750X stack with the following error message :

%DIAG-3-TEST_FAIL: Switch 6: TestPortAsicCam{ID=3} has failed. Error code = 0x1

(DIAG_FAILURE)

Conditions:

This issue is seen ONLY in Catalyst 3750X running 12.2(58)SE or 15.0(1)SE releases.

This issue is NOT seen in Catalyst 3750G/E or in pre-12.2(58)SE releases.

Workaround:

None

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCtl54262

Regards.

Wilson B.

Please rate useful post!

View solution in original post

Thanks.