cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
326
Views
0
Helpful
3
Replies
Highlighted
Beginner

3850- 16.12.3a snmp delays

We have been upgrading our 3850's to the 16.12.3a but have run into issues with polling hardware status in Solarwinds. When I looked into it further I discovered SNMP Delayed messages. I found numerous bugs for different values and tried applying SNMP views blocking them but all it did was delay another oid, by the time I stopped I had blocked all the environmental/hardware sensors

Example of one I see

%SNMP-3-RESPONSE_DELAYED: processing GetNext of entSensorType (27086 msecs)

 

I increased the snmp monitor timeout value to the max in the switch and it still goes beyond that as you can see above. I opened a case with solarwinds for my hardware polling issues and when we do SNMP walks it shows the hardware OID's missing which makes sense since its being delayed on the switch and is not processing the request. 

 

Has anyone else seen this behavior on their switches or have a work around?

3 REPLIES 3
Highlighted
Hall of Fame Community Legend


@AdamF1 wrote:

%SNMP-3-RESPONSE_DELAYED: processing GetNext of entSensorType (27086 msecs)


Use the following command: 

no snmp monitor response
Highlighted

I never did that one as from my understanding itjust disables the message from appearing and pinpointing the particular snmp delay issue.

Highlighted

I went ahead and applied that command a while back and it did as I thought it would and just suppress the message. It did not clear my polling issue. Solarwinds has stated this is a Cisco issue and I am inclined to actually believe them at this point. Doing the MIB walks we can see the missing OID's which is because they are timing out when trying to poll due to the delay.

I have started experiencing this same behavior on the 9500C's running 16.11.1 where others the others running the same code don't have the issue. 

I have looked all over the forums and everything states its a cosmetic bug and to disable the view or disable the logging alerts which only hides the issue. 

 

Is there no one else out there experiencing this issue and having difficulty polling stats from hardware due to this? 

Maybe my issue will magically resolve when I upgrade my solarwinds server? 

 

Anyone out there running 16.12.3a on their 3850's and are able to successfully poll them with solarwinds?

If so what version of NPM are you running and are you using any custom pollers? 

Content for Community-Ad