cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
410
Views
0
Helpful
3
Replies
Highlighted
Beginner

3850 marking dscp ef to af21

I have a yealink t46g phone (or some similar model) connected to a 3560X48PS.  That is then connected via a port-channel to a 385024te.  I can take a capture at the back of the phone.  This gives me what the phone believes it is receiving and sending.  At this point the phone is sending rtp marked with dscp ef.  The phone is receiving (from my SIP provider) rtp packets marked dscp af21.

I take a capture on the voice vlan on the router/3850.  I see the same behavior.

I take a capture on the uplink to the core of our network on the 3850 and I see rtp packets from my provider marked with dscp ef, and rtp packets from the phone marked with dscp af21.

How can I get dscp ef to pass unscathed through this router?

3850:

int g1/1/2

description UpLink to Core
switchport trunk native vlan <snip>
switchport trunk allowed vlan <snip, snip>
switchport mode trunk
auto qos trust dscp
service-policy input AutoQos-4.0-Trust-Dscp-Input-Policy
service-policy output AutoQos-4.0-Output-Policy

interface Vlan801
description Sip Provider's Phones
ip dhcp relay information trusted
ip address 10.12.36.1 255.255.255.192
ip helper-address 192.168.8.15
ip helper-address 192.168.8.16
no ip proxy-arp

bldg-ge-385024te-dl-87#show policy-map AutoQos-4.0-Trust-Dscp-Input-Policy
Policy Map AutoQos-4.0-Trust-Dscp-Input-Policy
Class class-default
set dscp dscp table AutoQos-4.0-Trust-Dscp-Table
sikes-ge-385024te-dl-87#show policy-map AutoQos-4.0-Output-Policy
Policy Map AutoQos-4.0-Output-Policy
Class AutoQos-4.0-Output-Priority-Queue
priority level 1 30 (%)
Class AutoQos-4.0-Output-Control-Mgmt-Queue
bandwidth remaining percent 10
queue-limit dscp cs2 percent 80
queue-limit dscp cs3 percent 90
queue-limit dscp cs6 percent 100
queue-buffers ratio 10
Class AutoQos-4.0-Output-Multimedia-Conf-Queue
bandwidth remaining percent 10
queue-buffers ratio 10
Class AutoQos-4.0-Output-Trans-Data-Queue
bandwidth remaining percent 10
queue-buffers ratio 10
Class AutoQos-4.0-Output-Bulk-Data-Queue
bandwidth remaining percent 4
queue-buffers ratio 10
Class AutoQos-4.0-Output-Scavenger-Queue
bandwidth remaining percent 1
queue-buffers ratio 10
Class AutoQos-4.0-Output-Multimedia-Strm-Queue
bandwidth remaining percent 10
queue-buffers ratio 10
Class class-default
bandwidth remaining percent 25
queue-buffers ratio 25

bldg-ge-385024te-dl-87#show table-map AutoQos-4.0-Trust-Dscp-Table
Table Map AutoQos-4.0-Trust-Dscp-Table
default copy

3 REPLIES 3
Highlighted
Collaborator

Sorry, but are you saying

Sorry, but are you saying that the 3850 is changing the the DSCP from EF to AF21 from the provider to the VoIP phone and changing it from the EF to AF21 from the VoIP phone to the provider on the uplink to the core?

Something doesn't sound right. It is strange that the EF and AF21 in the same packet stream are being flipped.  Can you verify that the trace to the core is accurate? If what you are seeing is happening, it's either a bug or something else in the configuration. The information given isn't enough to provide any suggestions, but if you want to provide a sanitized config and even a diagram it may help.

Highlighted
Beginner

So, I resolved this issue, ..

So, I resolved this issue, ...but I'm not sure why what I did fixed it (or was necessary at least).

I added the same service-policy(s) that are on g1/1/2 to vlan 801.  When I did that, it passed ef all the way through.  

My concern is why without a service policy applied, it was being rewritten in the first place.  Not stripped entirely, but rewritten/mangled/mutated.

Collaborator

Glad it is working, but I

Glad it is working, but I agree in that it doesn't make much sense. You may have put a band-aid on a bug. Thanks for the update. If you have anymore issues reply to this post with a config if you want and I'll take a look.

Regards

CreatePlease to create content
Content for Community-Ad