cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

224
Views
5
Helpful
14
Replies

4331 with SM-X-ES3-24-P TFTP socket error

Hello,

 

I have 4331 with SM-X-ES3-24-P switching module and Im trying to copy running config in and out using TFTP. Everything is fine on router but when I try it from switch it says socket error. Thank you for any advice!!

14 REPLIES 14
Hall of Fame Community Legend

Re: 4331 with SM-X-ES3-24-P TFTP socket error

Socket error = trying to transfer something that doesn't have an IP address
VIP Advisor

Re: 4331 with SM-X-ES3-24-P TFTP socket error

Have you checked from Switch, is the TFTP Server IP reachable?

 by pinging?

BB
*** Rate All Helpful Responses ***

Re: 4331 with SM-X-ES3-24-P TFTP socket error

I have vlan 30 with ip 10.1.3.1 on router and Im connected to swich interface gig0/24 via putty ssh or COM. This switch  interface is has access vlan 30. Host PC is 10.1.3.10 .. Copy tftp works fine.. does switch need any other special configuration?

VIP Advisor

Re: 4331 with SM-X-ES3-24-P TFTP socket error

Trying to understand the problem, once you connected to the router it was working, what is the issue? what switch configuration you were looking?

 

BB
*** Rate All Helpful Responses ***

Re: 4331 with SM-X-ES3-24-P TFTP socket error

I need to copy config from TFTP from my PC to router. Im connected through Putty SSH via gig0/24 which is switch interface because I have vlan 30 on my router and gig0/24 on switch is in this vlan.I enter command copy tftp: flash: on router and everything is fine. Then I connect to switch card in my router by entering command hw-module session 1/0 and when I try to copy tftp: flash: on switch it says socket error.
VIP Advocate

Re: 4331 with SM-X-ES3-24-P TFTP socket error

Hi,

I've seen a socket error when doing TFTP when the switch has either no IP address or is on the wrong subnet as the TFTP server. I also recommended to check the Routing on the Switch as well.

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!

Re: 4331 with SM-X-ES3-24-P TFTP socket error

I think that IP addresses are fine because I can copy TFTP via switch to router. How can I ping from switch to TFTP server on PC?
VIP Advocate

Re: 4331 with SM-X-ES3-24-P TFTP socket error

Hi,

Have you set up any username and password on the TFTP server? Share your switch configration.

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!

Re: 4331 with SM-X-ES3-24-P TFTP socket error

here is my config of switch... im connected from PC to switch via interface gig0/24 which is in vlan 30. Router has interface vlan 30 IP 10.1.3.1 and PC has 10.1.3.10 which is host on TFTP.
Last two port gig0/25 and gig0/26 trunk because of communication to router from switch card.
I made ip tftp source-interface GigabitEthernet0/24 aswell as you can see..


!
! Last configuration change at 03:49:36 UTC Mon Jan 2 2006 by cisco
!
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname SWITCH
!
boot-start-marker
boot-end-marker
!
enable secret 5 ....................
!
username cisco privilege 15 secret 5 .....................
no aaa new-model
system mtu routing 1500
!
!
ip domain-name ........................
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-3265677184
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3265677184
revocation-check none
rsakeypair TP-self-signed-3265677184
!
!
crypto pki certificate chain TP-self-signed-3265677184
certificate self-signed 01
...............................
.............
..............
................
....................
...................
quit
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
ip tftp source-interface GigabitEthernet0/24
ip ssh version 2
!
!
!
!
!
interface GigabitEthernet0/1
switchport access vlan 30
!
interface GigabitEthernet0/2
switchport access vlan 30
!
interface GigabitEthernet0/3
switchport access vlan 30
!
interface GigabitEthernet0/4
switchport access vlan 30
!
interface GigabitEthernet0/5
switchport access vlan 30
!
interface GigabitEthernet0/6
switchport access vlan 30
!
interface GigabitEthernet0/7

switchport access vlan 30
!
interface GigabitEthernet0/8

switchport access vlan 30
!
interface GigabitEthernet0/9

switchport access vlan 30
!
interface GigabitEthernet0/10

switchport access vlan 30
!
interface GigabitEthernet0/11

switchport access vlan 30
!
interface GigabitEthernet0/12
switchport access vlan 30
!
interface GigabitEthernet0/13
switchport access vlan 30
!
interface GigabitEthernet0/14
description SCD RED
switchport access vlan 30
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport trunk allowed vlan 1-30
switchport mode trunk
speed 100
duplex full
no keepalive
!
interface GigabitEthernet0/15

switchport access vlan 30
!
interface GigabitEthernet0/16

switchport access vlan 30
!
interface GigabitEthernet0/17

switchport access vlan 30
!
interface GigabitEthernet0/18

switchport access vlan 30
!
interface GigabitEthernet0/19

switchport access vlan 30
!
interface GigabitEthernet0/20

switchport access vlan 30
!
interface GigabitEthernet0/21
description NAS
switchport access vlan 40
switchport mode access
!
interface GigabitEthernet0/22
description SRV2
switchport access vlan 40
switchport mode access
!
interface GigabitEthernet0/23
description SRV1
switchport access vlan 40
switchport mode access
!
interface GigabitEthernet0/24
switchport access vlan 30
!
interface GigabitEthernet0/25
switchport trunk encapsulation dot1q
switchport mode trunk
switchport protected
!
interface GigabitEthernet0/26
switchport trunk encapsulation dot1q
switchport mode trunk
switchport protected
!
interface Vlan1
no ip address
!
interface Vlan30
no ip address
!
interface Vlan40
no ip address
!
ip http server
ip http secure-server
!
!
!
line con 0
login local
flowcontrol software
line vty 0 4
logging synchronous
login local
transport input ssh
line vty 5 15
login
!
!
end

Highlighted
VIP Advisor

Re: 4331 with SM-X-ES3-24-P TFTP socket error

looks for me now it is configuration issue :

 

look at the config guide and make config appropriate or post full configuration to have look at what is wrong?

 

https://www.cisco.com/c/en/us/td/docs/routers/access/interfaces/eesm/software/configuration/guide/4451_config.html

BB
*** Rate All Helpful Responses ***

Re: 4331 with SM-X-ES3-24-P TFTP socket error

So here is my switch config.I connect to switch from router by using command hw-module session 1/0. I have vlan 30 on router with IP 10.1.3.1 255.255.255.0 .PC has IP 10.1.3.10 255.255.255.0 which is host IP on TFTPd64 server.

Last two ports gig0/25 and gig0/26 are trunk because of connectivity from switch card to routed. Im connected via switch interface gig0/24 through SSH or console cable. I can transfer files just to or from router, when i try to transfer to switch it says socket errror... I had problems with router but I added command ip tftp source-interface GigabitEthernet0/24 and it started working.. but just on router.. not switch..

TFTP security on TFTP setting is NONE, address is set, base directory aswell.. firewall off, no antivirus... 

 

Is it posible to transfer files from router to switch card by using some other way? Because I can send config to router and then send it to switch if it is possible... THANK YOU SO MUCH FOR YOUR TIME!


!
! Last configuration change at 03:49:36 UTC Mon Jan 2 2006 by cisco
!
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname switchhh
!
boot-start-marker
boot-end-marker
!
enable secret 5 .....................................
!
username cisco privilege 15 secret 5 ..........................
no aaa new-model
system mtu routing 1500
!
!
ip domain-name pindour.com
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-3265677184
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3265677184
revocation-check none
rsakeypair TP-self-signed-3265677184
!
!
crypto pki certificate chain TP-self-signed-3265677184
certificate self-signed 01
........

........

........

.......

......

9
quit
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
ip tftp source-interface GigabitEthernet0/24
ip ssh version 2
!
!
!
!
!
interface GigabitEthernet0/1
switchport access vlan 30
!
interface GigabitEthernet0/2
switchport access vlan 30
!
interface GigabitEthernet0/3
switchport access vlan 30
!
interface GigabitEthernet0/4
switchport access vlan 30
!
interface GigabitEthernet0/5
switchport access vlan 30
!
interface GigabitEthernet0/6
switchport access vlan 30
!
interface GigabitEthernet0/7
switchport access vlan 30
!
interface GigabitEthernet0/8
switchport access vlan 30
!
interface GigabitEthernet0/9
switchport access vlan 30
!
interface GigabitEthernet0/10
switchport access vlan 30
!
interface GigabitEthernet0/11
switchport access vlan 30
!
interface GigabitEthernet0/12
switchport access vlan 30
!
interface GigabitEthernet0/13
switchport access vlan 30
!
interface GigabitEthernet0/14
switchport access vlan 30
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport trunk allowed vlan 1-30
switchport mode trunk
speed 100
duplex full
no keepalive
!
interface GigabitEthernet0/15
switchport access vlan 30
!
interface GigabitEthernet0/16
switchport access vlan 30
!
interface GigabitEthernet0/17
switchport access vlan 30
!
interface GigabitEthernet0/18
switchport access vlan 30
!
interface GigabitEthernet0/19
switchport access vlan 30
!
interface GigabitEthernet0/20
switchport access vlan 30
!
interface GigabitEthernet0/21
switchport access vlan 40
switchport mode access
!
interface GigabitEthernet0/22
description SRV2
switchport access vlan 40
switchport mode access
!
interface GigabitEthernet0/23
description SRV1
switchport access vlan 40
switchport mode access
!
interface GigabitEthernet0/24
switchport access vlan 30
!
interface GigabitEthernet0/25
switchport trunk encapsulation dot1q
switchport mode trunk
switchport protected
!
interface GigabitEthernet0/26
switchport trunk encapsulation dot1q
switchport mode trunk
switchport protected
!
interface Vlan1
no ip address
!
interface Vlan30
no ip address
!
interface Vlan40
no ip address
!
ip http server
ip http secure-server
!
!
!
line con 0
login local
flowcontrol software
line vty 0 4
logging synchronous
login local
transport input ssh
line vty 5 15
login
!
!
end

VIP Advisor

Re: 4331 with SM-X-ES3-24-P TFTP socket error

Since this Switch module do not have any IP configured you can not have route to reach the TFTP Server.

 

Rather you can do out of the box Linux with expect command, SSH to router and connect to session and get the config and save in the secure place.

BB
*** Rate All Helpful Responses ***

Re: 4331 with SM-X-ES3-24-P TFTP socket error

Thank you so much for this but I have no idea about Linux. Is there any chance to solve problem via SSH or console cable? So I need to assign IP to last ports that are trunking connection between router ( ethinternal 1/0/0,1/0/1) and switch( gig0/25 and 0/26)

Re: 4331 with SM-X-ES3-24-P TFTP socket error

I tried on trunking ports on router ethInternal1/0/0 and 1/0/1 and trunking ports on switch gig0/17 and gig0/18 ti give them access to vlan 10, so they will have IP but its worked only on one pair of them.. They are supposed to work like connection between router and switch.. am I right? Is there any command like COPY from router to switch card or something like that?

Switch is on router like:         

subslot 1/0     switch=SM-X-ES3-16-P

 

I need to copy config from router to switch...

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards