cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
206
Views
0
Helpful
4
Replies
Highlighted
Beginner

4500 Port-Channel Bug - Suggestions

Hello, 

I have a strange issue, that I'm have not been able to nail down, I'll do the best I can to explain this.

 

Background

We have a P2P link between 2 switches, HQ and Data Center. On the DC side, we have configured port channels to our VM environment, an example of the configuration per port is below.

!

int TenGigabitEthernet5/5

switchport trunk native vlan 999

switchport allowed vlan 4, 81-83, 160,600, 601

switchport mode trunk

switchport nonegotiate

channel-group 23 mode on

spanning-tree portfast trunk

!

int TenGigabitEthernet6/5

switchport trunk native vlan 999

switchport allowed vlan 4, 81-83, 160,600, 601

switchport mode trunk

switchport nonegotiate

channel-group 23 mode on

spanning-tree portfast trunk

!

int port-channel23

switchport 

switchport trunk native vlan 999

switchport trunk allowed vlan 4, 81-83. 160,600,601

!

The VM servers belong to vlan 4.

 

The issue here is on one, Port-channel, I'm unable to reach the IP assigned to the VM, from HQ. It's available over the LAN, but not across, the wire. Now the interesting thing is, if I remove a port from the channel, I can reach it.

 

I've comparted the configs and all looks good, and compared the settings on the VM's nothing stands out. This feels like a bug, but lost here, any suggestions would be appreciated.

 

Thansk 

 

!

 

 

 

 

 

4 REPLIES 4
Highlighted
Hall of Fame Expert

Hi,

It could be a bug,

A couple of suggestions,

1-can you delete the Portchannel completely and rebuild it again?

2-If that does not work, can you delete the Portchannel and rebuild it with a new po number?

How other Portchannels are connected to VMS and are working with no issues?

HTH

Highlighted

Hi Reeza,

Thanks, I tried rebuilding the Port-Channels, no luck there, same behavior.

 

They are connected to the VM's the same, but issues are there, one I just discovered, this morning.

 

On the other connections, I can ping, from our core to the VM addresses, but from my pc, they drop. If I kill one of the interfaces that are on the port-channel, then I can ping from my PC and the local core.

 

I agree, it's very buggy behavior, very unusual. 

Highlighted

Hi,

Seems like a load balancing issue. Can you try matching the switch load balancing criteria to the VM. I think the VMs are by default source ip. Also, for testing, you may want to change one of the Portchannel protocol from on on to LACP and see if it changes anything.

HTH 

 

 

Highlighted

Guy, its sounds like a promiscous mode on vm.

Check this link and try it: https://kb.vmware.com/s/article/1004099

obs: do it on host that you having problem.
Jaderson Pessoa
*** Rate All Helpful Responses ***
Content for Community-Ad