cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
749
Views
0
Helpful
5
Replies
JaneLeisure1133
Beginner

6509-E showing up multiple times in CDP neighbor table

We are experiencing an odd issue with CDP on our 6509-E and could use a little help.  On a connected switch the 6509 will show up multiple times in the CDP neighbor table, some ports on the 6509 have this issue and some don't.  Supervisors are WS-SUP720-3B and code is 12.2(33)SXI6.  Example output from show cdp neighbors is below.  Thanks!

 

2960#sh cdp neigh

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,

                  D - Remote, C - CVTA, M - Two-port Mac Relay

 

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

6509-DIST       Gig 0/11          179             R S I  WS-C6509- Gig 4/42

6509-DIST       Gig 0/11          179             R S I  WS-C6509- Gig 4/35

6509-DIST       Gig 0/11          178             R S I  WS-C6509- Gig 3/22

6509-DIST       Gig 0/11          178             R S I  WS-C6509- Gig 4/34

6509-DIST       Gig 0/11          177             R S I  WS-C6509- Gig 2/6

6509-DIST       Gig 0/11          176             R S I  WS-C6509- Gig 4/4

6509-DIST       Gig 0/11          176             R S I  WS-C6509- Gig 1/26

6509-DIST       Gig 0/11          175             R S I  WS-C6509- Gig 3/26

6509-DIST       Gig 0/11          175             R S I  WS-C6509- Gig 3/45

6509-DIST       Gig 0/11          174             R S I  WS-C6509- Gig 1/17

6509-DIST       Gig 0/11          174             R S I  WS-C6509- Gig 1/21

6509-DIST       Gig 0/11          173             R S I  WS-C6509- Gig 3/47

6509-DIST       Gig 0/11          173             R S I  WS-C6509- Gig 1/45

6509-DIST       Gig 0/11          173             R S I  WS-C6509- Gig 4/37

6509-DIST       Gig 0/11          172             R S I  WS-C6509- Gig 1/22

6509-DIST       Gig 0/11          172             R S I  WS-C6509- Gig 4/20

6509-DIST       Gig 0/11          171             R S I  WS-C6509- Gig 4/6

6509-DIST       Gig 0/11          170             R S I  WS-C6509- Gig 3/31

6509-DIST       Gig 0/11          170             R S I  WS-C6509- Gig 3/12

6509-DIST       Gig 0/11          170             R S I  WS-C6509- Gig 1/32

6509-DIST       Gig 0/11          170             R S I  WS-C6509- Gig 9/9

6509-DIST       Gig 0/11          171             R S I  WS-C6509- Gig 2/9

 

Total cdp entries displayed : 22

5 REPLIES 5
Jaderson Pessoa
Engager

please,

share here:
show run int gi 0/11

show cdp entry *
Jaderson Pessoa
*** Rate All Helpful Responses ***
Richard Burts
Hall of Fame Guru

I agree with @Jaderson Pessoa that seeing the config of the interface on the 2960 will be helpful. I think it might also be helpful to see the config of at least a couple of interfaces from the 6509 (for example Gig4/32 and Gig4/35).

 

HTH

 

Rick

HTH

Rick

The interfaces on either side were configured very minimally as trunk ports.  On the 2960, something like:

 

switchport

switchport mode trunk

 

On the 6509:

 

switchport

switchport trunk encap dot1q

switchport mode trunk

 

We used this simplified config for testing.  When we first encountered this problem the interfaces on this 6509 and on a Nexus 7K were configured as trunk ports in a L2 portchannel.  It was still a pretty simple configuration though.  

 

On the 7K:

interface e3/1

switchport
switchport mode trunk
switchport trunk native vlan 14
switchport trunk allowed vlan 5,10,14,19,21,94,170-171,192,207
switchport trunk allowed vlan add 254,750-752,1064-1074,1096-1097
switchport trunk allowed vlan add 2312
mtu 9216
channel-group 40 mode active
no shutdown

 

interface port-channel40
switchport
switchport mode trunk
switchport trunk native vlan 14
switchport trunk allowed vlan 5,10,14,19,21,94,170-171,192,207
switchport trunk allowed vlan add 254,750-752,1064-1074,1096-1097
switchport trunk allowed vlan add 2312
mtu 9216
vpc 40

 

On the 6509:

interface g2/1

switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 14
switchport trunk allowed vlan 5,10,14,19,94,170,171,192,207,254,750-752,1064
switchport trunk allowed vlan add 1065,1069-1072,1097,2312
switchport mode trunk
mtu 9216
channel-group 40 mode active

 

interface port-channel 40

switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 14
switchport trunk allowed vlan 5,10,14,19,94,170,171,192,207,254,750-752,1064
switchport trunk allowed vlan add 1065,1069-1072,1097,2312
switchport mode trunk
mtu 9216
spanning-tree guard none

 

Thanks!

ok..

please, shere here
on 6509
show run int gi 0/11
show cdp entry *
show etherc summ
Jaderson Pessoa
*** Rate All Helpful Responses ***
Leo L
VIP Community Legend

Physically trace the link between the two switches. I suspect there is a Layer 2 bridge in between.