cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
135
Views
0
Helpful
1
Replies
Highlighted
Beginner

7841 Phone not recognizing Voice VLAN

I am running into an issue with getting NEW Cisco 7841 phones to register with Call Manager. Investigation shows the phones are not recognizing the voice VLAN.

Here is a config snippet that has worked with 250 7900 series phones for 8 years:

interface GigabitEthernet1/0/16
description PHONE-PC PORT
switchport access vlan 109
switchport trunk encapsulation dot1q
switchport trunk native vlan 109
switchport mode trunk
switchport voice vlan 209
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!

What I have found is that if I remove the line "switchport trunk native vlan 109" the phone registers with the voice VLAN and everything seems to work properly.

Here are my questions:

1/ What has changed between the old 7900 series phones and the NEW 7800 series

2/ What is the proper way to correct this?

3/ By removing the "Native VLAN" from the switchport, does that mean the PC will now be forced into VLAN 1?

Thanks,

Brian

1 REPLY 1
Highlighted
Hall of Fame Expert

Hi,

You don't need a trunk port. So, just need a voice vlan and a data vlan, which you already have defined. So, you can just delete these 3 command and it should work fine.

 

switchport trunk encapsulation dot1q
switchport trunk native vlan 109
switchport mode trunk

HTH

Content for Community-Ad