cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

363
Views
0
Helpful
2
Replies
Highlighted
Beginner

871 Set up fails

I dont understadn how this works but basically I have enabled dhcp or so I thought bu clients dont get a lease.  The vlan does but clients connecting to the switchports attached to the vlan do not get a lease and cant connect to anything.  If I static the ip or use my server to issue dhcp then it's fine still some issues since I am cluceless but I dont understand what I have to do to get dhcp to work on the fa0-3 ports.

Router#sh running-config

Building configuration...

Current configuration : 1015 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

!

!

dot11 syslog

ip source-route

!

!

!

ip dhcp pool local

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   dns-server 192.168.2.1

   lease 8

!

!

ip cef

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface Vlan1

ip address dhcp

ip nat inside

ip virtual-reassembly

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

ip dns server

!

!

!

!

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end

1 ACCEPTED SOLUTION

Accepted Solutions
Advocate

871 Set up fails

James,

Can you try this:-

!
ip dhcp excluded-address 192.168.2.1
!
interface Vlan1
shut
no ip address dhcp
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
no shut
!

Clients on fas int 0 - 3
should now obtain an addreess from this router
in the range/scope

192.168.2.2 - 254


show ip dhcp bind

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
2 REPLIES 2
Advocate

871 Set up fails

James,

Can you try this:-

!
ip dhcp excluded-address 192.168.2.1
!
interface Vlan1
shut
no ip address dhcp
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
no shut
!

Clients on fas int 0 - 3
should now obtain an addreess from this router
in the range/scope

192.168.2.2 - 254


show ip dhcp bind

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Beginner

871 Set up fails

Sir you indeed are correct.  As I said I am pretty new.  Added this and copy run start reload and was back in business.  A few simple additions for nating the vlan and was out to the web.  I can read with the best of them but seems not to many people using cisco at cli that wouldn't know this without google.  :-)  Thanks again. 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards