05-11-2013 03:45 AM - edited 03-07-2019 01:18 PM
Hello,
A cisco noob here. At home I have a small test lab with a 877, this 877 is connectect with the fa0 to my service provider router. I want to configure a DNS server, but when I do I can ping to a DNS name from my 877 but nog from my client. I hope some of you cisco gurus can help me out?
Here is a sh run and screenshots of the ping commando. (ps. I did enter de commando ip domain lookup)
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Geoffrey_Home
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.0.0.1 10.0.0.10
ip dhcp excluded-address 10.0.0.200 10.0.0.254
!
ip dhcp pool NETWORK_10.0.0.0
network 10.0.0.0 255.255.255.0
default-router 10.0.0.254
dns-server 10.0.0.254
!
!
ip host router 10.0.0.254
ip host laptop 10.0.0.11
ip name-server 8.8.8.8
!
!
!
!
username geoffrey privilege 15 secret 5 $1$m2LO$kd/uNJ6UjvMqVtE4RkIpx0
archive
log config
hidekeys
!
!
!
!
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
interface FastEthernet0
switchport access vlan 50
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 10.0.0.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Vlan50
ip address 192.168.2.200 255.255.255.0
ip nat outside
ip virtual-reassembly
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.254
!
ip dns server
!
no ip http server
no ip http secure-server
ip nat inside source list 101 interface Vlan50 overload
!
access-list 101 permit ip 10.0.0.0 0.0.0.255 any
!
!
control-plane
!
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
login local
transport preferred none
transport input ssh
transport output none
!
scheduler max-task-time 5000
end
Translation of the text after the ping request: Ping-request cant find host laptop. Check the name and try again.
Solved! Go to Solution.
05-11-2013 11:28 AM
Hello Geoffrey
That because as stated previously the ip host command is locally significant to the router so it will be able to ping the client however this will not be propagated outside that router
Res
Paul
Sent from Cisco Technical Support iPad App
05-11-2013 03:58 AM
Hi,
Please confirm your PC is using your router as DNS server. How about another record (e.g. router)?
05-11-2013 04:39 AM
Yes it is... and the other record doesnt work also. thats whats weird about it...
05-11-2013 04:43 AM
excusse me... the other record work the same as this one...;)
05-11-2013 04:05 AM
Hello, I can see that you have a host entry in the router
ip host laptop 10.0.0.11
This is almost like adding an entry in to the 'hosts' file on a PC. (its static)
The router is not using DNS in its true sense. If you was to remove that command, it probably wont work, but try it to make sure.
Im not really sure on how to achieve this in ios. But you could just edit the host file on your PC. But obviously this isn't the solution you are looking for.
This might be able to help:
Please rate useful posts and remember to mark any solved questions as answered. Thank you.
05-11-2013 04:42 AM
thanks.... but like you said, this isnt the way i'm looking for.... just want to make this work to practice for CCNA.
05-11-2013 05:16 AM
Hello
I am assuming your dhcp clients are receiving a dhcp address and can ping 8.8.8.8?
if so in your dhcp pool specify your isp dns server addresss instead if the default-gateway
also if you are using hosts file on the client then dont!
one you have ammended the dhcp pool clear the dns from the clients
ipconfig / release
ipconfig / renew
ipconfig / registerdns
res
Paul
Sent from Cisco Technical Support Android App
05-11-2013 05:23 AM
Hello Paul, Will this resolve local hostnames too?
e.g. laptop is able to ping "router" and "laptop"
Please rate useful posts and remember to mark any solved questions as answered. Thank you.
05-11-2013 05:35 AM
Paul, thanks for the reply... but i already did this, this router already has been reboted (i did wr before reboot;))
for my knowledge i did everything right... If i do the ipconfig /all i see that my DNS realy is 10.0.0.254... for the info... the laptop from where i send this ping from is not the laptop with IP 10.0.0.11 ..... it is like the DNS works fine with in the router... but doesnt send his information correctlie to the client... I have already spend google-ing for hours with out result....:S
05-11-2013 05:40 AM
Hellp bilal
to be honest mate in this setup not sure it will
usually i would have an internal dns/wins server to point to if i wanted to acces my internal routers by name.
if you do want the clients to ping this router by then wihout creating a dns/wins server the only option is static hosts file on the cleints
res
paul
Sent from Cisco Technical Support Android App
05-11-2013 05:46 AM
hello geoffrey
are you saying changing the dns server address in your dhcp pool isnt being propergated to the clients
forgive me but would you clarify what is your ultimate goal you would like to acheive?
fyi - ip host x command is ONLY local significant ias far as i am aware t will not be propergated to clients via dhcp
res
paul
Sent from Cisco Technical Support Android App
05-11-2013 08:55 AM
My situation is as following:
Router: 10.0.0.254 (used as DNS)
Client A: 10.0.0.11 (in this case a laptop)
Client B: 10.0.0.12 (in this case a laptop)
My goal is to reach client A from client B by using a DNS.
My practical goal is, when you have a IP phone with default FTP server/pbx adress XXX.XXX.local or something like that, I dont need to to change this manual any more.
But i wanne focus on my goal to reach client A, from client B, by using a DNS. before i go a step further.
05-11-2013 09:18 AM
Hello Geoffrey
thanks for the clarification - i would suggest you then use a specific server to perform the dhcp and dns functions instead if a cisco device although you can run dhcp/dns services there main job is route/switch traffic and adding these serivces like dhcp/dns requires the router/switch to alocate cpu/ memory towards them.
The benefit of say Windows server doing the job is:
dns/dhcp and client intergration with or without active directory
more manageable
less resource requests on the router/switch to run these service
and last but no least resiliency of these services through primary and secondary servers
hope this helps
res
paul
Sent from Cisco Technical Support Android App
05-11-2013 10:44 AM
I will take this into consideration but some times this is not possible. Also i still think its a little but strange that is can ping the DSN name from out the 877 and not from the client... I know its a little bit stubborn of me... but I just want to have it work... so I know it can;)
05-11-2013 10:51 AM
What DNS name are you pinging -The router itself from the router?
Res
Paul
Sent from Cisco Technical Support iPad App
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide