cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
845
Views
0
Helpful
4
Replies

887VAW - WLAN to wired routing

LSIArchitects
Level 1
Level 1

Hi

I am at a relatively basic level when it come to cisco routers, but I want to learn more.

I have aquired a 887VAW. I have successfully configured it to connect to my DSL line etc and works a treat.

What I am struggling to do is have the WLAN traffic join the wired traffic. But I just cant get anywhere.

I dont yet have a config for the wlan side of things.

Please could someone point me in the right direction, and perhaps explain how the wlan and wired work together.

Many thanks,

Rich.

4 Replies 4

Daniel Boling
Level 1
Level 1

Richard,

Your router has many different types of interfaces (WAN interface(s), switch ports, wireless radio's, etc.)  You can create a BVI (Bridge Group Virtual Interface) to interconnect your integraded wireless radio and switch ports.  Below is sample code from another post I made, which whould be a good example for you to work with.  If you are still having issues, please post your config so we can assist you further.

! Create an SSID and broadcast:

dot11 ssid MY_SSID

vlan 1

   authentication open

   authentication key-management wpa

   guest-mode

   wpa-psk ascii MY_PASSWORD

! Configure the physical interface, assuming you have a Dot11Radio0 interface

interface Dot11Radio0

no shutdown

no ip address

encryption vlan 1 mode ciphers tkip

ssid MY_SSID

! Configure a subinterface

interface Dot11Radio0.1

encapsulation dot1Q 1 native

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

! Configure a BVI, where x.x.x.x x.x.x.x is your LAN gateway IP address and subnet mask

interface BVI1

ip address x.x.x.x x.x.x.x

ip nat inside

ip virtual-reassembly

! Modify your VLAN configuration

interface Vlan1

no ip address

ip nat inside

ip virtual-reassembly

bridge-group 1

bridge-group 1 spanning-disabled

! Other commands

bridge 1 route ip

Hi,

I dont seem to have the same wlan interface as you list there.....

Here is my config (sanitised) that will help identify how its working with my router.

I am not overly keen on CLI and I have got to where I am so far with CCP.

Thanks for your help.

Building configuration...

Current configuration : 4405 bytes

!

! Last configuration change at 16:41:04 UTC Thu May 30 2013 by admin

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname yourname

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

!

no aaa new-model

!

crypto pki trustpoint TP-self-signed-167107849

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-167107849

revocation-check none

rsakeypair TP-self-signed-167107849

!

!

crypto pki certificate chain TP-self-signed-167107849

certificate self-signed 01

  30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31363731 30373834 39301E17 0D313330 35323931 36333732

  345A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F

  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3136 37313037

  38343930 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100

  D8958879 96334023 C7721348 1070DC4D F442926E DAE3EEA6 BD3FD99D 8BDD34BD

  D9166C58 0AFD5374 58854B14 39C946E3 0775A4D5 F336EE41 559AFE00 8508F5B3

  5398CC8A BA4795E4 BDD3EA71 DCF22348 DE4F6828 DBD88D55 0F53037B 470CBBE4

  A9CF6F65 BAB60AC7 A8E02AFB 7A38D3C3 F92FA6AB AAA25363 0DECA681 2B413FF7

  02030100 01A35330 51300F06 03551D13 0101FF04 05300301 01FF301F 0603551D

  23041830 16801405 E9EE264C 7C8E111D C6EB5E0A F1E8532E 705A1430 1D060355

  1D0E0416 041405E9 EE264C7C 8E111DC6 EB5E0AF1 E8532E70 5A14300D 06092A86

  4886F70D 01010505 00038181 0071FD97 96103D51 213D90F9 9372AC15 13868C6C

  F78366C9 002017A3 4B87CAFF 2C5CF4BA 04E21D3F DBE36F98 897E8A83 CA7D5E1B

  B4F7CC8F 07DEF31B F05A34C9 DA12F3DF 1157C4C5 D9F20E32 7EFE6C78 DBBBD750

  8B1CC4D9 875E8F14 ED779D5C A843BCA7 0EB9C19A 20D07B82 7A7C0CF2 53962CE5

  344F955F 3294E963 7481775C 51

      quit

ip cef

!

!

!

!

!

!

ip domain name yourdomain.com

ip name-server 89.145.254.78

ip name-server 94.30.127.100

no ipv6 cef

!

!

license udi pid C887VA-W-E-K9 sn FCZ171793S5

!

!

!

!

!

!

!

controller VDSL 0

!

!

!

!

!

!

!

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

!

interface ATM0.1 point-to-point

description Daisy

pvc 0/38

  pppoe-client dial-pool-number 1

!

!

interface Ethernet0

no ip address

shutdown

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface Wlan-GigabitEthernet0

description Internal switch interface connecting to the embedded AP

switchport mode trunk

no ip address

!

interface wlan-ap0

description Service module interface to manage the embedded AP

ip unnumbered Vlan1

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 10.0.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1412

!

interface Dialer0

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname

ppp chap password

ppp pap sent-username

ppp ipcp dns request

no cdp enable

!

ip forward-protocol nd

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat inside source list 199 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

!

access-list 23 permit 10.0.0.0 0.0.0.255

access-list 23 permit any

access-list 199 permit ip any any

dialer-list 1 protocol ip permit

no cdp run

!

!

!

line con 0

login local

no modem enable

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

stopbits 1

line vty 0 4

access-class 23 in

privilege level 15

login local

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

!

end

interface wlan-ap0

description Service module interface to manage the embedded AP

ip unnumbered Vlan1

The configuration needed by your router will be different than my example above.  You need to log into the module to configure wireless settings.  Please refer to these documents:

http://www.cisco.com/en/US/docs/routers/access/1900/software/configuration/guide/wlan.html

http://www.cisco.com/en/US/docs/routers/access/800/880/software/configuration/guide/880_basic_device_wireless_config.html

LSIArchitects
Level 1
Level 1

Hi,

It appears I had a duff router, so opened a TAC and already have the replacement in place.

Thanks for your help.

Review Cisco Networking products for a $25 gift card