cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
290
Views
5
Helpful
4
Replies
mgsuzen
Beginner

9200L high availability

Hi;

 

I have 2 cisco 9200L switches and I cross connected them with Stack cables (1 to 2 - 2 to 1). 

 

Switch#   Role    Mac Address     Priority Version  State 

-------------------------------------------------------------------------------------

*1       Active   ac4a.6543.4c00     1      V01     Ready                

 2       Standby  b67c.d5a0.6a00     1      V01     Ready                

 

Sw#/Port#  Port Status  Neighbor  Cable Length   Link OK   Link Active   Sync OK   #Changes to LinkOK  In Loopback 

-------------------------------------------------------------------------------------------------------------------

1/1        OK           2         50cm           Yes       Yes           Yes       2                   No           

1/2        OK           2         50cm           Yes       Yes           Yes       2                   No           

2/1        OK           1         50cm           Yes       Yes           Yes       1                   No           

2/2        OK           1         50cm           Yes       Yes           Yes       1                   No    

 

I don't think there's a problem until this part.

 

I want to configure the devices as HA.

When one device breaks down, I want it to continue without interruption from the other.

I couldn't figure out how to do this configuration.

 

When I connect with the console and run the sh run; I see all the ports;

gig1/0/1 to gig1/0/48 and gig2/0/1 to gig2/0/48

 

Don't I just have to see only the starts gig1/0/... ports for HA ?

 

for example;

 

I defined vlan10 access for port 10; how can i define that gig1/010 or gig2/0/10 or how

 

 

 

 

 

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi there,

you would connect your device in one of three ways:

 

1) Active/ Passive network interface:

snip01.PNG

 

! 
hostname switch01
!
int range gi1/0/10, gi2/0/10
  switchport mode access
  switchport access vlan 10
  no shut
!

The device would detect when eth0 is down and begin forwarding on eth1.

 

 

2) Active/ Active with LACP

snip02.PNG

!
hostname switch01
!
int range gi1/0/10, gi2/0/10
  channel-group 1 mode active
  no shut
!
int po1
  switchport mode access
  switchport access vlan 10
!

The device would need to have eth0 and eth1 bundled and be using LACP.

 

3)  Single attached to one switch in the stack

snip03.PNG

!
hostname switch01
!
int gi1/0/10
  switchport mode access
  switchport access vlan 10
  no shut
!

The least resilient option. Failure of the cable or of switch01-1 would cause device01 to lose all connectivity.

 

cheers,

Seb.

 

View solution in original post

4 REPLIES 4
Seb Rupik
VIP Advisor

Hi there,

In a stack all member switches are Active with regards to forwarding, there is no concept of Active/ Passive. The output you are seeing Gi1/x/x and Gi2/x/x is expected.

 

The resiliency of this design is gathered by using connections which span multiple switches in the stack. For instance, uplinks to your core/ distribution should be via cables which are connected to different switches in the stack, better still these switchports should be members of the same port-channel.

 

Devices connected to the switch can also benefit by having there Ethernet interfaces connected to different switches, and using port-channels if possible.

By connecting to sperate switches in the stack and failure of the cable or even one switch does not mean that forwarding of frames is impaired. By also using port-channels you also gain additional bandwidth when using multiple streams.

 

cheers,

Seb.

Hi;

Thank you for your interest.

 

For this structure, which I created with 2 switches;

 

should I configure it as follows ?

 

exp.

switch 1 port gig10 access vlan 10

switch 2 port gig10 access vlan 10

 

I need to edit the port of both devices (stack members) in the same way and link to the endpoints from the same port of device 1 and device 2 to end points

 

is that correct ?

 

Hi there,

you would connect your device in one of three ways:

 

1) Active/ Passive network interface:

snip01.PNG

 

! 
hostname switch01
!
int range gi1/0/10, gi2/0/10
  switchport mode access
  switchport access vlan 10
  no shut
!

The device would detect when eth0 is down and begin forwarding on eth1.

 

 

2) Active/ Active with LACP

snip02.PNG

!
hostname switch01
!
int range gi1/0/10, gi2/0/10
  channel-group 1 mode active
  no shut
!
int po1
  switchport mode access
  switchport access vlan 10
!

The device would need to have eth0 and eth1 bundled and be using LACP.

 

3)  Single attached to one switch in the stack

snip03.PNG

!
hostname switch01
!
int gi1/0/10
  switchport mode access
  switchport access vlan 10
  no shut
!

The least resilient option. Failure of the cable or of switch01-1 would cause device01 to lose all connectivity.

 

cheers,

Seb.

 

View solution in original post

you're great, thank you very much.