cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
10314
Views
5
Helpful
7
Replies
Frequent Contributor

Access port shows Amber light

Hi all,

i did this trunk test on switces

Switch A

sh run int fa0/20
Building configuration...

Current configuration : 69 bytes
!
interface FastEthernet0/20
switchport mode dynamic desirable
end

h int fa0/20 switchport
Name: Fa0/20
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: static access******************************************************************************
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

this switch por thas amber light and it is connected to switch B

switch b

sh run int fa0/20
Building configuration...

Current configuration : 81 bytes
!
interface FastEthernet0/20
switchport mode trunk
switchport nonegotiate
end

2950T#sh int fa0/20 swi
2950T#sh int fa0/20 switchport
Name: Fa0/20
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

my question is switch B  port shows as trunk and switch A port shows as static access

why switch B port shows as stativc access as per me it should say dynamic access as we do not hardcore it  to access port ?

also why switch b port has amber  blinking light?

thanks

mahesh

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Access port shows Amber light

Q: thanks for reply  but i do not see any messages in  switch log do you why?

A: You will only see it the when the port fist comes up and goes through spanning tree listen/learn states and you're logging is set up to log this level of message.

You can look at port spanning tree state while the port is amber and it will show as broken due to port inconsistency:

SW3#sh span int f0/24

Vlan                Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
VLAN0001            Desg BKN*19        128.26   P2p *TYPE_Inc

If you shut/no shut the access port that will also trigger the message.

SW3(config)#int f0/24
SW3(config-if)#shut
1d15h: %LINK-5-CHANGED: Interface FastEthernet0/24, changed state to administratively down
SW3(config-if)#no shut
SW3(config-if)#
1d15h: %LINK-3-UPDOWN: Interface FastEthernet0/24, changed state to up
1d15h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up
1d15h: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet0/24 VLAN1.
1d15h: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/24 on VLAN0001. Inconsistent port type.

If you're still not seeing the message logged make sure your logging level is set to debug, increase the size of your logging buffer and make sure you're logging to console.

SW3(config)#logg buff 7
SW3(config)#logg buff 1000000
SW3(config)#logg console 7

To reiterate my earlier statement, your config is not supported.  You can't have mode dynamic on one side and static trunk on the other.

7 REPLIES 7
Highlighted
Cisco Employee

Re: Access port shows Amber light

First - the solid amber light on the 2950 indicates the port is not forwarding:

http://www.cisco.com/en/US/docs/switches/lan/catalyst2950/hardware/installation/guide/hgovrev.html#wp1089458

The reason it is not forwarding is becasue you have a non-supported config.  One side of the link (switch b) is a static trunk and is not running DTP so it is not notifying the far end that it is a trunk.  Switch A has not recevied any DTP frames so he falls back to an access port.  You probably will see log messages similar to this on switch A:

23:00:10: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet0/24 VLAN1.
23:00:10: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/24 on VLAN0001. Inconsistent port type.

As to why it shows up as static access, it is because we are not receiving DTP frames on that port so we're not negotiating to access.  We are falling back to access.

Hope this answers your questions.

Frequent Contributor

Re: Access port shows Amber light

Hi james,

thanks for reply  but i do not see any messages in  switch log do you why?

mahesh

Advisor

Re: Access port shows Amber light

Hi,

How are you connected to the switch, console or telnet/ssh?

if second option then you need to enter following command in privileged mode:  terminal monitor

if first option, verify logging is enabled in console and at which level ----> show log

Regards.

Alain

Don't forget to rate helpful posts.
Frequent Contributor

Re: Access port shows Amber light

hi cadetalain

here is info

2950T(config)#logging con
2950T(config)#logging console
2950T(config)#end
2950T#term mon
2950T#term monitor
2950T#sh log
Syslog logging: enabled (0 messages dropped, 1 messages rate-limited, 0 flushes,                                                       ...







Log Buffer (4096 bytes):

.Jan 29 07:24:36.374 MST: %SYS-5-CONFIG_I: Configured from console by manveer on                                                                                                                                vty0 (192.168.5.1)
2950T#

still i di not see this log message

Cisco Employee

Re: Access port shows Amber light

Q: thanks for reply  but i do not see any messages in  switch log do you why?

A: You will only see it the when the port fist comes up and goes through spanning tree listen/learn states and you're logging is set up to log this level of message.

You can look at port spanning tree state while the port is amber and it will show as broken due to port inconsistency:

SW3#sh span int f0/24

Vlan                Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
VLAN0001            Desg BKN*19        128.26   P2p *TYPE_Inc

If you shut/no shut the access port that will also trigger the message.

SW3(config)#int f0/24
SW3(config-if)#shut
1d15h: %LINK-5-CHANGED: Interface FastEthernet0/24, changed state to administratively down
SW3(config-if)#no shut
SW3(config-if)#
1d15h: %LINK-3-UPDOWN: Interface FastEthernet0/24, changed state to up
1d15h: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up
1d15h: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet0/24 VLAN1.
1d15h: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/24 on VLAN0001. Inconsistent port type.

If you're still not seeing the message logged make sure your logging level is set to debug, increase the size of your logging buffer and make sure you're logging to console.

SW3(config)#logg buff 7
SW3(config)#logg buff 1000000
SW3(config)#logg console 7

To reiterate my earlier statement, your config is not supported.  You can't have mode dynamic on one side and static trunk on the other.

Frequent Contributor

Re: Access port shows Amber light

Hi James,

many thanks for reply.

i did as you said and now i can see in logs


3550SMIB#                                      terminal monitor


3550SMIB#config t
Enter configuration commands, one per line.  End with CNTL/Z.
3550SMIB(config)#int fa0/20
3550SMIB(config-if)#no shut
3550SMIB(config-if)#no shutdown
3550SMIB(config-if)#
000068: Jan 29 12:14:38.219 MST: %LINK-3-UPDOWN: Interface FastEthernet0/20, changed state to up
000069: Jan 29 12:14:40.763 MST: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q    BPDU on non trunk FastEthernet0/20 VLAN1.
000070: Jan 29 12:14:40.767 MST: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/20 on VLAN0001. Inconsistent port type.
000071: Jan 29 12:14:41.747 MST: %LINEPROTO-5-UPDOWN: Line protocol on Interface  FastEthernet0/20, changed state to up


3550SMIB(config-if)#end
3550SMIB#


000072: Jan 29 12:15:01.260 MST: %SYS-5-CONFIG_I: Configured from console by mintoo on vty1 (192.168.5.1)


3550SMIB#sh spanning-tree int fa0/20

Vlan                Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
VLAN0001            Desg BKN*19        128.20   P2p *TYPE_Inc
3550SMIB#

Check the other end  of link  that switch logs shows

***********************************************************************************************************8

                                     switch2950

Jan 29 12:13:13.141 MST: %DTP-5-NONTRUNKPORTON: Port Fa0/20 has become non-trunk

Jan 29 12:13:13.601 MST: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/20, changed state to down
Jan 29 12:13:14.645 MST: %LINK-3-UPDOWN: Interface FastEthernet0/20, changed state to down
Jan 29 12:14:38.385 MST: %DTP-5-TRUNKPORTON: Port Fa0/20 has become dot1q trunk
Jan 29 12:14:39.881 MST: %LINK-3-UPDOWN: Interface FastEthernet0/20, changed state to up
Jan 29 12:14:40.881 MST: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/20, changed state to up

regards

mahesh

Hall of Fame Guru

Re: Access port shows Amber light

Amber port LED means a number of things:

1.  ASIC has failed POST;

2.  Spanning-Tree (wait for 55 seconds and see if the LED changes color);

3.  Collisions;

4.  Error disable;

5.  VLAN mismatch

CreatePlease to create content
Content for Community-Ad