cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
174
Views
5
Helpful
0
Replies
MikeC06933
Beginner

Adding a 3750X switch to an existing network with 3550 switches disables them both

Hi - 

Have an odd problem I can't get to the bottom of.

 

I have an existing network with a couple of WS-C3550-12T switches on it that link two buildings via fiber. These have been working fine for years without any problems. They are running 12.2(44)SE6 - IP-SERV-CRYPTO

 

I recently obtained some WS-C3750X-48P-L switches which I have reset and are now running c3750e-universalk9npe-mz.152-4.E10.bin

 

Both sets of switches are pretty much at minimal configuration - just an IP address assigned to VLAN1 and an enable password and secret and vty password - essentially what the initial basic setup configuration does (not set to cluster command switch and snmp not enabled). I also paired two 3750X's in a stack with two stack cables.

 

I took this newly configure 3750X stack on-site and plugged it in to the existing network - connecting one of the 48 gigabit ports on the 3750x stack to the existing network via a non-cisco switch. There are at least two non-cisco switches between the new 3750X stack and the existing 3550 switches

About 5 minutes later - I got frantic calls from users that the network was down - seems like the two 3550's were no longer routing any traffic between the two buildings. I couldn't access them from the network either.

As I'd done very little else to cause this problem (both 3550 switches seemed to be up and running according to the lights on them) - I thought I'd unplug the 3750x stack from the network. After about 5-10 minutes - and without me doing anything else - the 3550's came back to life and started passing traffic between them again.

I tried this once more a few hours later - plugged in 3750x stack - five or so minutes later - 3550's stop passing traffic. Unplugged 3750X from network - about 5-10 minutes later -3550's working again.

 

As it's a live network and this caused huge disruption - I couldn't really test it - so I set up a test network - very similar - this time three 3750X's - two in a stack - one stand-alone - and two 3550's - again - non-cisco switches between the two (part of another existing network)

 

Fortunately I was able to replicate the issue straight away - after a few minutes of plugging the 3750X switches into the existing network - the 3550's became inaccessible. So did the 3750X plugged into the network - pings to the router stopped and they showed up as missing in CNA

 

Unfortunately no amount of trouble shooting has got me any closer to a solution or figuring out what is going on.

I had a console connection to the 3550 that was connected to the existing network. When the problem occurred it logged the following:

00:04:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/10, changed state to down
00:04:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/10, changed state to up

And immediately afterwards you could no longer ping the switch - console access was still fine and no other errors were shown. I tried turning off spanning tree - no difference. sh int shows the interface up and line protocol up and all details look OK (same as without problem). show interface status err-disabled comes back with nothing

 

The 3750X switch was similar - same lineproto down and up - no other errors - sh int normal and status err-disabled blank

 

No messages were logged when the switch became accessible again

 

I set the logging level to debugging - slight more info when fault occurs on 3550 - but nothing helpful (at least to me):

000020: *Mar 1 03:10:04: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/10, changed state to down
000021: *Mar 1 03:10:04: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
000022: *Mar 1 03:10:07: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/10, changed state to up
000023: *Mar 1 03:10:37: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

 

The Vlan1 changing back to UP does NOT restore connectivity to the switch

 

Now when the switch becomes accessible gain some minutes after unplugging the 3750x it logs the following:

000024: *Mar 1 03:52:38: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
000025: *Mar 1 03:53:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

 

 

The problem occurs with a single 3550 and a single 3750x

I have not tried link the two switches together directly - they have always been connected with at least two other non-cisco switches between them

They have the same passwords

I never added them to the same community in CNA (but I don't think that has any effect on the switches themselves?)

The non-cisco switches were different between the live and test networks - so I don't think the make of them is relevant.

Also - the non-cisco switches seem unaffected by any of this and continue to work throughout.

 

I'm completely out of ideas as to what to try next or any sort of troubleshooting commands or steps that might shed further light on the issue. (I'm not a Cisco guru)

 

Thank in advance,

 

Mike

0 REPLIES 0