05-09-2018 12:32 PM - edited 03-08-2019 02:58 PM
I am trying to get a VLAN added to my network, and I am unable to get clients from one VLAN to Ping the new VLAN I added. I can ping the address assigned to the Routers Virtual Interface, but I cannot ping clients behind that.
From the switches, I can ping clients behind the router.
So a switch can ping 10.10.10.1 (gateway, IP assigned to the router) and 10.10.10.2 A client PC attached to the 10.10.10.0 Subnet, but a client PC assigned to 192.168.113.0 subnet cannot ping 10.10.10.2, but can ping 10.10.10.1.
I will post the configurations to the switches and routers, trying to remove some of the settings to reduce the length.
Router (2911):
Building configuration...
Current configuration : 5257 bytes
no ipv6 cef
ip source-route
ip cef
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 10.0.0.102 255.255.255.252
ip helper-address 192.168.116.240
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.10
encapsulation dot1Q 10
ip address 10.10.10.1 255.255.255.0
ip helper-address 10.10.10.2
!
interface GigabitEthernet0/1.113
encapsulation dot1Q 113
ip address 192.168.113.6 255.255.255.0
ip helper-address 192.168.100.1
!
interface GigabitEthernet0/1.116
encapsulation dot1Q 116
ip address 192.168.116.1 255.255.255.0
ip helper-address 192.168.100.1
!
interface GigabitEthernet0/2
ip address 10.0.0.42 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/0/0
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
!
ip route 0.0.0.0 0.0.0.0 192.168.116.251
ip route 10.4.0.0 255.255.240.0 192.168.113.227
ip route 10.231.2.0 255.255.255.0 192.168.116.3
ip route 10.231.5.0 255.255.255.0 192.168.116.3
ip route 172.22.0.0 255.255.0.0 192.168.113.245
ip route 172.23.140.0 255.255.255.0 192.168.113.245
ip route 192.168.2.0 255.255.255.0 192.168.113.1
ip route 192.168.3.0 255.255.255.0 192.168.113.1
ip route 192.168.6.0 255.255.255.0 192.168.113.1
ip route 192.168.100.0 255.255.255.0 10.0.0.41
ip route 192.168.101.0 255.255.255.0 10.0.0.41
ip route 192.168.105.0 255.255.255.0 10.0.0.41
ip route 192.168.107.0 255.255.255.0 10.0.0.41
ip route 192.168.108.0 255.255.255.0 10.0.0.41
ip route 192.168.109.0 255.255.255.0 10.0.0.41
ip route 192.168.113.0 255.255.255.0 192.168.100.251
ip route 192.168.114.0 255.255.255.0 10.0.0.41
ip route 192.168.118.0 255.255.255.0 10.0.0.41
ip route 192.168.151.0 255.255.255.0 10.0.0.101
ip route 192.168.159.0 255.255.255.0 10.0.0.41
ip route 192.168.200.0 255.255.255.0 10.0.0.41
!
Switch 3850:
Building configuration...
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-vrf
!
address-family ipv4
exit-address-family
!
ip routing
!
! quit
diagnostic bootup level minimal
spanning-tree mode rapid-pvst
spanning-tree extend system-id
hw-switch switch 1 logging onboard message level 3
!
redundancy
mode sso
!
!
!
class-map match-any non-client-nrt-class
!
policy-map port_child_policy
class non-client-nrt-class
bandwidth remaining ratio 10
!
!
interface Port-channel3
description 20GB LACP to 3750 Stack
switchport trunk allowed vlan 10,113,116
switchport mode trunk
switchport nonegotiate
!
interface TenGigabitEthernet1/0/7
description Uplink to 3750 Stack
switchport trunk allowed vlan 10,113,116
switchport mode trunk
switchport nonegotiate
channel-group 3 mode desirable non-silent
spanning-tree portfast trunk
!
!
interface TenGigabitEthernet1/0/8
description Uplink to 3750 Stack
switchport trunk allowed vlan 10,113,116
switchport mode trunk
switchport nonegotiate
channel-group 3 mode desirable non-silent
spanning-tree portfast trunk
!
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 10.10.10.247 255.255.255.0
ip helper-address 10.10.10.2
!
interface Vlan113
ip address 192.168.113.247 255.255.255.0
ip helper-address 192.168.116.240
!
interface Vlan116
ip address 192.168.116.247 255.255.255.0
ip helper-address 192.168.116.240
!
ip route 0.0.0.0 0.0.0.0 192.168.113.6
!
Switch 3750:
Current configuration : 26895 bytes
!
aaa session-id common
stacks scan-lite
switch 1 provision ws-c3750x-48
switch 2 provision ws-c3750x-48
switch 3 provision ws-c3750x-48
switch 4 provision ws-c3750x-48
system mtu routing 1500
ip routing
quit
!
spanning-tree mode pvst
spanning-tree extend system-id
no spanning-tree vlan 112-113
!
!
!
!
vlan internal allocation policy ascending
!
!
interface Port-channel3
description LACP to 3850 Fiber
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,113,116
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0
no ip address
no ip route-cache cef
no ip route-cache
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,113,116,151
switchport mode trunk
spanning-tree portfast
!
interface TenGigabitEthernet2/1/1
description Uplink to FIBER Switch
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,113,116
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk
channel-group 3 mode auto
!
interface TenGigabitEthernet2/1/2
description Uplink to FIBER Switch
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,113,116
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk
channel-group 3 mode auto
!
interface GigabitEthernet4/0/1
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet4/0/45
description CONNECTED TO MGMNT PORT ASA5516
switchport access vlan 116
switchport mode access
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 10.10.10.253 255.255.255.0
ip helper-address 10.10.10.2
!
interface Vlan113
ip address 192.168.113.253 255.255.255.0
ip helper-address 192.168.100.1
!
interface Vlan116
ip address 192.168.116.253 255.255.255.0
ip helper-address 192.168.100.1
!
interface Vlan151
ip address 192.168.151.253 255.255.255.0
ip helper-address 192.168.116.240
!
ip http server
ip http secure-server
end
05-09-2018 12:48 PM
I don't see any 10.10.10.2 address in your config.
Also, do the clients in 192.168.113.0 subnet have the correct gateway?
What switch do these clients connect to?
HTH
05-09-2018 12:56 PM
@Reza Sharifi wrote:
I don't see any 10.10.10.2 address in your config.
Also, do the clients in 192.168.113.0 subnet have the correct gateway?
What switch do these clients connect to?
HTH
I am not sure I understand the question.
Yes the 113 Subnet client have the correct gateway 192.168.113.6 (on the router config).
All the switches have the 113 and 116 and 10 vlans.
You will not see the 10.10.10.2 IP in the switches and routers config, it is a PC attached to the 3750 stack on port 4/0/1.
05-09-2018 01:11 PM
Got it. Thanks for the clarification.
ip route 192.168.113.0 255.255.255.0 192.168.100.251
192.168.113.0 255.255.255.0 is a connected interface. Is there a reason for this statement?
HTH
05-09-2018 01:15 PM
@Reza Sharifi wrote:
Got it. Thanks for the clarification.
ip route 192.168.113.0 255.255.255.0 192.168.100.251
192.168.113.0 255.255.255.0 is a connected interface. Is there a reason for this statement?
HTH
ip route 192.168.113.0 255.255.255.0 192.168.100.251
This is a route statement for traffic from the 113 VLAN to be routed to another locations subnet once a year for video traffic. They turn the circuit on, the route allows us to monitor their camera feeds and once they are finished the circuit is turned off.
05-09-2018 01:30 PM
But in this case, the statement basically says, to get to
192.168.113.0 255.255.255.0 go to 192.168.100.251 while 192.168.113.0 is a connected interface.
The 2800 is routing to itself?
Also, physically, does the 3750 connect to the 3850 and then the 3850 to 2800?
HTH
05-09-2018 01:36 PM
@Reza Sharifi wrote:
But in this case, the statement basically says, to get to
192.168.113.0 255.255.255.0 go to 192.168.100.251 while 192.168.113.0 is a connected interface.
The 2800 is routing to itself?
Also, physically, does the 3750 connect to the 3850 and then the 3850 to 2800?
HTH
I removed this statement from the 2911 router to see if it made a difference, it doesn't seem to have made a difference.
ip route 192.168.113.0 255.255.255.0 192.168.100.251
The 3850 has an LACP team attached to the 3750 stack. The 3750 is connected to the 2911 router.
I am not sure about the statement "routing to itself" can you clairify? Thanks!
05-09-2018 01:53 PM
So, where is the host in vlan 113 located (what switch and what port)?
What is its IP address?
Is that static IP or DHCP?
Can that host ping its gateway (192.168.113.6)?
05-09-2018 02:04 PM - edited 05-09-2018 02:04 PM
@Reza Sharifi wrote:
So, where is the host in vlan 113 located (what switch and what port)?
What is its IP address?
Is that static IP or DHCP?
Can that host ping its gateway (192.168.113.6)?
It is located on the 3850. interface TenGigabitEthernet1/0/24, but they are all on the 113 subnet on the 3850, so far anyway, I haven't put any on the 116.
It's IP is statically assigned (as most are on that Subnet). 192.168.113.29 specifically.
@That host is what I am using on a daily basis. Yes it can ping the gateway (192.168.113.6) it can even ping the router @ 10.10.10.1, I can't get to any other 10.10.10.0/24 I add to a port.
What I don't get is the switches can ping 10.10.10.1 and 10.10.10.2. The router can ping 10.10.10.2.
05-10-2018 06:58 AM
@metuckness wrote:
@Reza Sharifi wrote:
So, where is the host in vlan 113 located (what switch and what port)?
What is its IP address?
Is that static IP or DHCP?
Can that host ping its gateway (192.168.113.6)?
It is located on the 3850. interface TenGigabitEthernet1/0/24, but they are all on the 113 subnet on the 3850, so far anyway, I haven't put any on the 116.
It's IP is statically assigned (as most are on that Subnet). 192.168.113.29 specifically.
@That host is what I am using on a daily basis. Yes it can ping the gateway (192.168.113.6) it can even ping the router @ 10.10.10.1, I can't get to any other 10.10.10.0/24 I add to a port.
What I don't get is the switches can ping 10.10.10.1 and 10.10.10.2. The router can ping 10.10.10.2.
No other ideas? Anyone?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide