cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

1997
Views
5
Helpful
7
Replies
Beginner

Advantages/Disadvantages of connecting two 6500s with a port-channel over the Sup720s?

I've seen this a lot, and at a point of redesigning my network during a planned outage, and would like to know if there are any Adv./Disadvantages to using the interfaces on the Sup720s for this.

Currently, we have 2 interfaces in a port-channel over two 6748 line cards.

We aren't doing anything crazy over the port-channels..  just standard traffic, no multicast, routing, etc.

Thanks a bunch, and here is a config example of what the setup is now..

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10-14,20,100

switchport mode trunk

speed 1000

duplex full

end

!

interface GigabitEthernet3/44

description TRUNK-TO-SW02

switchport

switchport trunk allowed vlan 10-14,20,100

switchport mode trunk

speed 1000

duplex full

channel-group 1 mode on

end

7 REPLIES 7
Hall of Fame Guru

Re: Advantages/Disadvantages of connecting two 6500s with a port

Dave

The main advantage of using at least one port on the supervisor (you can obviously still use 6748 for other port) is that the supervisor boots up first before any linecards. This means the 2 6500s can start to etablish routing neighborships etc. between each other while still booting up the rest of the linecards.

It is also dependant on what other devices you have connected to the 6500s ie. if you had a WAN router connected to both 6500s on a linecard and that linecard booted up before the linecards with your interconnect on then you can have the situation where the sups and WAN router have exchanged routes with each other.  But the 2 6500s have not yet peered with each other. This could lead to a delay in forwarding depending on your topology.

In the grand scheme of things if both your 6500s are rebooting then it is not a huge concern but if all your L3 devices are in sync then it can speed up traffic forwarding (although obviously to forward to certain devices you are still dependant on the sspecific linecard booting up).

Disadvantages, can't think of any really.

Jon

Hall of Fame Community Legend

Advantages/Disadvantages of connecting two 6500s with a port-cha

I agree with Jon (+5) about using the Sup's fibre ports as an etherchannel.

But I also would recommend not putting "all your eggs in one basket".  If you have dual supervisor cards, then spreading your etherchannel links between the two cards is OK.  If you only have one supervisor card, I don't see the benefit of spreading your etherchannel to one fibre to the supervisor card and the other to another line card.

Beginner

Advantages/Disadvantages of connecting two 6500s with a port-cha

I might be misunderstood here..

I'm not trying to separate the member interfaces of the port-channel between a line card and a Sup.  I'm asking if there is any advantage over a pair of interfaces in a port-channel..   in a line card, vs. the Sup itself. 

The first reply was right on, however, I don't have any routing to worry about. 

I'm purely speaking of this from a layer 2 standpoint, with ASIC buffering in mind.  We've recently run into some queue drop problems, and I've moved the port-channel to an ASIC without as much traffic, and this has alleviated our problem for now.  However, I'm wondering if I can get the port-channel traffic entirely off of our line card, and use the two interfaces on each Sup, in each switch.  I know I can..  but, is it more/less adviseable to do so, and why?  Obviously one downfall I can see, is that we're limited to only two interfaces (therefore 2Gbits) in the port-channel.  But are there any advantages to going straight to the line cards and not the Sup?

Hall of Fame Community Legend

Re: Advantages/Disadvantages of connecting two 6500s with a port

Ahhhh ... I think I get what you are trying to determine.

Depends on your line card, to be honest.  Some line cards and push wire speed/non-blocking and some line cards just can't.

Take the 6148 vs 6748 for example.  People find that the 6148 or even the 6548 to be cheaper alternative to a 6748 and decides to deploy either one to the data centre.  Next they plug high-speed servers to them and they complain of output drops.  The answer is because the 6148 and 6548 are access-port switches and wasn't designed for high-speed servers.  The 6748, however, is.

I don't have the figures memorized (I'm sure Jon can because he's got one of these cards in his wallet ).

Beginner

Re: Advantages/Disadvantages of connecting two 6500s with a port

Actually, you've hit it right on the head.. 

We have a 6503, with a 6748, and a 6148..    we had the port-channel on the 6148..   we ran into the queue drop problem, and I took it upon myself to move the port-channel to a better ASIC..  

This wknd, we're replacing the 6148 line cards with 6748s..   however, I also noticed that we're not using our interfaces on the SUPs for anything, so I figured since we're only suing two interfaces in the port-channel, I would go a step further, and move the port-channel off of ANY line card.

So yes..  basically it's 2 Interface port-channel on 6748 VS. 720 Sup.  Which is better? 

Hall of Fame Community Legend

Advantages/Disadvantages of connecting two 6500s with a port-cha

I agree with Jon.  The Supervisor card boots first so I'd put the links there.  If you need more then put them in the 6748.  If you have dual supervisor cards then distribute the links. 

Highlighted
VIP Expert

Advantages/Disadvantages of connecting two 6500s with a port-cha

Disclaimer

The      Author of this posting offers the information contained within this      posting without consideration and with the reader's understanding   that    there's no implied or expressed suitability or fitness for any    purpose.   Information provided is for informational purposes only  and   should not   be construed as rendering professional advice of any  kind.   Usage of  this  posting's information is solely at reader's own  risk.

Liability Disclaimer

In     no event shall Author be liable for any damages  whatsoever   (including,   without limitation, damages for loss of use,  data or   profit) arising  out  of the use or inability to use the  posting's   information even if  Author  has been advised of the  possibility of  such  damage.

Posting

I recall the 6748 line card has a superior port architecture than a sup720's gig ports, but I'm not 100% certain without doing some digging.

I do know the 6748 is also a CEF720 card, so it has much more bandwidth to/from the fabric (20 Gbps per 24 ports) than older series line cards and can also do local forwarding if a DFC is installed.  I.e. it's a much better choice for lots of gig ports that are actually busy, as more often the case for servers, for example.

CreatePlease to create content
Content for Community-Ad