cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3983
Views
0
Helpful
8
Replies

After ip route command but still cant ping...

sshishi1234
Level 1
Level 1

Hi Again,

I am using Packet tracer to build a network, i have two routers and assigned ips of 192.168.1.1 and 192.168.2.1 to fa0/0 's on 2811 router model... I then did an ip route but it would nt allow me use the exact ips that i had assigned. i then just used 0 instead of 1 at the end.. But i still cannot ping. Any reason

why i couldnt use the ip i had assigned and is this my issue, that my ip is not actaully the ones on the router.. confused! Any help appreciated... thanks

Building configuration...

Current configuration : 511 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.2.0
!
!
line con 0
line vty 0 4
login
!
!
end

1 Accepted Solution

Accepted Solutions

You are not listening to what is being said to you and you are not understanding the basic principle that whichever interfaces connect the 2 routers, they must have an address from the same subnet.

Here is the relevant bits of config you currently have -

Router 1

======

interface FastEthernet0/0
ip address 192.168.2.225 255.255.254.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.4.20 255.255.254.0
duplex auto
speed auto

ip default-network 0.0.0.0
ip route 192.168.4.0 255.255.254.0 192.168.2.20
ip route 192.168.2.0 255.255.254.0 192.168.4.68
ip route 192.168.4.0 255.255.254.0 192.168.2.0
ip route 192.168.2.0 255.255.254.0 192.168.4.0
ip route 192.168.8.0 255.255.254.0 192.168.6.10

Router 2

======

interface FastEthernet0/0
ip address 192.168.6.10 255.255.254.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.8.22 255.255.254.0
duplex auto
speed auto

ip route 192.168.2.0 255.255.254.0 192.168.4.20

So this is what you need to do -

which interfaces are the routers connected to each other with ? Lets assume it is fa0/0 on each router. These 2 interfaces therefore need to be in the same subnet to communicate. You don't have them in the same subnet. So lets use 192.168.1.0 255.255.255.0 for this subnet

router 1

======

int fa0/0

ip address 192.168.1.1 255.255.255.0

router 2

======

int fa0/0

ip address 192.168.1.2 255.255.255.0

on each router you only have one other network that is attached to fa0/1 so on each router you only need one route statement. Not sure why you are using the 255.255.254.0 mask but we will stick with it. So -

router 1

=====

ip route 192.168.8.0 255.255.254.0 192.168.1.2

and remove all your other routes including the ip default-network

router 2

=====

ip route 192.168.4.0 255.255.254.0 192.168.1.1

and remove the other route statement.

You do not need a route statement for the 192.168.1.0/24 network because both routers know about this network.

Jon

View solution in original post

8 Replies 8

Jon Marshall
Hall of Fame
Hall of Fame

sshishi1234 wrote:

Hi Again,

I am using Packet tracer to build a network, i have two routers and assigned ips of 192.168.1.1 and 192.168.2.1 to fa0/0 's on 2811 router model... I then did an ip route but it would nt allow me use the exact ips that i had assigned. i then just used 0 instead of 1 at the end.. But i still cannot ping. Any reason

why i couldnt use the ip i had assigned and is this my issue, that my ip is not actaully the ones on the router.. confused! Any help appreciated... thanks

Building configuration...

Current configuration : 511 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.2.0
!
!
line con 0
line vty 0 4
login
!
!
end

How are these routers connected to each other ? If they are connected via the fa0/0 interfaces then you need the fa0/0 interface on each router to be in the same subnet ie. you cannot have 192.168.1.1 and 192.168.2.1 on the fa0/0 interfaces and then connect them together.

If the routers are connected via different interfaces then perhaps you could post full configuration ?

Jon

hi bro

off course you having problems, cuz its seems that you forgat to put a subnet ...

first of all

you cant use 192.168.1.1 and 192.168.2.1 cuz you cannt use the first and the last of the subnet (first for the network ID second for the broadcast )

second of all ,,, since its 192.168.1.0 and 192.168.2.0 soooo you should identify them both as subnets, and this is how we do it below :

11111111.11111111.11111110.00000000 = 255.255.254.0 subnet mask  for each of the networks you should put it in the ip route

192.168.0.0 - 192.168.1.255 range one

192.168.2.0 - 192.168.3.255 range two

192.168.4.0 and so on 

i hope this will help you identifying the problem

Ok thanks, i felt i was stupidly doing something with subnets.... I have changed them all, the image attached shows what i assigned to what interface...

PC0 and PC 2 Have ips of  192.168.1.20 and 192.168.6.23

This is router 1

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.0.0/23 is directly connected, FastEthernet0/1
C    192.168.2.0/23 is directly connected, FastEthernet0/0

This is router 2

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.4.0/23 is directly connected, FastEthernet0/0
C    192.168.6.0/23 is directly connected, FastEthernet0/1

Router#show running-config
Building configuration...

Current configuration : 468 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
interface FastEthernet0/0
ip address 192.168.4.10 255.255.254.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.6.55 255.255.254.0
duplex auto
speed auto
!
interface Vlan1
no ip address
!
ip classless
!
line con 0
line vty 0 4
login
!
!
!
end

lusandi
Level 1
Level 1

Fa0/1:192.168.1.2(Router2)Fa0/0:192.168.2.225------------fa0/0:192.168.4.10(Router1)fa0/1:192.168.6.55

Router1:

interface FastEthernet0/0 --------> Connected to router2
ip address 192.168.4.10 255.255.254.0   (Range will contain 192.168.2.0 --- 192.168.3.255)
duplex auto
speed auto

interface FastEthernet0/1  --------> Connected to LAN
ip address 192.168.6.55 255.255.254.0  (Range will contain 192.168.6.0 --- 192.168.7.255)
duplex auto
speed auto

Router2:

!
interface FastEthernet0/0 --------> Connected to router1
ip address 192.168.2.1 255.255.255.0  (Range will contain 192.168.2.0 --- 192.168.3.255)
duplex auto
speed auto


Basically you will need this to get this working.
1. Fix the network mask on router 2 ---> ip address 192.168.2.1 255.255.254.0
2. on router 2 add the following ip route:
ip route 192.168.6.0 255.255.254.0 [fa 0/0] or [192.168.4.10]
3. on router 3 add  the following ip route:
ip route 192.168.0.0 255.255.254.0 [fa0/0] or 192.168.2.225

I hope this will be helpful.

hi, thanks for response,

i only have 2 routers so i presume you meant router 1 and 2 and not 3. I have corrected the ip address and masks but still nothing and attached the current config, unfortunatly i still cant ping hosts on other router..

Router 1 show running config:

Router#show running-config
Building configuration...

Current configuration : 749 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
interface FastEthernet0/0
ip address 192.168.2.225 255.255.254.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.4.20 255.255.254.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip default-network 0.0.0.0
ip route 192.168.4.0 255.255.254.0 192.168.2.20
ip route 192.168.2.0 255.255.254.0 192.168.4.68
ip route 192.168.4.0 255.255.254.0 192.168.2.0
ip route 192.168.2.0 255.255.254.0 192.168.4.0
ip route 192.168.8.0 255.255.254.0 192.168.6.10
!
!
!
line con 0
line vty 0 4
login
!
!
!
end

ROuter 2 running config

Router#show running-config
Building configuration...

Current configuration : 527 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
interface FastEthernet0/0
ip address 192.168.6.10 255.255.254.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.8.22 255.255.254.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.2.0 255.255.254.0 192.168.4.20
!
!
line con 0
line vty 0 4
login
!
!
end

From Router 1:

!
interface FastEthernet0/1
ip address 192.168.4.20 255.255.254.0
duplex auto
speed auto

From router2:

!
interface FastEthernet0/0
ip address 192.168.6.10 255.255.254.0
duplex auto
speed auto

first. stop changing the configuration.

1. they are not in the same subnet.

change the ip address on the router 2  to 192.168.4.25 255.255.254. or something like that.

ip route 192.168.4.0 255.255.254.0 192.168.2.20
ip route 192.168.2.0 255.255.254.0 192.168.4.68
ip route 192.168.4.0 255.255.254.0 192.168.2.0
ip route 192.168.2.0 255.255.254.0 192.168.4.0
ip route 192.168.8.0 255.255.254.0 192.168.6.10

you are telling the router to send the packets from one network to another network.

The router just need to know where to forward one network.

if you are in router 1. use this:

ip route 192.168.8.0 255.255.254.0 fa0/1

if you are in router 2 use this:

ip route 192.168.2.0 255.255.254.0 fa0/0

You Do Not Need To Have 2 IP routes ponting to the same subnet and one pointing to a network ID.

As per your subnet mask this will be the addressing:

192.168.0.0 ---> 192.168.1.255

192.168.2.0 ---> 192.168.3.255

192.168.4.0 ---> 192.168.5.255

192.168.6.0 ---> 192.168.7.255

192.168.8.0 ---> 192.168.9.255

I hope this will be helpful.

You are not listening to what is being said to you and you are not understanding the basic principle that whichever interfaces connect the 2 routers, they must have an address from the same subnet.

Here is the relevant bits of config you currently have -

Router 1

======

interface FastEthernet0/0
ip address 192.168.2.225 255.255.254.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.4.20 255.255.254.0
duplex auto
speed auto

ip default-network 0.0.0.0
ip route 192.168.4.0 255.255.254.0 192.168.2.20
ip route 192.168.2.0 255.255.254.0 192.168.4.68
ip route 192.168.4.0 255.255.254.0 192.168.2.0
ip route 192.168.2.0 255.255.254.0 192.168.4.0
ip route 192.168.8.0 255.255.254.0 192.168.6.10

Router 2

======

interface FastEthernet0/0
ip address 192.168.6.10 255.255.254.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.8.22 255.255.254.0
duplex auto
speed auto

ip route 192.168.2.0 255.255.254.0 192.168.4.20

So this is what you need to do -

which interfaces are the routers connected to each other with ? Lets assume it is fa0/0 on each router. These 2 interfaces therefore need to be in the same subnet to communicate. You don't have them in the same subnet. So lets use 192.168.1.0 255.255.255.0 for this subnet

router 1

======

int fa0/0

ip address 192.168.1.1 255.255.255.0

router 2

======

int fa0/0

ip address 192.168.1.2 255.255.255.0

on each router you only have one other network that is attached to fa0/1 so on each router you only need one route statement. Not sure why you are using the 255.255.254.0 mask but we will stick with it. So -

router 1

=====

ip route 192.168.8.0 255.255.254.0 192.168.1.2

and remove all your other routes including the ip default-network

router 2

=====

ip route 192.168.4.0 255.255.254.0 192.168.1.1

and remove the other route statement.

You do not need a route statement for the 192.168.1.0/24 network because both routers know about this network.

Jon

at last! i mean on my part its working... back to basic os subnetting until it finally goes through... thanks for your time on this.

Review Cisco Networking products for a $25 gift card