cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1487
Views
5
Helpful
12
Replies

after run ip routing on C9300-48P, SVI becomes unreachable

Herman2018
Level 3
Level 3

Hi, we have 2x catalyst 9300-48P switches, after running "ip routing", then SVI (vlan interface) becomes unreachable. cannot ping those vlan interfaces IP addresses. If removing the command "ip routing", then can ping from other devcie.  anyone please advise, thanks.

1 Accepted Solution

Accepted Solutions

Agreed  with you can send me over or condense the config and post here

 

post below information :  (before and post ip routing enabled)

 

show ip route

show ip interface brief

show loggg

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

View solution in original post

12 Replies 12

share the show run output

Please rate this and mark as solution/answer, if this resolved your issue
Good luck
KB

show vlan 
show ip route 
show ip interface brief, 
please share output here

Thanks MHM!

please see the attached file. 

i saw your vlan interfaces are in down state. you need to take them up by assigning relevant vlans to trunk or access port

Please rate this and mark as solution/answer, if this resolved your issue
Good luck
KB

Thanks Kasun!

the vlan 82  interface is up. when running the command "ip routing", then cannot ping vlan 82 IP. 

If you are not using vlan 1 interface, shutdown interface vlan 1 and test it.

 

Also i have asked some information :

 

post below information : (before and post ip routing enabled)

 

show ip route

show ip interface brief

show loggg

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

I agree with @balaji.bandi that the symptom of something becoming unreachable when ip routing is enabled does suggest that ip default-gateway had been used. But the output that you posted is clear that there is a static default route configured. 

Could you tell us which SVIs become unreachable? Is it all of them, or some of them, or what?

Also can you tell us where you are pinging from?

Would you post the output of the command show arp?

HTH

Rick

can I see the interface interconnect both SW ?

balaji.bandi
Hall of Fame
Hall of Fame

If you configured ip default-gateway - then you may see this break i guess here (high level assuming)

 

when you enable ip routing, you need to change default-gateway to ip route x.x.x.x x.x.x.x

 

as other suggest post the config

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hi Balaji,

thanks for your reply.

I didn't use ip default-gateway command, use ip route xxx.xx command.  here not convenient to post full config. 

 

Agreed  with you can send me over or condense the config and post here

 

post below information :  (before and post ip routing enabled)

 

show ip route

show ip interface brief

show loggg

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

....

Review Cisco Networking for a $25 gift card