cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
577
Views
0
Helpful
8
Replies

Aironet 1142 Console Unavailable

iphoneguru27
Beginner
Beginner

Hello all,

I am currently having difficulty configuring my AP. The Cisco Aironet 1142's that I bought from a working environment have been factory reset, and checked for issues throughly. That being said, I am unable to access the CLI from the console port, or through telnet. Whenever I try via telnet, I receive a 'no password set' error and termination. I've tried multiple cables, including the AIR-CONCAB1200 cable and a crossover cable from a friend, but had no luck. I would like to flash the image with an autonomous one, however I cannot even open a tftp session as I cannot get in. Has anyone else had this issue? Any help is greatly appreciated!

8 Replies 8

Peter Paluch
Hall of Fame Cisco Employee Hall of Fame Cisco Employee
Hall of Fame Cisco Employee

Hi,

With a lightweight firmware, it is possible that the console is unresponsive. The method for reverting a lightweight AP to autonomous mode is described in these two documents:

https://web.archive.org/web/20090124191043/http://cisco.com/en/US/docs/wireless/access_point/conversion/lwapp/upgrade/guide/lwapnote.html#wp160918

https://reggle.wordpress.com/2013/01/12/converting-a-cisco-lightweight-access-point-to-standalone-mode/

Check these out!

Best regards,
Peter

I've tried the latter of the posts, but am confused. I've got the AP blinking red/orange now and that is in recovery mode. However, it won't bind to 10.0.0.1 so I can TFTP into it. I have the following configurations changed for my Router and Switch respectively.


Current configuration : 1149 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname CISCO_R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$xrBZ$QZ.v510UOZgYXANqBZI/r/
enable password 7 0822455D0A16
!
clock timezone CDT -6
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
ip dhcp excluded-address 10.0.0.1 10.0.0.4
!
ip dhcp pool DHCP_POOL
network 10.0.0.0 255.255.255.0
default-router 10.0.0.2
dns-server 10.0.0.2
domain-name ciscolab.local
!
!
!
!
!
interface Ethernet0/0
ip address 192.168.4.1 255.255.255.0
shutdown
full-duplex
!
interface Serial0/0
no ip address
shutdown
!
interface Ethernet0/1
ip address 10.0.0.2 255.255.255.0
full-duplex
!
ip default-gateway 10.0.0.2
ip http server
ip classless
!

Current configuration : 2127 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname CISCO_SW1
!
enable secret 5 $1$B9Ad$Wn9RObNmRPpXefwMZlUc01
enable password 7 060506324F41
!
ip subnet-zero
!
no ip domain-lookup
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
switchport access vlan 10
duplex full
!
interface FastEthernet0/2
switchport access vlan 10
duplex full
!
interface FastEthernet0/3
switchport access vlan 10
duplex full
!
interface FastEthernet0/4
switchport access vlan 10
duplex full
!
interface FastEthernet0/5
switchport access vlan 10
duplex full
!
interface FastEthernet0/6
switchport access vlan 10
duplex full
!
interface FastEthernet0/7
switchport access vlan 10
duplex full
!
interface FastEthernet0/8
switchport access vlan 10
duplex full
!
interface FastEthernet0/9
switchport access vlan 20
!
interface FastEthernet0/10
switchport access vlan 20
!
interface FastEthernet0/11
switchport access vlan 20
!
interface FastEthernet0/12
switchport access vlan 20
!
interface FastEthernet0/13
switchport access vlan 20
!
interface FastEthernet0/14
switchport access vlan 20
!
interface FastEthernet0/15
switchport access vlan 20
!
interface FastEthernet0/16
switchport access vlan 20
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan20
ip address 10.0.0.3 255.255.255.0
no ip route-cache
!
ip default-gateway 10.0.0.2
ip http server

Peter Paluch
Hall of Fame Cisco Employee Hall of Fame Cisco Employee
Hall of Fame Cisco Employee

Hello,

How do you know that the AP won't bind to 10.0.0.1? According to the documents, it will bind to this IP address on its own, without needing a DHCP server. The latter document mentioned that a static ARP may be needed on the TFTP server for the AP's IP/MAC because the AP did not respond to ARP requests.

Best regards,
Peter

Will try this later today. I am unfamiliar with creating a static ARP on a TFTP server, though. I recently changed my configuration files to bind to the 10.0.0.0/24 network. Could there be an issue with my configuration files?

Also I believe it isn't binding to 10.0.0.1 due to my nmap probes and the fact that the TFTP transmission times out

Starting Nmap 6.40 ( http://nmap.org ) at 2016-04-06 09:09 CDT
Nmap scan report for 10.0.0.2
Host is up (0.0017s latency).
Not shown: 998 closed ports
PORT STATE SERVICE
23/tcp open telnet
80/tcp open http
MAC Address: 00:30:85:9D:7F:41 (Cisco Systems)

Nmap scan report for 10.0.0.3
Host is up (0.0024s latency).
Not shown: 998 closed ports
PORT STATE SERVICE
23/tcp open telnet
80/tcp open http
MAC Address: 00:1B:0D:78:AE:C0 (Cisco Systems)

Nmap scan report for 10.0.0.5
Host is up (0.000010s latency).
All 1000 scanned ports on 10.0.0.5 are closed

I have created a static arp using 'arp -s 10.0.0.1 MAC:ADDRESS' but to no avail.

I tried tonight and havent made any progress. So far I have power-cycled the AP, and gotten it into recovery mode (blinking red). I have it plugged into PoE and then into a switch, IP 10.0.0.3. The switch is plugged into a router IP 10.0.0.2. The AP is supposedly going to bind to 10.0.0.1, so I added the static arp. I have the IOS files ready to go. All thats left is that I still cannot connect to the AP. Should I just directly plug my computer into the AP, i.e. LAN port on PoE?

Edit: The TFTP server is on 10.0.0.5. I have a PC connected to the switch. I cannot ping the AP, or see it in any NMAP procedure.

Any ideas?

johnlloyd_13
Engager
Engager

hi,

what terminal emulation software did you use?

try using putty when connecting via console.

I have been using minicom on xubuntu. I have tried putty but it still doesn't respond for the access point. I have access to my Router and Switch with either minicom or putty, so the program isn't the issue.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers