cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2712
Views
16
Helpful
9
Replies

Amber Light

ryno7819
Level 1
Level 1

We are attempting to connect a C9200 (L2) switch to a C9500 (L3). Done this many times but for whatever reason, having issues with this setup. We have a direct fiber connection between the two. But receiving Amber light on the Rx side of the fiber cable. If I just plug in the Tx side of the fiber cable, it's green, but once I complete the other piece of the fiber, it goes amber. It only flashes Amber on the C9500 side uplink.  It goes Amber and then Green a few times and then back to Amber. On the C9200 side it's constant green. I am perplexed. Opened a ticket with Cisco and also reached out to our consultant and they are stating everything looks fine and not seeing anything in logs. Here is the config of each:

Core Config:

 

interface TenGigabitEthernet1/1/5
description SW0101 10g Link Old Master
switchport mode trunk
switchport nonegotiate
ip arp inspection trust
auto qos trust dscp
spanning-tree portfast disable
spanning-tree bpdufilter enable
spanning-tree link-type point-to-point
service-policy input AutoQos-4.0-Trust-Dscp-Input-Policy
service-policy output AutoQos-4.0-Output-Policy
ip dhcp snooping trust

 

C9200 Config:

interface TenGigabitEthernet1/1/1
description Trunk Port to Core
switchport mode trunk
auto qos trust dscp
service-policy input AutoQos-4.0-Trust-Dscp-Input-Policy
service-policy output AutoQos-4.0-Output-Policy

Sho log does not show any issues at all. We are using SFP-10G-SR. We have tried multiple different SFPs, Fiber Cables, and tried different ports on each end. Same issue. 

 

1 Accepted Solution

Accepted Solutions

ryno7819
Level 1
Level 1

It ended up being a firmware issue. Upgraded to latest recommended version and that fixed connectivity issues. Odd!

View solution in original post

9 Replies 9

marce1000
VIP
VIP

 

 - Did you examine logs on both switches, could you also for the time being test with trunk-only settings as in :

interface TenGigabitEthernet1/1/5
description SW0101 10g Link Old Master
switchport mode trunk

 

C9200 Config:

interface TenGigabitEthernet1/1/1
description Trunk Port to Core
switchport mode trunk

  - Could you also configure a syslog-server on both and also use logging trap debugging , then try to form the trunk again and examine info's send to the syslog server.

 M.

 

 

 



-- Each morning when I wake up and look into the mirror I always say ' Why am I so brilliant ? '
    When the mirror will then always repond to me with ' The only thing that exceeds your brilliance is your beauty! '

Yes, I will try those configs tomorrow or next week and see how it goes. Wouldn't spanning tree command need to be used though on each port so I do not create some sort of loop?

- Any current spanning tree issue would be reported in the logs when
connecting. For the time being take no actions on that but check the syslog
messages too. M.


-- Each morning when I wake up and look into the mirror I always say ' Why am I so brilliant ? '
    When the mirror will then always repond to me with ' The only thing that exceeds your brilliance is your beauty! '

ryno7819
Level 1
Level 1

Sorry, not fully understanding. You are saying I should hold off on using that new port config and instead check syslog?  Or will those commands be fine with no spanning tree command in each?  And yes we analyzed logs on both switches. Can't find a single thing mentioning any issue. 

 

interface TenGigabitEthernet1/1/5
description SW0101 10g Link Old Master
switchport mode trunk

 

C9200 Config:

interface TenGigabitEthernet1/1/1
description Trunk Port to Core
switchport mode trunk

 

 - Yes , I mean to use native-trunk settings only without any spanning-tree directives and check the syslog server, after configured according to earlier instructions. Also use compatible SFP's at both ends , verify with : https://tmgmatrix.cisco.com/

 M.



-- Each morning when I wake up and look into the mirror I always say ' Why am I so brilliant ? '
    When the mirror will then always repond to me with ' The only thing that exceeds your brilliance is your beauty! '

ryno7819
Level 1
Level 1

It ended up being a firmware issue. Upgraded to latest recommended version and that fixed connectivity issues. Odd!

thanks a lot for update us

Which firmware resolved this. I have exact same issue

For our situation, installing 17.06.03 fixed it. 

Review Cisco Networking for a $25 gift card