cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
21126
Views
78
Helpful
120
Replies
ciscomoderator
Community Manager

Ask the Expert: QoS on Catalyst Switches.

With Shashank Singh  and Read the bioRead the bio

Welcome to the Cisco Support Community Ask the Expert conversation. This is an opportunity to learn from Cisco experts Shashank Singh and Sweta Morga about implementation and working and troubleshooting QoS on Cisco Catalyst 2960, 3650, 3750, 4500 and 6500 switches.

Shashank Singh  graduated in 2009 with a bachelor's degree in Computer Science and Engineering from VIT University, Vellore India. Prior to joining Cisco he worked at General Electric as a software engineer. Later on he joined the Cisco Technical Assistance Center as an engineer in October of 2009. He has been working on LAN Switching technologies in TAC since then. Shashank also holds a CCNP certificate. QoS on Catalyst switches is one of the areas of his interest.

Sweta Mogra is a Computer Science & Engineering graduate from VIT University, India. She has worked as a consultant with Tata Consultancy Services before joining Cisco's Technical Assistance Center (TAC) in 2011. She is currently working on LAN Switching technologies and QoS as one of her areas of expertise.

Remember to use the rating system to let Shashank and Sweta know if you have received an adequate response. 

Shashank and Sweta might not be able to answer each question due to the volume expected during this event. Remember that you can continue the conversation on the Network Infastructure sub-communityLan Switching forum shortly after the event. This event lasts through June 1, 2012. Visit this forum often to view responses to your questions and the questions of other community members.

120 REPLIES 120
soliehm.jeevan
Beginner

Hi,

I am looking for help in configuring marking packets on the SVIs on 3750s and 3750s. Only marking on the outbound direction.

I have multiple ACLs in the class-map. I am unable to apply the service-policy on the SVI. It throws an error "

%QOSMGR-4-CLASS_NOT_SUPPORTED: Classification is not supported in classmap XXXX "

Could you provide your suggestions as to how can I mark packets on SVIs.

ThX

Could you please share your ACL, class-map and policy-map config?

Regards,

Shashank

ip access-list extended RFC1918

permit ip any 10.0.0.0 0.255.255.255

permit ip any 172.16.0.0 0.15.255.255

permit ip any 192.168.0.0 0.0.255.255

ip access-list extended IP_VOICE

permit udp any gt 1023 any eq 1719

permit udp any eq 1719 any gt 1023

permit tcp any gt 1023 any eq 1720

permit tcp any eq 1720 any gt 1023

class-map match-all IP_VOICE

  match access-group name RFC1918

  match access-group name IP_VOICE

policy-map MARK_VOICE

  class IP_VOICE

  set dscp ef

I am trying to apply this on the SVI in outbound direction.

Thanks

Hi Soilehm,

More than one match statements in a class-map is not supported. Please see the explanation below

taken from http://www.cisco.com/en/US/docs/switches/lan/catalyst2970/software/release/12.1_11_ax/system/message/msg_desc.html

Error Message   

QOSMGR-4-CLASS_NOT_SUPPORTED: Classification is not supported in classmap [chars]


Explanation   

This message means that an unsupported match class-map configuration command was configured in a policy map and attached to an egress interface or that more than one match command was configured. This is a hardware limitation. [chars] is the class-map name.


Recommended Action

Reconfigure the class map or the policy map. Use only the match ip dscp dscp-list class-map configuration command in a policy map that is attached to an egress interface. Only one match per class map is supported.

Hope this helps.

Regards,

Shashank

Hi,

Thanks for the reply. Is this a hardware limitation or a software one?

Hi jeevan,

It's a hardware limitation on 3750. You can actually fix your ACL as i notice "match-all" in your policy-map. Probably club those two ACL's together & have one match statement. Just highlighed, you may already know the fix

Thanks

Vivek

Thanks Vivek :-)

Do u happen to hear about support for object-groups in ACLs on these platforms ?

3750 platforms doesn't have the support of object-groups yet. I believe on router starting IOS 12.4 we do have. Unfortunately, this is not the case on 3750.

I would still suggest to check the feature navigator. But i doubt.

Thanks Vivek for pitching in with your excellent replies!

Regards,

Shashank

jmoss1
Beginner

Hi, I am wondering about best practices when trying to mark and classify webex video traffic from the users PC client.  I have looked around and nbar is possibly one option or i could match on the destination and ports of the traffic.

But i'm wondering on what other people had experienced?  as there does not seem to be a best practices guide on this currently (unless i'm missing it)? 

thanks in advance

Jonathan         

Hi Jonathan,

First time any traffic is marked, we normally depend either on nbar or an ACL (matching L4ports/IP address etc). Once traffic is marked with a dscp/ip prec, the marking can be used to classify traffic on every subsequent hop which will also be quicker as deep packet inspection will be avoided.

Hope that helps.

Regards,

Shashank

m.sir
Rising star

Hello

I need limit bandwidth on Cisco 3750 using command srr-queue bandwidth limit

However i need limit speed around 30 Mbit sec.. interface is 1 Gig.. My question is if I  force speed on interface to 100 Mbit and apply command srr-queue bandwidth limit 30  will i get desired 30 Mbit??.. in other words is limit calculated from HW speed of interface (1 Gig) or from actual speed (100Mbit) ??

thanks

msir

weight specified in "srr-queue bandiwdth limit weight" is percentage of the port speed to which the standard port should be limited and not the maximum speed of the interface.  So your comfiguration should work to limit the rate to 30 mbps. However please note that this command only affects egress rate. If you wish to rate limit ingress traffic, policing is the option.

Regards,

Shashank

jkeeffe
Explorer

Hello - This question has to do with QoS on a 6500 1P3Q8T line card, and the max/min thresholds to be more specific.

In the following example, what tells the scheduler (if that is the correct term) to drop packets in queue 1 before queue 2, and queue 2 before queue 3?  I'm still a little confused about the min/max values and how to determine what to use.  Since the values for queue 1 & 2 are the same, what then gives preference to queue 2 over queue 1?

int gx/x

mls qos trust dscp

wrr-queue queue-limit 5 40 25

priority-queue queue-limit 30

wrr-queue bandwidth 5 50 45

wrr-queue random-detect 1

wrr-queue random-detect 2

wrr-queue random-detect 3

wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100

wrr-queue random-detect min-threshold 1 80 100 100 100 100 100 100 100

wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100

wrr-queue random-detect min-threshold 2 80 100 100 100 100 100 100 100

wrr-queue random-detect max-threshold 3 70 80 90 100 100 100 100 100

wrr-queue random-detect min-threshold 3 60 70 80 90 100 100 100 100

wrr-queue cos-map 1 1 1

wrr-queue cos-map 2 1 0

wrr-queue cos-map 3 1 2

wrr-queue cos-map 3 2 3

wrr-queue cos-map 3 3 6

wrr-queue cos-map 3 4 7

priority-queue cos-map 1 4 5

Hi,

Please find the answers below:

I'm still a little confused about the min/max values and how to determine what to use.

The min threshold identifies the queue size percentage at which the WRED dropping starts to be applied, while the max threshold identifies the queue size level at which tail drops occur.

Since the values for queue 1 & 2 are the same, what then gives preference to queue 2 over queue 1?

You need to consider bandwidth ratios for the queues. If bandwidth ratios were the same, then they would be treated the same.  If bandwidth ratios were different, scheduler will remove lesser number of packets from queue having lower bandwidth guarantee.

Regards,

Sweta