cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
714
Views
0
Helpful
2
Replies
Highlighted
Beginner

ASR 1001-x Vlan trunking

Current I have the following network design

 

(cisco 6500 – site 1)--------trunk------------(cisco 6500 – site 2)

 

The 6500’s are configured to share certain vlans between both sites. On vlan 777 I also do OSPF for IGP between locations.

 

 

Current 6500 trunk:

interface GigabitEthernet4/9

 switchport

 switchport access vlan 777

 switchport trunk encapsulation dot1q

 switchport trunk native vlan 777

 switchport trunk allowed vlan 3,500,701,777,999

 switchport trunk pruning vlan 701

 switchport mode trunk

 bandwidth 500000

 load-interval 30

 mls qos trust dscp

 no cdp enable

 

 

OSPF vlan for IGP between sites:

interface Vlan777

bandwidth 500000

 ip address x.x.x.1 255.255.255.252

 ip flow ingress

 ip flow egress

 load-interval 30

 ipv6 address xxx:xxx:0:1::5/126

 ipv6 ospf 2 area 0

 hold-queue 2000 in

 

I’m looking to change this but keep the vlan connectivity between sites, where vlans on the 6500 switches at both locations can communicate with each other over the trunk

But im adding a cisco ASR 1001-x to handle BGP/EDGE and link from site to site.

 

{upstream/internet}--------[ASR1001-x]---------trunk---------[ASR 1001-x]------{upstream/internet}

                                                     |                                                              |

                                                  Trunk                                                    Trunk

                                                     |                                                              |                                                                                                                             (6500)                                                  (6500)

 

So is it possible to have the ASR handle vlans coming in from the 6500 and pass them down to another ASR to the final destination on the 6500.

I’m running IOS XE version 16 and have found very little information on how to do this.  I wanted to do this as a pure config/software solution however I know the ASR has Gig SPAS (SPA-2X1GE-V2 ) that will handle trunks. Not sure if this is the best route but initially I would like to stay away from extra hardware if I can.

 

If someone can point me in the right direction or has a config example that would be highly appreciated.

 

TIA, Paul

 

 

 

Everyone's tags (3)
2 REPLIES 2
VIP Advisor

Re: ASR 1001-x Vlan trunking

Hello

You could have the core 6500 with L3 vlans for the ISR connections and switch mgt 

 

assign the ISR to access ports in its relative  vlan and keep the trunk interconnect between the 6500 providing this connection supports it

 

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: ASR 1001-x Vlan trunking

Ended up using EVC, EFP bridge domains on the ASR to take vlan trunks from the 6500 and tunnel them through or to the L3 device in this case a cisco ASR 1001-x.  Hope this helps someone.

 

BTW i notice that on the ASR1K there is no trunk instance only ethernet, so you end up with all these service instances for the various EVCs/VLANs.

 

 

Paul

 

 

on the ASR 1001-x

 

!
interface GigabitEthernet0/0/1
no ip address
negotiation auto
cdp enable
no cdp tlv app
service instance 10 ethernet
encapsulation dot1q 10
rewrite ingress tag pop 1 symmetric
l2protocol forward stp
bridge-domain 10
!
service instance 800 ethernet
encapsulation dot1q 9
bridge-domain 9
!

 

! acts as L3 SVI interface only needed if L2 links needs to get out using this router or for testing.

interface BDI9
ip address 172.32.32.1 255.255.255.0
encapsulation dot1Q 9
!
interface BDI10
ip address 172.31.31.1 255.255.255.0
!

 

on the 6500

interface GigabitEthernet4/7
description TEST TRUNK TO ASR
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 9,10
switchport mode trunk
end

 

!
interface Vlan9
description testing vlan
ip address 172.32.32.2 255.255.255.0
end

 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards