cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
2938
Views
0
Helpful
15
Replies
TarasKotov
Beginner

ASR1002 OSPF trouble

I have a problem with OSPF on ASR1002 router.

It has 2 neighbors - D-Link L3 switches (DGS-3627G). I attached the scheme to this post.

ASR1002 is used for: 2 BGP FW, NAT, ISG, Netflow.

IOS version is: asr1000rp1-adventerprise.03.03.00.S.151-2.S.bin

Neighbors are:

ASR1002#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface

1.1.1.87          1   FULL/BDR        00:00:31    10.255.10.1     GigabitEthernet0/1/2

1.1.1.99          1   FULL/BDR        00:00:06    10.255.10.5     GigabitEthernet0/1/0

The problem is that neighbors are periodically going down:

6756: Aug 23 10:50:59.005 OMSST: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.99 on GigabitEthernet0/1/0 from FULL to DOWN, Neighbor Down: Dead timer expired

016757: Aug 23 10:51:29.018 OMSST: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.99 on GigabitEthernet0/1/0 from LOADING to FULL, Loading Done

016758: Aug 23 11:24:59.145 OMSST: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.99 on GigabitEthernet0/1/0 from FULL to DOWN, Neighbor Down: Dead timer expired

016759: Aug 23 11:25:29.156 OMSST: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.99 on GigabitEthernet0/1/0 from LOADING to FULL, Loading Done

016761: Aug 23 13:04:29.555 OMSST: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.99 on GigabitEthernet0/1/0 from FULL to DOWN, Neighbor Down: Dead timer expired

016762: Aug 23 13:04:59.566 OMSST: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.99 on GigabitEthernet0/1/0 from LOADING to FULL, Loading Done

016763: Aug 23 13:34:49.683 OMSST: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.99 on GigabitEthernet0/1/0 from FULL to DOWN, Neighbor Down: Dead timer expired

016764: Aug 23 13:35:19.695 OMSST: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.99 on GigabitEthernet0/1/0 from LOADING to FULL, Loading Done

And the biggest problem is that they sometimes go down simultaneously.

ASR says that it doesn't see hello packets and drops the adjacency:

018299: Aug 23 17:58:39.073 OMSST: OSPF-1 HELLO Gi0/1/0: Rcv hello from 1.1.1.99 area 0.0.0.2 10.255.10.5

018300: Aug 23 17:58:39.450 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018301: Aug 23 17:58:40.430 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018302: Aug 23 17:58:41.367 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018303: Aug 23 17:58:42.286 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018304: Aug 23 17:58:42.327 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018305: Aug 23 17:58:43.189 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018306: Aug 23 17:58:44.119 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018307: Aug 23 17:58:45.096 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018308: Aug 23 17:58:45.794 OMSST: OSPF-1 HLOIN: input packet - Hello   GigabitEthernet0/1/2 (0)

018309: Aug 23 17:58:46.093 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018310: Aug 23 17:58:47.046 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018311: Aug 23 17:58:48.010 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018312: Aug 23 17:58:48.026 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018313: Aug 23 17:58:48.026 OMSST: OSPF-1 HELLO Gi0/1/0: Send hello to 224.0.0.5 area 0.0.0.2 from 10.255.10.6

ASR1002#

018314: Aug 23 17:58:48.975 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018315: Aug 23 17:58:49.908 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018316: Aug 23 17:58:50.844 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018317: Aug 23 17:58:51.785 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018318: Aug 23 17:58:52.286 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018319: Aug 23 17:58:52.747 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018320: Aug 23 17:58:53.739 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018321: Aug 23 17:58:54.718 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018322: Aug 23 17:58:55.621 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018323: Aug 23 17:58:55.795 OMSST: OSPF-1 HLOIN: input packet - Hello   GigabitEthernet0/1/2 (0)

018324: Aug 23 17:58:56.601 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018325: Aug 23 17:58:57.028 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018326: Aug 23 17:58:57.028 OMSST: OSPF-1 HELLO Gi0/1/0: Send hello to 224.0.0.5 area 0.0.0.2 from 10.255.10.6

018327: Aug 23 17:58:57.506 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018328: Aug 23 17:58:58.489 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018329: Aug 23 17:58:59.418 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018330: Aug 23 17:59:00.355 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018331: Aug 23 17:59:01.288 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018332: Aug 23 17:59:01.675 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018333: Aug 23 17:59:02.216 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018334: Aug 23 17:59:03.123 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018335: Aug 23 17:59:04.083 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018336: Aug 23 17:59:05.064 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018337: Aug 23 17:59:05.795 OMSST: OSPF-1 HLOIN: input packet - Hello   GigabitEthernet0/1/2 (0)

018338: Aug 23 17:59:06.059 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018339: Aug 23 17:59:06.263 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018340: Aug 23 17:59:06.263 OMSST: OSPF-1 HELLO Gi0/1/0: Send hello to 224.0.0.5 area 0.0.0.2 from 10.255.10.6

018341: Aug 23 17:59:06.998 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018342: Aug 23 17:59:07.983 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018343: Aug 23 17:59:08.975 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018344: Aug 23 17:59:09.936 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018345: Aug 23 17:59:10.930 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018346: Aug 23 17:59:11.399 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018347: Aug 23 17:59:11.889 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018348: Aug 23 17:59:12.876 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018349: Aug 23 17:59:13.869 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018350: Aug 23 17:59:14.792 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018351: Aug 23 17:59:15.733 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018352: Aug 23 17:59:15.796 OMSST: OSPF-1 HLOIN: input packet - Hello   GigabitEthernet0/1/2 (0)

018353: Aug 23 17:59:16.174 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018354: Aug 23 17:59:16.174 OMSST: OSPF-1 HELLO Gi0/1/0: Send hello to 224.0.0.5 area 0.0.0.2 from 10.255.10.6

018355: Aug 23 17:59:16.714 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

ASR1002#

018356: Aug 23 17:59:17.648 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018357: Aug 23 17:59:18.616 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

018358: Aug 23 17:59:19.073 OMSST: OSPF-1 HLOTM: timer expiration - NBR_DEAD_TIMER (0)

018359: Aug 23 17:59:19.073 OMSST: OSPF-1 ADJ   Gi0/1/0: 1.1.1.99 address 10.255.10.5 is dead

018360: Aug 23 17:59:19.073 OMSST: OSPF-1 ADJ   Gi0/1/0: 1.1.1.99 address 10.255.10.5 is dead, state DOWN

018361: Aug 23 17:59:19.073 OMSST: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.99 on GigabitEthernet0/1/0 from FULL to DOWN, Neighbor Down: Dead timer expired

ASR1002#

018362: Aug 23 17:59:19.073 OMSST: OSPF-1 ADJ   Gi0/1/0: Neighbor change event

018363: Aug 23 17:59:19.073 OMSST: OSPF-1 ADJ   Gi0/1/0: DR/BDR election

018364: Aug 23 17:59:19.073 OMSST: OSPF-1 ADJ   Gi0/1/0: Elect BDR 0.0.0.0

018365: Aug 23 17:59:19.073 OMSST: OSPF-1 ADJ   Gi0/1/0: Elect DR 10.255.0.1

018366: Aug 23 17:59:19.073 OMSST: OSPF-1 ADJ   Gi0/1/0: DR: 10.255.0.1 (Id)   BDR: none

018367: Aug 23 17:59:19.564 OMSST: OSPF-1 HLOTM: timer expiration - IF_HELLO_TIMER (0)

I placed another switch between ASR1002 and one of its neighbors (neighbor 1.1.1.99) to mirror traffic (Cisco calls it SPAN) and see hello packets to and from D-Link switch. At some moment (there is no exact pattern like "once an hour" or "once 30 minutes") ASR begins to send hello packets without Neighbor field in it. After 4 hello packets it drops an adjacency and begins DR/BDR election and reestablishes adjacency again.

Here is config section about OSPF on ASR:

ASR1002#sh run | s router ospf

router ospf 1

router-id 10.255.0.1

auto-cost reference-bandwidth 10000

area 4 nssa

passive-interface default

no passive-interface GigabitEthernet0/1/0

no passive-interface GigabitEthernet0/1/2

network 10.255.10.2 0.0.0.0 area 0.0.0.1

network 10.255.10.6 0.0.0.0 area 0.0.0.2

neighbor 10.255.10.5

default-information originate always metric-type 1

ASR1002#sh run int gi0/1/0

Building configuration...

Current configuration : 456 bytes

!

interface GigabitEthernet0/1/0

description === ASR1002[Gi0/1/0] --- agsw01-99[23] [Access Net] ===

dampening

ip address 10.255.10.6 255.255.255.252

ip access-group nat-pool in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip flow egress

ip virtual-reassembly

load-interval 30

carrier-delay msec 0

negotiation auto

service-policy type control ISG-IP-POLICY

ip subscriber routed

  initiator unclassified ip-address

end

ASR1002#sh run int gi0/1/2

Building configuration...

Current configuration : 456 bytes

!

interface GigabitEthernet0/1/2

description === ASR1002[Gi0/1/2] --- agsw01-87[23] [Access Net] ===

dampening

ip address 10.255.10.2 255.255.255.252

ip access-group nat-pool in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip flow egress

ip virtual-reassembly

load-interval 30

carrier-delay msec 0

negotiation auto

service-policy type control ISG-IP-POLICY

ip subscriber routed

  initiator unclassified ip-address

I suspect that the problem can be somehow connected with ESP resources like DRAM, TCAM, etc and ASR drops hello packets before getting them to RP. But can't find any diagnostic command to confirm it.

15 REPLIES 15
grinch182
Beginner

First thing I would like to say that your ospf designed strange. To me your ASR should be in Area 0 or at least be connected to Area 0.

Second thing is - I can see you use ACL on your interfaces, please make sure you have permition for OSPF traffic on it.

Third thing you need to compare OSPF timers on all devices. Instead of EIGRP OSPF can orginize neighborship with different timers but adjacency process will never be done.

Sincerely,

GRinch

Dear GRinch,

Thank you for answering.

There is nothing strange about design. Anyway. I tried "all in area 0" design, tried to use subinterfaces, and many other things. Two links with different area in each is used because of its small size (only two routers) and simplicity to diagnose.

ACL is simple - deny some public IP addresses while allow everything else:

Extended IP access list nat-pool

    10 deny ip any 0.0.0.15 (10797 matches)

    20 deny ip any 0.0.0.31 (2 matches)

    30 deny ip any 0.0.0.31

    40 deny ip any 0.0.0.31 (1 match)

    50 deny ip any 0.0.0.255

    60 permit ip any any (462977191 matches)

If you read my first message carefully, you'll notice that ASR and D-Link switches form an adjacencies for some time. So, the problem is not about timers.

Sincerely,

Taras Kotov

Talking about design I still thinking it's strange. Functioning between two different areas should be organyzed throug area 0. This is OSPF concept =)

Give me a bit time to think and read what can be reason of your issue.

Sincerely,

GRinch

There is no problem with it - 1.1.1.87 and 1.1.1.99 are in area 0. As well as in some other areas. )

Yep, but your ASR in two aereas too and none of it is area 0. However I would like to advice you increase dead timers and see if it helps.

-Grinch

Peter Paluch
Hall of Fame Cisco Employee

Grinch,

Increasing dead timers, in my opinion, is not a good idea because it only makes the problem less apparent but not solved. Within the default dead interval setting of 40 seconds, a router should send 4 Hello packets - more than enough for the neighborship/adjacency to stay up. If 4 Hello packets in a row are lost, the problem is not going to be solved by increasing the dead interval.

We should be probably inspecting the basic IP connectivity between this ASR and its OSPF neighbors. It seems that the OSPF/IP packets are being lost somewhere along the way, or for some reason, they are not processed even if they arrived.

Taras: Grinch is correct in his comment that your ASR appears to be physically connected to different areas but none of them is Area 0. It does not matter in such case that some of the ASR's OSPF neighbors are in area 0 themselves. OSPF internal design mandates that whenever your router has a physical connectivity to multiple areas (i.e. has different interfaces assigned to different areas), one of these areas must be area 0 - in other words, an area boundary router must always be physically connected to area 0. According to your exhibit, this requirement is not met.

However, failing to meet this requirement would not cause the OSPF adjacencies to flap.

Best regards,

Peter

Thanks everyone for answering.

I made area 0 between ASR and its neighbors:

ASR1002#sh run | s router ospf

router ospf 1

router-id 10.255.0.1

auto-cost reference-bandwidth 10000

area 4 nssa

passive-interface default

no passive-interface GigabitEthernet0/1/0

no passive-interface GigabitEthernet0/1/2

network 10.255.10.2 0.0.0.0 area 0.0.0.0

network 10.255.10.6 0.0.0.0 area 0.0.0.0

neighbor 10.255.10.5

default-information originate always metric-type 1

ASR1002#show ip ospf neighbor detail

Neighbor 1.1.1.87, interface address 10.255.10.1

    In the area 0.0.0.0 via interface GigabitEthernet0/1/2

    Neighbor priority is 0, State is FULL, 6 state changes

    DR is 10.255.10.2 BDR is 0.0.0.0

    Options is 0x2 in Hello (E-bit)

    Options is 0x2 in DBD (E-bit)

    Dead timer due in 00:00:38

    Neighbor is up for 00:14:27

    Index 2/1, retransmission queue length 0, number of retransmission 0

    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)

    Last retransmission scan length is 0, maximum is 0

    Last retransmission scan time is 0 msec, maximum is 0 msec

Neighbor 1.1.1.99, interface address 10.255.10.5

    In the area 0.0.0.0 via interface GigabitEthernet0/1/0

    Neighbor priority is 0 (configured 0), State is FULL, 13 state changes

    DR is 10.255.10.6 BDR is 0.0.0.0

    Options is 0x2 in Hello (E-bit)

    Options is 0x2 in DBD (E-bit)

    Dead timer due in 00:00:38

    Neighbor is up for 00:08:11

    Index 1/2, retransmission queue length 0, number of retransmission 2

    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)

    Last retransmission scan length is 1, maximum is 1

    Last retransmission scan time is 0 msec, maximum is 0 msec

And after 3 minutes adjacency with neigbor 1.1.1.99 went down once again:

007022: Aug 24 17:00:13.921 OMSST: %SYS-5-CONFIG_I: Configured from console by admin on vty0 (81.1.213.21)

007023: Aug 24 17:03:59.998 OMSST: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.99 on GigabitEthernet0/1/0 from FULL to DOWN, Neighbor Down: Dead timer expired

007024: Aug 24 17:04:43.878 OMSST: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.99 on GigabitEthernet0/1/0 from LOADING to FULL, Loading Done

Sincerely,

Taras Kotov

Could you please provide output of show ip ospf traffic command?

-GRinch

> Could you please provide output of show ip ospf traffic command?

Here it is:

ASR1002#show ip ospf traffic

OSPF statistics:

  Last clearing of OSPF traffic counters never

  Rcvd: 6413 total, 0 checksum errors

        5073 hello, 132 database desc, 38 link state req

        1007 link state updates, 155 link state acks

  Sent: 6493 total

        5620 hello, 123 database desc, 38 link state req

        539 link state updates, 173 link state acks

            OSPF Router with ID (10.255.0.1) (Process ID 1)

OSPF queue statistics for process ID 1:

                   InputQ     UpdateQ    OutputQ

  Limit            0          200        0

  Drops            0          0          0

  Max delay [msec] 154        4842       1

  Max size         16         15         2

    Invalid        0          0          0

    Hello          1          0          0

    DB des         0          0          1

    LS req         0          0          1

    LS upd         15         15         0

    LS ack         0          0          0

  Current size     0          0          0

    Invalid        0          0          0

    Hello          0          0          0

    DB des         0          0          0

    LS req         0          0          0

    LS upd         0          0          0

    LS ack         0          0          0

Interface statistics:

    Interface GigabitEthernet0/1/2

Last clearing of interface traffic counters never

OSPF packets received/sent

  Type          Packets              Bytes

  RX Invalid    0                    0

  RX Hello      170                  8160

  RX DB des     10                   1280

  RX LS req     0                    0

  RX LS upd     25                   1652

  RX LS ack     17                   808

  RX Total      222                  11900

  TX Failed     0                    0

  TX Hello      180                  14396

  TX DB des     2                    1088

  TX LS req     0                    0

  TX LS upd     43                   3712

  TX LS ack     0                    0

  TX Total      225                  19196

OSPF header errors

  Length 0, Auth Type 0, Checksum 0, Version 0,

  Bad Source 0, No Virtual Link 0, Area Mismatch 0,

  No Sham Link 0, Self Originated 0, Duplicate ID 0,

  Hello 0, MTU Mismatch 0, Nbr Ignored 0,

  LLS 0, Unknown Neighbor 0, Authentication 0,

  TTL Check Fail 0

OSPF LSA errors

  Type 0, Length 0, Data 0, Checksum 0

    Interface GigabitEthernet0/1/0

Last clearing of interface traffic counters never

OSPF packets received/sent

  Type          Packets              Bytes

  RX Invalid    0                    0

  RX Hello      170                  8160

  RX DB des     11                   2252

  RX LS req     1                    84

  RX LS upd     47                   4420

  RX LS ack     8                    512

  RX Total      237                  15428

  TX Failed     0                    0

  TX Hello      187                  14944

  TX DB des     7                    1528

  TX LS req     1                    596

  TX LS upd     54                   4808

  TX LS ack     0                    0

  TX Total      249                  21876

OSPF header errors

  Length 0, Auth Type 0, Checksum 0, Version 0,

  Bad Source 0, No Virtual Link 0, Area Mismatch 0,

  No Sham Link 0, Self Originated 0, Duplicate ID 0,

  Hello 0, MTU Mismatch 0, Nbr Ignored 0,

  LLS 0, Unknown Neighbor 0, Authentication 0,

  TTL Check Fail 0

OSPF LSA errors

  Type 0, Length 0, Data 0, Checksum 0

    Interface GigabitEthernet0/1/4.4

Last clearing of interface traffic counters never

OSPF packets received/sent

  Type          Packets              Bytes

  RX Invalid    0                    0

  RX Hello      0                    0

  RX DB des     0                    0

  RX LS req     0                    0

  RX LS upd     0                    0

  RX LS ack     0                    0

  RX Total      0                    0

  TX Failed     0                    0

  TX Hello      0                    0

  TX DB des     0                    0

  TX LS req     0                    0

  TX LS upd     0                    0

  TX LS ack     0                    0

  TX Total      0                    0

OSPF header errors

  Length 0, Auth Type 0, Checksum 0, Version 0,

  Bad Source 0, No Virtual Link 0, Area Mismatch 0,

  No Sham Link 0, Self Originated 0, Duplicate ID 0,

  Hello 0, MTU Mismatch 0, Nbr Ignored 0,

  LLS 0, Unknown Neighbor 0, Authentication 0,

  TTL Check Fail 0

OSPF LSA errors

  Type 0, Length 0, Data 0, Checksum 0

Summary traffic statistics for process ID 1:

OSPF packets received/sent

  Type          Packets              Bytes

  RX Invalid    0                    0

  RX Hello      340                  16320

  RX DB des     21                   3532

  RX LS req     1                    84

  RX LS upd     72                   6072

  RX LS ack     25                   1320

  RX Total      459                  27328

  TX Failed     0                    0

  TX Hello      367                  29340

  TX DB des     9                    2616

  TX LS req     1                    596

  TX LS upd     97                   8520

  TX LS ack     0                    0

  TX Total      474                  41072

OSPF header errors

  Length 0, Auth Type 0, Checksum 0, Version 0,

  Bad Source 0, No Virtual Link 0, Area Mismatch 0,

  No Sham Link 0, Self Originated 0, Duplicate ID 0,

  Hello 0, MTU Mismatch 0, Nbr Ignored 0,

  LLS 0, Unknown Neighbor 0, Authentication 0,

  TTL Check Fail 0

OSPF LSA errors

  Type 0, Length 0, Data 0, Checksum 0

Sincerely,

Taras Kotov

also please provide output from command show interface Gi0/1/2 and Gi0/1/0.

Sincerely,

GRinch

Could it be a problem with the DLink side? Per your debug, the ASR is doing its job.

It sent 4 hello packets to the DLink switch and the switch never responded to the hello packets so it declared the neighbor dead.

Do you have any other Cisco equipment that you can test OSPF adjacency with the ASR?

You can be facing some interoperability issues or a bug in the DLink.

TarasKotov
Beginner

1. It's sad, but I can't add a comment with info about interfaces info. Site errors me:

This message can not be displayed due to its content.  Please use the Contact Us link with any questions.

I wrote a question to Cisco support, but didn't get a response yet.

But I can say that there is no error packet in any of this two interfaces. And maximum load is 30 Mb/s in each direction.

2. As I said earlier (my 1st post) I sniffed for traffic between ASR and 1.1.1.99 and saw hello packets in each direction.

I tried to use monitor command on ASR, but I lost connection with it and had to ask to reboot it (ASR is in a production).

3. Sorry, but I don't have any other Cisco equipment on that site to replace D-Link.

Also I used RFC 2328 and sniffer to look at packets. There is nothing wrong in them.

It seems, that for some unknown reason ASR stop seeing hello packets from D-Link. And that's all.

Peter Paluch
Hall of Fame Cisco Employee

Taras,

If you are able to use a packet sniffer, can you capture the OSPF traffic since the beginning of the adjacency up to and including its flap and reestablishment, and post the capture here? Please include these protocols in the capture:

- OSPF

- ICMP

- ARP

Also, are you running any sort of multicast filtering between the ASR and the D-Link, or some kind of IGMP Snooping?

Best regards,

Peter

douhanm
Beginner

You never answered the question above if all timers are the same on all devices, it is most likely a variation in timing that makes your neighbors go down

Sent from Cisco Technical Support iPhone App