cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

943
Views
0
Helpful
3
Replies
Highlighted

Auto-Failover between 2 ISPs

Hi,

I have 2 ISPs & configured my interfaces as below :

WAN INTERFACE 1 :-

interface GigabitEthernet0/1

description TCL_WAN

ip address 116.212.176.2 255.255.255.224

ip nat outside

ip virtual-reassembly in

ip policy route-map TCL

duplex full

speed 100

crypto map clientmap

WAN INTERFACE 2 :-

interface GigabitEthernet0/2

description BHARTI_WAN

ip address 61.95.191.54 255.255.255.252

ip nat outside

ip virtual-reassembly in

ip policy route-map BHARTI

duplex full

speed 100

LAN INTERFACE :-

interface GigabitEthernet0/0

description LAN_INTERFACE

ip address 192.168.32.1 255.255.255.224

ip nat inside

ip virtual-reassembly in

duplex full

speed 100

The Auto-Failover configuration is :-

ip sla 1

icmp-echo 203.124.230.12 source-ip 116.212.176.2

frequency 5

ip sla schedule 1 life forever start-time now

track 1 ip sla 1 reachability

delay down 5 up 30

!

track 2 interface GigabitEthernet0/2 ip routing

delay down 5 up 5

Default IP Routes are :-

ip route 0.0.0.0 0.0.0.0 116.212.176.1 track 1          //Primary WAN

ip route 0.0.0.0 0.0.0.0 61.95.191.53 250 track 2     //Backup WAN

Please tell me whether TRACK 2 is also really needed for my requirement OR only Track 1 will be helpful. What will be the impact of Track 2? Please suggest.

-Balbeer Singh.

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Advisor

Auto-Failover between 2 ISPs

Hi,

only track 1 is needed but you should modify the IP SLA like this:

no ip sla 1

ip sla 1

icmp-echo 203.124.230.12 source-interface GigabitEthernet0/0

frequency 5

I have a question though, why are you doing PBR on inbound WAN traffic ? Shouldn't it be on the LAN interface instead ?

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
3 REPLIES 3
Advisor

Auto-Failover between 2 ISPs

Hi,

only track 1 is needed but you should modify the IP SLA like this:

no ip sla 1

ip sla 1

icmp-echo 203.124.230.12 source-interface GigabitEthernet0/0

frequency 5

I have a question though, why are you doing PBR on inbound WAN traffic ? Shouldn't it be on the LAN interface instead ?

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Auto-Failover between 2 ISPs

Hi Alain,

Thanks for the reply. Please tell me what can be the impact of Track 2 ?

I faced one problem in which both the WAN 1 was down which made Track 1 down but when WAN 1 came up, the Track 1 in the router was not up. So, I had to add the another default route entry manually as ip route 0.0.0.0 0.0.0.0 116.212.176.1. After that the Track 1 came up. Why this was happened? Please suggest. After adding this route, the entries in the router were :

ip route 0.0.0.0 0.0.0.0 116.212.176.1 track 1

ip route 0.0.0.0 0.0.0.0 61.95.191.53 250 track 2

ip route 0.0.0.0 0.0.0.0 116.212.176.1

Please Suggest.

-Balbeer Singh.

Advisor

Auto-Failover between 2 ISPs

Hi,

My suggestion is to use the source-interface in the IP SLA object and if it is still failing then you can either:

- put a host route for the destination that IP SLA is pinging with a next-hop on the primary interface

-configure local PBR for ICMP traffic destined to the host IP SLA is pinging

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards