cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1366
Views
0
Helpful
28
Replies
Beginner

Basic 891-W Config

Trying to configure an 891-W on my home network.

Basic TW cable modem ---> 891-W with DHCP

I have done the following and are getting an IP address but no internet.

I have FE8 set as DHCP and VLAN1 as 192.168.1.1 255.255.255.0

I originally thought that "WAN GE 0" would be connected via my modem but I had no luck there either so I set FE8 as WAN?

Building configuration...

Current configuration : 2907 bytes

!

! No configuration change since last restart

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 891

!

boot-start-marker

boot-end-marker

!

!

enable secret 5 $1$NEo3$vKhriHJTWWvuUH91t/4T2/

enable password

!

no aaa new-model

!

service-module wlan-ap 0 bootimage autonomous

crypto pki token default removal timeout 0

!

!

--More--                           ip source-route

no ip routing

!

!

!

ip dhcp excluded-address 192.168.1.1

!

ip dhcp pool HOME_CLIENTS

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

!

!

no ip cef

no ipv6 cef

!

!

!

!

multilink bundle-name authenticated

!

!

!

!

--More--                           !

!

license udi pid CISCO891W-AGN-A-K9 sn FTX163086U5

!

!

username cisco4 privilege 15 secret 4 drWavSXMI9Ae0nTpOhq3JAvEAKC6rTmASLdwwVrkjJ.

username cisco1 privilege 15 secret 4 gMj8cDXfU6CzFI9r1WoD5G6GTI5KwVY2O2lU2DSTP4c

username cisco2 privilege 15 secret 4 6yU7cyZFSWW4QGtgFIB/eBlLIAvZBlES6kZS.IBYhO6

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0

no ip address

--More--                           !

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

no ip address

!

interface FastEthernet5

no ip address

!

interface FastEthernet6

no ip address

!

interface FastEthernet7

no ip address

!

interface FastEthernet8

ip address dhcp

--More--                            ip nat outside

ip virtual-reassembly in

no ip route-cache

duplex half

speed auto

!

interface GigabitEthernet0

ip address dhcp

ip nat outside

ip virtual-reassembly in

no ip route-cache

duplex auto

speed auto

!

interface wlan-ap0

description Service module interface to manage the embedded AP

no ip address

no ip route-cache

arp timeout 0

!

interface Wlan-GigabitEthernet0

description Internal switch interface connecting to the embedded AP

no ip address

!

--More--                           interface Vlan1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

no ip route-cache

!

interface Async1

no ip address

encapsulation slip

no ip route-cache

!

ip forward-protocol nd

!

!

ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 101 interface Vlan1 overload

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0

ip route 0.0.0.0 0.0.0.0 FastEthernet8

!

access-list 101 permit ip 192.168.1.0 0.0.0.255 any

!

--More--                           !

!

!

!

snmp-server community public RO

!

control-plane

!

!

!

!

mgcp profile default

!

!

!

!

!

line con 0

line 1

modem InOut

stopbits 1

speed 115200

flowcontrol hardware

line 2

--More--                            no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin udptn ssh

line aux 0

line vty 0 4

privilege level 15

password 110fall2014

login local

transport input telnet

transport output telnet

line vty 5 15

privilege level 15

login local

transport input telnet

transport output telnet

!

end

891#

28 REPLIES 28
Rising star

Basic 891-W Config

Hi

it should be interface FastEthernet8 overload.

Thanks

Beginner

Basic 891-W Config

Your config above has

no ip routing

First of all you'd better change this to

ip routing

Advisor

Basic 891-W Config

Hi,

to add to the 2 previous replies, get rid of these 2 static routes as first they are pointing to a multipoint exit interface( which is highly discouraged for performance reasons and  may not work if the next-hop is not implementing proxy-arp) and secondly because they are not needed as dhcp is advertising you the default route.

---->

no ip route 0.0.0.0 0.0.0.0 GigabitEthernet0

no ip route 0.0.0.0 0.0.0.0 FastEthernet8

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Beginner

Basic 891-W Config

Thanks for the responses, can I just delete the lines from my config and reload using TFTP or is there a command that will remove these using the CLI?

no ip route 0.0.0.0 0.0.0.0 GigabitEthernet0

no ip route 0.0.0.0 0.0.0.0 FastEthernet8

Highlighted
Beginner

Basic 891-W Config

Those are the commands you enter via the CLI, the 'no' negating the  previously entered commands. You need to enter global configuration  mode, so it will look something like:

router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

router(config)#ip routing

router(config)#no ip route 0.0.0.0 0.0.0.0 GigabitEthernet0

router(config)#no ip route 0.0.0.0 0.0.0.0 FastEthernet8

router(config)#exit

router#

You'll have to save the config before rebooting otherwise any changes will be lost.

Beginner

Basic 891-W Config

OK done. What about this comment from above "it should be interface FastEthernet8 overload."?

I will connect the router to the modem via the FastEthernet8 port and try again I suppose.

Beginner

Re: Basic 891-W Config

Still no Internet, but router and laptop are getting IP address, if I do IPCONFIG /ALL everything looks good, DNS is 209.18.47.61 and 62 which I assume is Time Warner?

Sent from Cisco Technical Support iPhone App

Beginner

Re: Basic 891-W Config

You should be trying to use the 'proper' WAN port (Gi0) rather than Fa8 as the latter is a switch port. Now that you've made the above changes, try using Gi0 again but first add:

ip nat inside source list 1 interface GigabitEthernet0 overload

access-list 1 permit 192.168.1.0 0.0.0.255

If that fails to work it might be worth reposting your latest config.

Beginner

Basic 891-W Config

I made the change as you suggested but still nothing, perhaps my VLAN is off?

Building configuration...

Current configuration : 2821 bytes

!

! No configuration change since last restart

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 891

!

boot-start-marker

boot-end-marker

!

!

enable secret 5 $1$NEo3$vKhriHJTWWvuUH91t/4T2/

enable password

!

no aaa new-model

!

service-module wlan-ap 0 bootimage autonomous

crypto pki token default removal timeout 0

!

!

--More--                           ip source-route

!

!

!

ip dhcp excluded-address 192.168.1.1

!

ip dhcp pool HOME_CLIENTS

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

!

!

ip cef

no ipv6 cef

!

!

!

!

multilink bundle-name authenticated

!

!

!

!

!

--More--                           !

license udi pid CISCO891W-AGN-A-K9 sn FTX163086U5

!

!

username cisco4 privilege 15 secret 4 drWavSXMI9Ae0nTpOhq3JAvEAKC6rTmASLdwwVrkjJ.

username cisco1 privilege 15 secret 4 gMj8cDXfU6CzFI9r1WoD5G6GTI5KwVY2O2lU2DSTP4c

username cisco2 privilege 15 secret 4 6yU7cyZFSWW4QGtgFIB/eBlLIAvZBlES6kZS.IBYhO6

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0

no ip address

!

--More--                           interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

no ip address

!

interface FastEthernet5

no ip address

!

interface FastEthernet6

no ip address

!

interface FastEthernet7

no ip address

!

interface FastEthernet8

ip address dhcp

ip nat outside

--More--                            ip virtual-reassembly in

duplex half

speed auto

!

interface GigabitEthernet0

ip address dhcp

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface wlan-ap0

description Service module interface to manage the embedded AP

no ip address

arp timeout 0

!

interface Wlan-GigabitEthernet0

description Internal switch interface connecting to the embedded AP

no ip address

!

interface Vlan1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

--More--                           !

interface Async1

no ip address

encapsulation slip

!

ip forward-protocol nd

!

!

ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface GigabitEthernet0 overload

ip nat inside source list 101 interface Vlan1 overload

!

access-list 1 permit 192.168.1.0 0.0.0.225

access-list 101 permit ip 192.168.1.0 0.0.0.255 any

!

!

!

!

!

snmp-server community public RO

!

--More--                           control-plane

!

!

!

!

mgcp profile default

!

!

!

!

!

line con 0

line 1

modem InOut

stopbits 1

speed 115200

flowcontrol hardware

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin udptn ssh

line aux 0

--More--                           line vty 0 4

privilege level 15

password

login local

transport input telnet

transport output telnet

line vty 5 15

privilege level 15

login local

transport input telnet

transport output telnet

!

end

891#

Beginner

Basic 891-W Config

Change to

no ip nat inside source list 101 interface Vlan1 overload

Beginner

Re: Basic 891-W Config

Still nothing, if I run the ever so helpful "network diagnostics" on my laptop it states "cannot communicate with DNS server". I'm running Windows 8 btw.

Sent from Cisco Technical Support iPhone App

Advisor

Basic 891-W Config

Hi,

save your config and reload the router.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Beginner

Re: Basic 891-W Config

I do that at every change.

Sent from Cisco Technical Support iPhone App

Advisor

Basic 891-W Config

Hi,

Can you post the output of ipconfig/all from the PC.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards