cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
895
Views
0
Helpful
5
Replies
Highlighted
Beginner

between N5K and Nexus 9K port channel not coming up

Hi All,


trying to configure port channel between Nexus 5k and Nexus 9K ,  port channel not coming up . the connected interfaces on the Nexus 5k device  status is suspended , Once I remove port channel configuration , interface status  moved from suspended to connected , any suggestion please ?

configs

interface port-channel300
   switchport mode trunk
  switchport trunk allowed vlan 300-314,703
  speed 10000   ( this got added automatically under the portchannel 300)


interface Ethernet1/3
  switchport mode trunk
  switchport trunk allowed vlan 300 - 314,703
  channel-group 300 mode active


interface Ethernet1/4
  switchport mode trunk
  switchport trunk allowed vlan 300 - 314,703
  channel-group 300 mode active


logs ---


nexus 5K# sh int port channel 300

port-channel300 is down (No operational members)
  MTU 1500 bytes, BW 100000 Kbit, DLY 10 usec
  reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA
  Port mode is trunk
  auto-duplex, 10 Gb/s
  Input flow-control is off, output flow-control is off
  Switchport monitor is off
  EtherType is 0x8100
  Members in this channel: Eth1/3, Eth1/4


nexus 5K# sh int eth1/3

Ethernet1/3 is down (suspended)
 Dedicated Interface
  Belongs to Po300


ETHPORT-5-IF_TX_FLOW_CONTROL: Interface Ethernet1/3, operational Transmit Flow Control state changed to off

ETHPORT-5-IF_RX_FLOW_CONTROL: Interface Ethernet1/4, operational Receive Flow Control state changed to off

Nexus 5k #sh int status


--------------------------------------------------------------------------------
Port          Name               Status    Vlan      Duplex  Speed   Type
--------------------------------------------------------------------------------

Eth1/3               xyz                 suspnd    trunk     full    10G     10Gbase-SR
Eth1/4               xyz                 suspnd    trunk     full    10G     10Gbase-SR


nexus 5k# sh port-channel summary
Flags:  D - Down        P - Up in port-channel (members)
        I - Individual  H - Hot-standby (LACP only)
        s - Suspended   r - Module-removed
        S - Switched    R - Routed
        U - Up (port-channel)
        M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port-       Type     Protocol  Member Ports
      Channel
--------------------------------------------------------------------------------

300   Po300(SD)   Eth      LACP      Eth1/3(s)    Eth1/4(s)   

the moment remove int port channel 300 from the switch , ports status shows - connected instead of suspended

5 REPLIES 5
Highlighted
VIP Mentor

Hello,

Hello,

try and enable lacp:

nexus5K(config)# feature lacp

Beginner

feature lacp already in place

feature lacp already in place , disable and added again , still no luck :(

Highlighted
VIP Mentor

Hello,

Hello,

I am not sure if that makes a difference, but I usually explicitly include Vlan1 in the allowed list of Vlans (unless of course you have configured another Vlan as the native one).

Highlighted
Beginner

thank you all your inputs , I

thank you all your inputs , I will let you know once done , remote end nexus 9K customer supported , yet to get response from them . thanks again.

Highlighted
VIP Expert

Hi,

Hi,

Can you try this;

Completely delete po300 from both switches

no po300

also under interface 1/3 and 1/4 delete all these commands on both switches.


  switchport mode trunk
  switchport trunk allowed vlan 300 - 314,703
  channel-group 300 mode active

now rebuild po300 this way

interface Ethernet1/3 and 1/4
 
channel-group 300 mode active

this command create po300.

now add these commands to the po interface and not the physical interfaces

int po300

switchport mode trunk
switchport trunk allowed vlan 300 - 314,703

no sh

At this time po300 should come up as well as interfaces 1/3 and 1/4 and also sync below commands to the physical interfaces

switchport mode trunk
switchport trunk allowed vlan 300 - 314,703

HTH

CreatePlease to create content
Content for Community-Ad