cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
420
Views
0
Helpful
5
Replies

BGP pinging layer 3 switch

sisqo2006
Level 1
Level 1

Hi guys,

I have been trying to familiarise myself with BGP and have come across an issue that I would like some assistance with. My set up is as follows:

I have 2 routers and 2 switches (L3) 

 

R1 connects to R2 and uses BGP               R1 G0/0> 10.10.10.1                       R2 G0/0> 10.10.10.2

R1 connects to SW1 and uses EIGRP        R1 G0/1 11.11.11.1                         SW Fa0/1> 11.11.11.2

R2 connects to SW2 and uses EIGRP        R1 G0/1 12.12.12.1                         SW Fa0/1> 12.12.12.2

 

The issue that I have is that if I try to ping 11.11.11.2 from R2 it fails (the same applies to R1 if I try ping 12.12.12.2) 

 

Hopefully the configs will explain a bit more, can anyone give me some info on this please?

 

R1:

Router#sh run
Building configuration...

Current configuration : 791 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
license udi pid CISCO1941/K9 sn FTX152422EV
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface GigabitEthernet0/0
 ip address 10.10.10.1 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 11.11.11.1 255.255.255.252
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 redistribute bgp 66 
 network 11.11.11.0 0.0.0.3
 auto-summary
!
router bgp 66
 bgp log-neighbor-changes
 no synchronization
 neighbor 10.10.10.2 remote-as 77
 network 11.11.11.0 mask 255.255.255.252
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

 

R2:

Router#sh run
Building configuration...

Current configuration : 791 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15243T7E
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface GigabitEthernet0/0
 ip address 10.10.10.2 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 12.12.12.1 255.255.255.252
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 redistribute bgp 77 
 network 12.12.12.0 0.0.0.3
 auto-summary
!
router bgp 77
 bgp log-neighbor-changes
 no synchronization
 neighbor 10.10.10.1 remote-as 66
 network 12.12.12.0 mask 255.255.255.252
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

SW1:

Switch#sh run
Building configuration...

Current configuration : 1233 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
 no switchport
 ip address 11.11.11.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 11.11.11.0 0.0.0.3
 auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

SW2:

Switch>en
Switch#sh run
Building configuration...

Current configuration : 1233 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
 no switchport
 ip address 12.12.12.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 12.12.12.0 0.0.0.3
 auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

5 Replies 5

David_Che
Level 1
Level 1

SW1 and SW2 did no have route to 10.10.10.x/252. please advertise them into EIGRP.

How do I provide this route. I thought if i used the redistribute bgp it would work. Any examples please?

You need to specify a metric when you redistribute into EIGRP.

So you can either specify it with the redistribute command or you can specific a default metric under your EIGRP process.

Jon

Sorry I forgot to mention that I also applied a metric to the command.Still no success.

Can you post -

1) "sh ip bgp summary" from both routers

2) "sh ip route" from all devices

Jon

Review Cisco Networking products for a $25 gift card