cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
833
Views
0
Helpful
1
Replies

Bridging F4 and a VLAN on C881SRST

gmorecausse
Level 1
Level 1

Hello,

I am trying to have F4 (the WAN interface) bridged to a VLAN interface. I have put my VLAN interface and my F4 in the same bridge-group, set an IP in the BVI Interface, and made sure that VLAN was properly trunked and configured on one of the router's switch ports

In other words, I need F4 to be treated as a switchport in access mode on my VLAN 10.

(...)

bridge irb

(...)

interface FastEthernet0

description trunk

switchport trunk native vlan 10

switchport trunk allowed vlan 1,10,20

switchport mode trunk

no ip address

(...)

interface FastEthernet4

no ip address

bridge-group 1

duplex auto

speed auto

(...)

interface Vlan450

no ip address

bridge-group 1

no ip redirects

no ip proxy-arp

ip nat enable

(...)

interface BVI1

vrf forwarding vl10

ip address 10.0.0.2 255.255.255.252

A ping in my vl10 VRF to 10.0.0.1 does not work. ARP does not resolve.

Is this something I am doing wrong? Or is it plain impossible?

Thanks !

1 Accepted Solution

Accepted Solutions

John Blakley
VIP Alumni
VIP Alumni

I'd have to try this with the bvi being in a vrf since I've never done it, but did you add your protocols for the bridge group?

bridge 1 protocol ieee

bridge 1 route ip

** Edit **

It does work with the bvi being in vrf:

interface FastEthernet0/0

no ip address

duplex auto

speed auto

bridge-group 1

end

interface FastEthernet1/4

no switchport

no ip address

bridge-group 1

end

interface Vlan1

no ip address

bridge-group 1

end

interface BVI1

ip vrf forwarding Cust

ip address 192.168.67.6 255.255.255.0

I have this configured as:

RouterA --- (f1/4) switch (fa0/0) ---- RouterB

RouterB can ping RouterA with no issues

RouterB#ping 192.168.67.7

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.67.7, timeout is 2 seconds:

!!!!!

The configuration is like this:

bridge irb

bridge 1 protocol ieee

bridge 1 route ip

And then the appropriate interface config to add them to the bridge group like you already have.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***

View solution in original post

1 Reply 1

John Blakley
VIP Alumni
VIP Alumni

I'd have to try this with the bvi being in a vrf since I've never done it, but did you add your protocols for the bridge group?

bridge 1 protocol ieee

bridge 1 route ip

** Edit **

It does work with the bvi being in vrf:

interface FastEthernet0/0

no ip address

duplex auto

speed auto

bridge-group 1

end

interface FastEthernet1/4

no switchport

no ip address

bridge-group 1

end

interface Vlan1

no ip address

bridge-group 1

end

interface BVI1

ip vrf forwarding Cust

ip address 192.168.67.6 255.255.255.0

I have this configured as:

RouterA --- (f1/4) switch (fa0/0) ---- RouterB

RouterB can ping RouterA with no issues

RouterB#ping 192.168.67.7

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.67.7, timeout is 2 seconds:

!!!!!

The configuration is like this:

bridge irb

bridge 1 protocol ieee

bridge 1 route ip

And then the appropriate interface config to add them to the bridge group like you already have.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Review Cisco Networking products for a $25 gift card