cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
290
Views
20
Helpful
7
Replies

C1000 stack LACP problem

Wei Ting Lin
Beginner
Beginner

Hi all

I stacked two C1000s, and set gi2/0/39-40 as etherchannel, the interface is default config,

but an error message appears, do I need to do other settings?

 

switch(config)#interface range gi2/0/39-40
switch(config-if-range)# switchport mode trunk
switch(config-if-range)# channel-group 1 mode active
Command rejected (Port-channel1, Gi2/0/39): Command execution failed on one or more switches

% Range command terminated because it failed on GigabitEthernet2/0/39

 

 

Device is C1000-48P-4X-L *2

version is 15.2(7)E4

 

7 Replies 7

marce1000
VIP Mentor VIP Mentor
VIP Mentor

 

 - Could you try channel-group 1 mode on, and or look into using the latest advisory release toohttps://software.cisco.com/download/home/286324209/type/280805680/release/15.2.7E6

 M.

Wei Ting Lin
Beginner
Beginner

I tested mode on, but it still doesn't work, and the release note didn't mention similar bugs.
I will try to test the new version.

Wei Ting Lin
Beginner
Beginner

i try upgrade to 15.2(7)E6 , the problem is slove.

thanks for sharing solution.

paul driver
VIP Expert VIP Expert
VIP Expert

Hello
Etherchannel can suffer from an order or operation in the way they are created, suggest do the following:

L2 etherchannel
1) default physical interfaces (if possible)
2) configure port-channel in physical interfaces

-- port-channel will be created automatically

3)create trunking encapsulation or access port mode directly in port-channel interface
4)enable physical interfaces "no shut"


Example:
conf t

default int ran gig0/1 -2 ( if applicable)

int ran gi0/1 -2
shut ( if applicable)
channel-group 1 mode xxx


int port-channel 1
switchport trunk encap dot1q
switchport- mode trunk
no shut

or

switchport vlan 123
swithport mode access
no shut


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

I have tried your way, but the device still shows command error.

Hello
If the error ONLY pertains to the interface range command, then could be cosmetric to the software train you are using and indeed upgrading that software solves the problem.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers