cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
418
Views
4
Helpful
11
Replies

C1300 port-channel native VLAN mismatch w/NX9k

clape
Level 1
Level 1
I am stumped.
I have a native vlan mismatch on a trunked port channel between a C1300 and 2 nexus 9336c-fx2. Now I do have this configured as a vpc on the nexus side just fyi
here are the details:
C1300
g17,18
channel-group 1 mode auto
sw mode trunk
sw trunk native vlan 999
sw trunk allowed vlan "blah,blah"

po1

sw mode trunk
sw trunk native vlan 999
sw trunk allowed vlan "blah,blah"

 

Nexus 9k both

e1/10

sw mode trunk
sw trunk native vlan 999
sw trunk allowed vlan "blah,blah"

channel-group 10 mode active

po10

sw mode trunk
sw trunk native vlan 999
sw trunk allowed vlan "blah,blah"

vpc 10

 

I have more VPCs than just this one, ALL of them are up with a native vlan of 999 and there are no native vlan log messages on either nexus. Could this be a bug on the c1300?

 

Thanks!

Charlie

 

 

1 Accepted Solution

Accepted Solutions

So good news! I found the issue and I no longer have native vlan mismatch messages. Here are the details:

If you config the native vlan for the gig interfaces and the port-channel it will act like it took the command, but if you go into the web gui and look at the port-channel members CDP interface details it will report a native vlan of 1096 or something like that, you can not view the cpd interface info for the port-channel.

To fix this in the GUI you have to configure the "LAG" in "port to VLAN" under the VLAN Management and make the membership type of the LAG for the selected VLAN (the VLAN that is the native) to untagged.

CLI solution 

 simply allow the native vlan across the trunk in addition to the native vlan command.

Thanks everyone!!!!

View solution in original post

11 Replies 11

Before do anything ypu must match the stp mode in all NSK and SW

Second it better to make mode active in  SW also, it better than use passive

MHM

I will check the stp settings, but the c1300 does not support the command active, the auto command it the only option to get a “active” channel group

the iOS on the c1300 seems to be rather watered down and syntax is rather different and the web ui is difficult to work with

 

-Charlie

MHM

Hi Again 

Do in NSK 

Show port-channel summary 

Check if the port is SU and it member is P

Then do 

Show spanning tree 

Check the status of PO to this SW

MHM

port-channel on nexus is SU and it member is P

I looked at spanning tree on c1300 and realized that I needed to disable it on the interfaces and the po. Doing this increased the time between error messages from 1 minute to 4 minutes.

-Charlie

Show interface trunk

Can you check native vlan in trunk 

Also in NSK do

Show vpc breif <-share it here 

MHM

balaji.bandi
Hall of Fame
Hall of Fame
I have a native vlan mismatch on a trunked port channel between a C1300 and 2 nexus 9336c-fx2

can you post the logs here to understand the issue, as per the configuration you did, not seen any obvious, since C1300 only support ON - NON-LACP - Auto - LACP.

VLAN 999 created on C1300 ?

Other information to confrm, you have Nexus 9K running vPC, so both the switches have identical configuration for the vPC to work.

Hope the port-channel up and only native VLAN is the worry bit here ?

what version of code running on both the devices ?

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Cant post the logs, VLAN 999 is created, vPC peer-link is up and the vPC to the c1300 is up. PO on c1300 is up.

native VLAN mismatch is the only issue to address

software NXOS 10.4.3

software c1300 4.0.0.93

 

Charlie 

Cant post the logs  - i am afraid any more we can support here - if don't have visibility.

native VLAN mismatch is the only issue to address

by saying that above, ignore with log discriminator - if that is log only.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

So good news! I found the issue and I no longer have native vlan mismatch messages. Here are the details:

If you config the native vlan for the gig interfaces and the port-channel it will act like it took the command, but if you go into the web gui and look at the port-channel members CDP interface details it will report a native vlan of 1096 or something like that, you can not view the cpd interface info for the port-channel.

To fix this in the GUI you have to configure the "LAG" in "port to VLAN" under the VLAN Management and make the membership type of the LAG for the selected VLAN (the VLAN that is the native) to untagged.

CLI solution 

 simply allow the native vlan across the trunk in addition to the native vlan command.

Thanks everyone!!!!

thanks for update us

have a nice day

MHM

Review Cisco Networking for a $25 gift card