cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4647
Views
0
Helpful
7
Replies

C3560 dhcp server for Nortel ip phones

CSCO10655862
Level 1
Level 1

Hi:

I just triying to setup a dhcp server in my catalyst 3560 switch for a nortel ip phones.  I show you mmy configuration:

VOICE VLAN: 3

DATA VLAN: 1

S1:10.2.110.200

port:4100

Nortel IP Phones: IP 2002 (Firmware Version 0604D9H)  & IP 1110 (Firmware Version 0623C7)

Switch Configuration:

aaa new-model
!
aaa session-id common
ip subnet-zero
ip routing
!
ip dhcp pool datos
   network 10.2.100.0 255.255.255.0
   default-router 10.2.100.1
   lease 0 2
!
ip dhcp pool voice
   network 10.2.110.0 255.255.255.0
   default-router 10.2.110.200
   option 191 ascii "VLAN-A:3"
   option 128 ascii "Nortel-i2004-A,10.2.100.200:4100,1,5."
   lease 0 2
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface FastEthernet0/1
switchport mode access
switchport voice vlan 3
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/2
switchport mode access
switchport voice vlan 3
spanning-tree portfast
!
interface FastEthernet0/3
switchport mode access
switchport voice vlan 3
spanning-tree portfast
!
interface FastEthernet0/4
switchport mode access
switchport voice vlan 3
spanning-tree portfast
!
interface FastEthernet0/5
switchport mode access
switchport voice vlan 3
spanning-tree portfast
!
interface FastEthernet0/6
switchport mode access
switchport voice vlan 3
spanning-tree portfast
!
interface FastEthernet0/7
switchport mode access
switchport voice vlan 3
spanning-tree portfast
!
interface FastEthernet0/8
switchport mode access
switchport voice vlan 3
spanning-tree portfast
!
interface FastEthernet0/9
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/10
switchport mode access
switchport voice vlan 3
spanning-tree portfast
!
interface FastEthernet0/11
switchport mode access
switchport voice vlan 3
spanning-tree portfast
!
interface FastEthernet0/12
switchport mode access
switchport voice vlan 3
spanning-tree portfast
!
interface FastEthernet0/13
switchport mode access
switchport voice vlan 3
spanning-tree portfast
!
interface FastEthernet0/14
switchport mode access
switchport voice vlan 3
spanning-tree portfast
!
interface FastEthernet0/15
switchport mode access
switchport voice vlan 3
spanning-tree portfast
!
interface FastEthernet0/16
switchport mode access
switchport voice vlan 3
spanning-tree portfast
!
interface FastEthernet0/17
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/18
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/19
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/20
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/21
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/22
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/23
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/24
switchport access vlan 2
switchport mode access
spanning-tree portfast
spanning-tree guard root
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 10.2.100.1 255.255.255.0
!
interface Vlan2
no ip address
!
interface Vlan3
ip address 10.2.110.1 255.255.255.0

1 Accepted Solution

Accepted Solutions

Hi,

You don't need an IP helper address on the switch.

A IP phone send out a dhcp discover on de DATA vlan first.

So you have to move the vlan option, in your case option 191, to the DATA scope. The IP phone will see this option when it get's an IP address of the DATA scope. Then it will release the IP address and sends out a discover in the VOICE LAN. Then it will get an IP address of the VOICE scope and will recognoze option 128 to find out where the nortel systems are.

This is normal behaviour of an IP phone.

There are other techniqs to iplement IP phones on the network,Like LLDP-MEDfor example.

The IP  phone has to support those techniqs

HtH

Michel

View solution in original post

7 Replies 7

Reza Sharifi
Hall of Fame
Hall of Fame

Hi,

Since vlan 3 is your voice vlan, under this vlan add this command:

interface Vlan3
ip address 10.2.110.1 255.255.255.0

ip helper-address (address)

HTH

Reza

Hi:

What address in helper-address, i don't understand, it's not the helper-address for a external DHCP Server ?

Hi,

Find out your DHCP's IP address.  That would be the helper-address

Hi:

I want setup the dhcp server on my c3560.

!
ip dhcp pool voice
   network 10.2.110.0 255.255.255.0
    default-router 10.2.110.200
   option 191 ascii "VLAN-A:3"
    option 128 ascii "Nortel-i2004-A,10.2.100.200:4100,1,5."
   lease 0 2
!

The same switch will be the dhcp server

interface Vlan3
ip address 10.2.110.1 255.255.255.0

So which would be my helper-address i don't get it.

Hi,

You don't need an IP helper address on the switch.

A IP phone send out a dhcp discover on de DATA vlan first.

So you have to move the vlan option, in your case option 191, to the DATA scope. The IP phone will see this option when it get's an IP address of the DATA scope. Then it will release the IP address and sends out a discover in the VOICE LAN. Then it will get an IP address of the VOICE scope and will recognoze option 128 to find out where the nortel systems are.

This is normal behaviour of an IP phone.

There are other techniqs to iplement IP phones on the network,Like LLDP-MEDfor example.

The IP  phone has to support those techniqs

HtH

Michel

That's the way it works.

A lot of thanks..

Hi ,,

kindly could you advise me with the following :

-   my Equipment is :

   1- Cisco voice Router 2901 (IOS Version 15.0 and telephony version is 8.6)

    2- HP Managed Switch V1910-24G PoE(365W) JE007A

    3- Nortel ip Phones 1140e

my setting :

- On Cisco router :

     1- DHCP Pool :

ip dhcp pool KSA

network 192.168.1.0 255.255.255.0

default-router 192.168.1.200

option 150 ip 192.168.1.200

    2- Configure Extension :

voice register global

mode cme

source-address 192.168.1.200 port 5060

max-dn 20

max-pool 20

authenticate realm cisco.com

tftp-path flash:

create profile sync 0001040727941127

voice register dn  1

number 105

allow watch

name user

label user

voice register pool  1

registration-timer max 200 min 100

id mac 001B.252F.ECA9

number 1 dn 1

presence call-list

dtmf-relay rtp-nte

username 1112 password 1112

-  on ip Phone :

i give the ip phone ip address from the same router and determine Server1 as 192.168.1.200 which is Cisco router and 5060 port

- on HP Switch :

i make a voice Vlan (Vlan ID is 3) and connect all my eqiupment to this Vlan (Nortel ip Phone plus router plus cisco ip phones) 

my case is i need to connect the nortel ip phone 1140e to be as Extension from cisco routers.so can you help me plz??? is this way the right way???!!!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card