cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1754
Views
0
Helpful
7
Replies

C3750 prioritization based on dscp or cos values

steven.geerts
Level 1
Level 1

Hi I'm working on a catalyst c3750 and for my work i need to prioritize certain streams independent of their bandwith usage.

The streams are the following:

- voice

- video

- data

I created policy maps based on vlans like below:

policy-map VOICE

  class class-default

  set precedence 5

policy-map VIDEO

  class class-default

  set precedence 4

policy-map DATA

  class class-default

  set precedence 0

Based on these policy maps i configured the correct vlans so that they are marked with the correct settings.

interface vlan 100

description data

ip address 172.16.0.1 255.255.255.0

service-policy input DATA

end

interface vlan 101

description data

ip address 172.16.1.1 255.255.255.0

service-policy input VOICE

end

interface vlan 102

description data

ip address 172.16.2.1 255.255.255.0

service-policy input VIDEO

end

I set the interfaces to use vlan-based cos and this is working, i see all packets being marked with the cos bit set and the tos byte as well.

But know I need to find out how my data gets prioritized... I assume i need to configure the queues so that the one with higher priority are always in the highes queu and then going downards with different queues.  But i've been reading on this and i don't get it working by configuring the qeues.

I verify this by using a laptop with a 1Gb interface sending 3 streams with iperf (video,voice and data) to a 100mb laptop.  I send 100Mb of data, 5 mbit of voice and 20mbit of video.  Data should have a lot of lost packets and video and voice none!  But i can't get this working.

Anybody an idea of how to do this?

thanks

steven

7 Replies 7

Joseph W. Doherty
Hall of Fame
Hall of Fame

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_tech_note09186a0080883f9e.shtml

Hi Steven,

How do you verify it it not working? Can you post some sh mls interface int statistics, sh mls qos queue-set and

sh mls qos input?

You have to set egress queue per port basis.

Best regards,

Alex

EDIT: Joseph 's link is very helpful.

Hi

the problem with the link is that it's the about QoS in general.  Off course you need to finetune this according to the settings that I need specifically.  But there's just the problem...I can't seem to get it working for my use case and it's hard to find out where it goes wrong.

How I verify this?  I have 3 streams running from 1 client to another client with udp traffic being sent from A -> B.  A sends 3 streams of 5 Mb (simulating voice), 20 Mb (simulating video) and 85Mb (simulating data).  Because i'm oversending i should see lost packets but according to my settings voice and video should not be dropped.  Although this happens of course.

I will check with your commands to see if I have some more information for you!

thanks anyway for the help!

sg

Hi,

You perhaps should not see the drops in your ingress flow as there you have 1Gb.

Check with the commands and lets view the output.

Best regards,

Alex

Guys

thank you for your help already.  Today i had some time to check it and actually, it seems more or less working... More or less because sometimes i see on my vlan 102 some drops.

Gigabit interface is sending 100Mb of data (vlan 100), 10mb of voice (vlan 101)  and 20mb of video (vlan 102).  Sometimes i notice drops on my outgoing interface 3/0/1 which is the fastethernet one.  I think i have now to play with the queue settings, but what is the best approach for this?

The problem is as well that when I increase the bandwith of the voice and video throughputs, that i will see some drops there as well.  I off course know how much bandwith we're sending from our video , but for voice it can be 10 or either 100 calls together, but the bandwith is much less in this case...but I want to know what in case this traffic increases and we see drops on the outgoing interfaces????

thanks again!

the results:

sh mls qos interface gigabitEthernet 3/0/1    

GigabitEthernet3/0/1

trust state: not trusted

trust mode: not trusted

trust enabled flag: ena

COS override: dis

default COS: 0

DSCP Mutation Map: Default DSCP Mutation Map

Trust device: none

qos mode: vlan-based

FastEthernet3/0/1

trust state: not trusted

trust mode: not trusted

trust enabled flag: ena

COS override: dis

default COS: 0

DSCP Mutation Map: Default DSCP Mutation Map

Trust device: none

qos mode: vlan-based

switchsteven#show mls qos interface fastEthernet 3/0/1 statistics

FastEthernet3/0/1 (All statistics are in packets)

  dscp: incoming 

-------------------------------

  0 -  4 :         285            0            0            0           15 

  5 -  9 :           0            0            0            0            0 

10 - 14 :           0            0            0            0            0 

15 - 19 :           0            0            0            0            0 

20 - 24 :           0            0            0            0            0 

25 - 29 :           0            0            0            0            0 

30 - 34 :           0            0            0            0            0 

35 - 39 :           0            0        0            0            0 

40 - 44 :           0            0            0            0            0 

45 - 49 :           0            0            0            0            0 

50 - 54 :           0            0            0            0            0 

55 - 59 :           0            0            0            0            0 

60 - 64 :           0            0            0            0 

  dscp: outgoing

-------------------------------

  0 -  4 :    1035298         0            0            0            0 

  5 -  9 :           0            0        0            0            0 

10 - 14 :           0            0            0            0            0 

15 - 19 :           0            0            0            0            0 

20 - 24 :           0            0            0            0            0 

25 - 29 :           0            0            0            0            0 

30 - 34 :           0            0            0            0            0 

35 - 39 :           0            0            0            0            0 

40 - 44 :     2118728            0            0            0            0 

45 - 49 :           0            0            0       408587            0 

50 - 54 :           0            0            0            0            0 

55 - 59 :           0            0            0            0            0 

60 - 64 :           0            0            0            0 

  cos: incoming 

-------------------------------

  0 -  4 :         468            0            0            0            0 

  5 -  7 :           0            0            0 

  cos: outgoing

-------------------------------

  0 -  4 :    10380858          0            0            0            0 

  5 -  7 :     2118774       408606            2 

  output queues enqueued:

queue:    threshold1   threshold2   threshold3

-----------------------------------------------

queue 0:     2135886           0           0

queue 1:    10436595          30         426

queue 2:           0           0           0

queue 3:      417123           0         145

  output queues dropped:

queue:    threshold1   threshold2   threshold3

-----------------------------------------------

queue 0:         277           0           0

queue 1:     1982167           0           0

queue 2:           0           0           0

queue 3:       34331           0           0

Policer: Inprofile:            0 OutofProfile:            0

show mls qos interface gigabitEthernet 3/0/1 statistics

GigabitEthernet3/0/1 (All statistics are in packets)

  dscp: incoming 

-------------------------------

  0 -  4 :    10328367            0            0            0            0 

  5 -  9 :           0            0            0            0            0 

10 - 14 :           0            0            0            0            0 

15 - 19 :           0            0            0            0            0 

20 - 24 :           0                     0            0            0 

25 - 29 :           0            0            0            0            0 

30 - 34 :           0            0            0            0            0 

35 - 39 :           0            0            0            0            0 

40 - 44 :           0            0            0            0            0 

45 - 49 :           0            0            0            0            0 

50 - 54 :           0            0            0            0            0 

55 - 59 :           0            0            0            0            0 

60 - 64 :           0            0            0            0 

  dscp: outgoing

-------------------------------

  0 -  4 :           4            0            0            0            0 

  5 -  9 :           0            0            0            0            0 

10 - 14 :           0            0            0            0            0 

15 - 19 :           0            0            0            0            0 

20 - 24 :           0            0            0            0            0 

25 - 29 :           0            0            0            0            0 

30 - 34 :           0            0            0            0            0 

35 - 39 :           0            0            0            0            0 

40 - 44 :           3            0            0            0            0 

45 - 49 :           0            0            0            4            0 

50 - 54 :           0            0            0            0            0 

55 - 59 :           0            0            0            0            0 

60 - 64 :           0            0            0            0 

  cos: incoming 

-------------------------------

  0 -  4 :    10328557            0            0            0            0 

  5 -  7 :           0            0            0 

  cos: outgoing

-------------------------------

  0 -  4 :          56            0            0            0            0 

  5 -  7 :          33           24            0 

  output queues enqueued:

queue:    threshold1   threshold2   threshold3

-----------------------------------------------

queue 0:          34           0           0

queue 1:         112           0          62

queue 2:           0           0           0

queue 3:          25           0           6

  output queues dropped:

queue:    threshold1   threshold2   threshold3

-----------------------------------------------

queue 0:           0           0           0

queue 1:           0           0           0

queue 2:           0           0           0

queue 3:           0           0           0

Policer: Inprofile:            0 OutofProfile:            0

switchsteven#show mls qos queue-set

Queueset: 1

Queue     :       1       2       3       4

----------------------------------------------

buffers   :      25      25      25      25

threshold1:     100     200     100     100

threshold2:     100     200     100     100

reserved  :      50      50      50      50

maximum   :     400     400     400     400

Queueset: 2

Queue     :       1       2       3       4

----------------------------------------------

buffers   :      25      25      25      25

threshold1:     100     200     100     100

threshold2:     100     200     100     100

reserved  :      50      50      50      50

maximum   :     400     400     400     400

Queue     :       1       2

----------------------------------------------

buffers   :      20      80

bandwidth :      20      80

priority  :       0      20

threshold1:     100     100

threshold2:     100     100

Hi Steve,

You can use vlan based qos and then queue in the hardware. So basically you do all the marking/policing etc under the vlan and then push those dscp values into respective queues . The HW queue I believe WRR and you can assigh 1Priority queue and 3 normal queues.( I need to double check the number of queues). So, once you classify and mark the packets then they get pushed into the respecive queues and then the scheduler kicks in.

However the only condition to use mls qos vlan-based is that it can be used only on trunk ports

HTH

Regards,

Kishore

Steven, what is the output of "sh mls qos maps dscp-output-q"? I do not see voice signaling in the default egress queue location  - queue 3 threshold 1. What do you need to configure exactly? The egress QoS on 3750 require SRR config as Kishore suggested.

For more information please take a look at this document:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_52_se/configuration/guide/swqos.html

Best regards,

Alex

Review Cisco Networking products for a $25 gift card