Showing results for 
Search instead for 
Did you mean: 

C3850 switch will not save config on reboot


Having issues with my C3850 saving config to startup. I've tried a bare basic initial configuration, saved, and reloaded. No dice. I tried the ROMmon mode to check bootvar but it just says it does not recognize the command.

I Get this upon booting.

Interface GE 0 link down***ERROR: PHY link is down

Getting rest of image
Reading full image into memory...Check base package header ...: done = 16384
Getting rest of image
Reading full image into memory....done
Reading full base package into memory...: done = 83297376
Bundle Image
Kernel Address : 0x5342e34c
Kernel Size : 0x41884e/4294734
Initramfs Address : 0x53846b9c
Initramfs Size : 0xe778c3/15169731
Compression Format: .mzip

Bootable image at @ ram:0x5342e34c
Bootable image segment 0 address range [0x81100000, 0x82140000] is in range [0x80180000, 0x90000000].
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@boot_system: 377
Loading Linux kernel with entry point 0x8166a600 ...
Bootloader: Done loading app on core_mask: 0xf

### Launching Linux Kernel (flags = 0x5)

All packages are Digitally Signed
Starting System Services

FIPS(NGWC): Flash Key Check : Begin
FIPS(NGWC): Flash Key Check : End, Not Found, FIPS Mode Not Enabled
MCU type = 0 and image name is main_mcu_ucode_bundle_6_2_0.tar
Final tar file: main_mcu_ucode_bundle_6_2_0.tar


Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

cisco Systems, Inc.
170 West Tasman Drive
San Jose, California 95134-1706


Cisco IOS Software, IOS-XE Software, Catalyst L3 Switch Software (CAT3K_CAA-UNIVERSALK9-M), Version 03.06.05E RELEASE SOFTWARE (fc2)
Technical Support:
Copyright (c) 1986-2016 by Cisco Systems, Inc.
Compiled Thu 02-Jun-16 09:03 by prod_rel_team

Cisco IOS-XE software, Copyright (c) 2005-2015 by cisco Systems, Inc.
All rights reserved. Certain components of Cisco IOS-XE software are
licensed under the GNU General Public License ("GPL") Version 2.0. The
software code licensed under GPL Version 2.0 is free software that comes
with ABSOLUTELY NO WARRANTY. You can redistribute and/or modify such
GPL code under the terms of GPL Version 2.0.
( For more details, see the
documentation or "License Notice" file accompanying the IOS-XE software,
or the applicable URL provided on the flyer accompanying the IOS-XE



FIPS: Flash Key Check : Begin
FIPS: Flash Key Check : End, Not Found, FIPS Mode Not Enabled

This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

If you require further assistance please contact us by sending email to

cisco WS-C3850-48U (MIPS) processor with 4194304K bytes of physical memory.
Processor board ID FCW2022C1Y1
2048K bytes of non-volatile configuration memory.
4194304K bytes of physical memory.
250456K bytes of Crash Files at crashinfo:.
1609272K bytes of Flash at flash:.
0K bytes of Dummy USB Flash at usbflash0:.
0K bytes of at webui:.

Base Ethernet MAC Address : **:**:**:**:**:**
Motherboard Assembly Number : 73-15799-07
Motherboard Serial Number : ***********
Model Revision Number : AA0
Motherboard Revision Number : B0
Model Number : WS-C3850-48U
System Serial Number : ***********


--- System Configuration Dialog ---

Enable secret warning
In order to access the device manager, an enable secret is required
If you enter the initial configuration dialog, you will be prompted for the enable secret
If you choose not to enter the intial configuration dialog, or if you exit setup without setting the enable secret,
please set an enable secret using the following CLI in configuration mode-
enable secret 0 <cleartext password>
Would you like to enter the initial configuration dialog? [yes/no]:

27 Replies 27


If I haven't said it yet. Thank you folks for the assistance with my frustration.

also everything I did since last RELOAD in txt file

Thank you for the additional information. The text file with the various things you did was quite helpful. I was glad to see where you were setting the config register to 0x102 as suggested. But I was quite surprised to see where your attempts to remove ignore startupconfig turned into commands to enable that feature

Main(config)#system ignore startupconfig switch 1
Applying config on Switch 1...[DONE]

I request another attempt. Change the config register to 0x102 and then still in config mode try "no system ignore startupconfig switch 1". Save running config to startup config and reboot.



still not taking

Post the "sh run" and the complete output to the command "sh romvar".

both "commands are not supported on this platform"

see earlier post

How about "sh run" and "sh boot"?

sh boot woked here is txt

@marshel50 wrote:
Main(config)#system ignore startup-config switch 1


Why are you instructing the switch to ignore startup-config?  

I'm trying to get this thing to save a config. I'm no expert if anything I'm learning for a potential career change.

@marshel50 wrote:
*Sep 17 08:36:00.206: %GBIC_SECURITY_CRYPT-4-VN_DATA_CRC_ERROR: GBIC in port Te1/1/4 has bad crc
*Sep 17 08:36:00.206: Warning: SFP gbic-security check fail


so in the code to make it save a config

Main#copy running-config startup-config  =   save current config to startup

then to make sure its running:

Main(config)#system ignore startupconfig switch 1
Applying config on Switch 1...[DONE]
Main(config)#no system ignore startupconfig

because the second doesnt seem to work